Closed Bug 1175056 Opened 6 years ago Closed 5 years ago

Owncloud mail issue with e10S

Categories

(Firefox :: Untriaged, defect)

40 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 940206
Tracking Status
e10s m8+ ---

People

(Reporter: baudouin, Assigned: mrbkap, NeedInfo)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150615004003

Steps to reproduce:

Use the Owncloud Mail app in Firefox developer edition with e10s activated.


Actual results:

Javascript error that block the page while loading. This doesn't happen in non e10s window.

Here is the javascript error:

NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "aWindow.QueryInterface is not a function" {file: "resource://gre/modules/PrivateBrowsingUtils.jsm" line: 49}]'[JavaScript Error: "aWindow.QueryInterface is not a function" {file: "resource://gre/modules/PrivateBrowsingUtils.jsm" line: 49}]' when calling method: [nsIWebContentHandlerRegistrar::registerProtocolHandler]

This error is triggered by that line: https://github.com/owncloud/mail/blob/v0.1.3/js/mail.js#L303


Expected results:

The page should load normally.
Can you try with a new profile or with all of your add-ons disabled?
Flags: needinfo?(baudouin)
With a new profile the same error occurs.
The new profile have no add-ons so I suppose that with all add-ons disabled the same will occur.
Flags: needinfo?(baudouin)
Do I need to create a Owncloud account to test the mail app?
I can open an account for you on my instance, contact me directly by email.
IMHO, it would be nice to have a guest account, so Mozilla devs/triagers could test, especially when it will be fixed (if there is a bug).
I understand your point. I am not the mail app developer. I will contact him to see if it is possible to provide such an account. Meanwhile peoples who wants to test the mail app can contact me directly by email.
FYI: here is the related bug for Owncloud Mail app : https://github.com/owncloud/mail/pull/818
Duplicate of this bug: 1177098
Assignee: nobody → mrbkap
tracking-e10s: --- → m8+
Duplicate of this bug: 1176646
Duplicate of this bug: 1182233
Depends on: 940206
Duplicate of this bug: 1176646
Is this not exactly the same as bug 117098, now fixed?  It is the same error message.  Perhaps someone can test with a recent nightly.
Blocks: 1097530
Blocks: 1095484
Status: UNCONFIRMED → NEW
Component: Untriaged → Sync
Ever confirmed: true
AFAICT this is not related to Sync, moving it out of that component.
Component: Sync → Untriaged
@Reporter: Please confirm if this is still an issue? Can you also report your current Firefox version? 
[Firefox 42.0]

If applicable - Have you checked current Firefox DevEdition or the current Nightly build?
Flags: needinfo?(baudouin)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 940206
You need to log in before you can comment on or make changes to this bug.