The default bug view has changed. See this FAQ.

TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/unifiedcomplete/test_searchSuggestions.js | singleWordQuery - [singleWordQuery : 236] Got as many results as expected - 0 == 2

RESOLVED FIXED in Firefox 41

Status

Thunderbird
General
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Magnus Melin, Assigned: Magnus Melin)

Tracking

({intermittent-failure, regression})

Trunk
Thunderbird 41.0
intermittent-failure, regression

Firefox Tracking Flags

(firefox41 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

2 years ago
05:12:02  WARNING -  TEST-UNEXPECTED-FAIL | toolkit/components/places/tests/unifiedcomplete/test_searchSuggestions.js | singleWordQuery - [singleWordQuery : 236] Got as many results as expected - 0 == 2
05:12:02     INFO -      /builds/slave/test/build/tests/xpcshell/tests/toolkit/components/places/tests/unifiedcomplete/head_autocomplete.js:check_autocomplete:236
05:12:02     INFO -      self-hosted:InterpretGeneratorResume:715
05:12:02     INFO -      self-hosted:next:623
05:12:02     INFO -      _run_next_test@/builds/slave/test/build/tests/xpcshell/head.js:1460:9
05:12:02     INFO -      do_execute_soon/<.run@/builds/slave/test/build/tests/xpcshell/head.js:653:9
05:12:02     INFO -      _do_main@/builds/slave/test/build/tests/xpcshell/head.js:207:5
05:12:02     INFO -      _execute_test@/builds/slave/test/build/tests/xpcshell/head.js:513:5
05:12:02     INFO -      @-e:1:1
05:12:02     INFO -  exiting test
05:12:02     INFO -  Unexpected exception 2147500036
05:12:02     INFO -  undefined
05:12:02     INFO -  exiting test
05:12:02     INFO -  <<<<<<<

http://mxr.mozilla.org/comm-central/source/mozilla/toolkit/components/search/SearchSuggestionController.jsm#131
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 25

2 years ago
Must be from bug 1173751 (which added the test)
Blocks: 1173751
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
we added a local engine here, so we're not using defaults... why does that fail on comm-central?
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
There are tons of failures on each of these runs and test_searchSuggestions.js isn't even the first one, so why's this bug blaming them on it?  It sure looks like there's some bigger problem here.
(Assignee)

Comment 102

2 years ago
Because this particular test started showing up as a failure since bug 1173751 landed.
Yes, the comm-central tree is not exactly green atm... that's backlog from various m-c landings.
(Assignee)

Comment 103

2 years ago
Created attachment 8626925 [details] [diff] [review]
comm-central part

Ok so the problem here was we had browser.search.suggest.enabled false set. That was set in bug 1059192 not to cause failure since the pref didn't exist. It's now in all.js (since bug 1117158) so we don't need to keep it.
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #8626925 - Flags: review?(acelists)
(Assignee)

Comment 104

2 years ago
Created attachment 8626926 [details] [diff] [review]
mozilla-central part

Ensure the browser.search.suggest.enabled pref is enabled when running the test.
Attachment #8626926 - Flags: review?(adw)
(Assignee)

Comment 105

2 years ago
Created attachment 8626927 [details] [diff] [review]
mozilla-central part

really the mozilla-central part
Attachment #8626926 - Attachment is obsolete: true
Attachment #8626926 - Flags: review?(adw)
Attachment #8626927 - Flags: review?(adw)

Comment 106

2 years ago
Comment on attachment 8626925 [details] [diff] [review]
comm-central part

Review of attachment 8626925 [details] [diff] [review]:
-----------------------------------------------------------------

So this pref is not used in TB, we just added it as tests in toolkit used it? The pref was defined when the tests were running under Firefox but not under Thunderbird?
So if that is the case and we do not care what value we get from all.js in m-c (whether true or false), then the patch seems fine.
Thanks for investigating it.
Attachment #8626925 - Flags: review?(acelists) → review+
Comment on attachment 8626927 [details] [diff] [review]
mozilla-central part

Review of attachment 8626927 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks.
Attachment #8626927 - Flags: review?(adw) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 125

2 years ago
c-c: https://hg.mozilla.org/comm-central/rev/205059915763
Target Milestone: --- → Thunderbird 41.0

Comment 126

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/b632a8d62d45
https://hg.mozilla.org/mozilla-central/rev/b632a8d62d45
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.