TEST-UNEXPECTED-TIMEOUT | netwerk/test/unit_ipc/test_predictor_wrap.js | Test timed out

RESOLVED DUPLICATE of bug 1176612

Status

defect
RESOLVED DUPLICATE of bug 1176612
4 years ago
4 years ago

People

(Reporter: mkmelin, Unassigned)

Tracking

Trunk
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Maybe the same as bug 1176612. They started showing simultaneously.
From bug 959752.

12:05:53     INFO -  TEST-START | netwerk/test/unit_ipc/test_predictor_wrap.js
12:10:53  WARNING -  TEST-UNEXPECTED-TIMEOUT | netwerk/test/unit_ipc/test_predictor_wrap.js | Test timed out
12:10:53     INFO -  TEST-INFO took 300054ms
12:10:53     INFO -  >>>>>>>
12:10:53     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
12:10:53     INFO -  (xpcshell/head.js) | test pending (2)
12:10:53     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
12:10:53     INFO -  running event loop
12:10:53     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cc" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 1}]"
12:10:53     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Ci" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 2}]"
12:10:53     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cu" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 3}]"
12:10:53     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cr" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 4}]"
12:10:53     INFO -  "CONSOLE_MESSAGE: (info) [JavaScript Warning: "ReferenceError: assignment to undeclared variable _XPCSHELL_PROCESS" {file: "/builds/slave/test/build/tests/xpcshell/head.js" line: 1212}]"
12:10:53     INFO -  PROCESS | 1810 | Xlib:  extension "RANDR" missing on display ":0".
12:10:53     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
12:10:53     INFO -  (xpcshell/head.js) | test finished (2)
12:10:53     INFO -  netwerk/test/unit_ipc/test_predictor_wrap.js | Starting reset_predictor
12:10:53     INFO -  (xpcshell/head.js) | test reset_predictor pending (2)
12:10:53     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
12:10:53     INFO -  (xpcshell/head.js) | test run_next_test 1 pending (2)
12:10:53     INFO -  (xpcshell/head.js) | test reset_predictor finished (2)
12:10:53     INFO -  netwerk/test/unit_ipc/test_predictor_wrap.js | Starting test_link_hover
12:10:53     INFO -  (xpcshell/head.js) | test test_link_hover pending (2)
12:10:53     INFO -  (xpcshell/head.js) | test run_next_test 1 finished (2)
12:10:53     INFO -  TEST-PASS | netwerk/test/unit_ipc/test_predictor_wrap.js | verifier_maybe_run_next_test - [verifier_maybe_run_next_test : 76] true == true
12:10:53     INFO -  (xpcshell/head.js) | test run_next_test 2 pending (2)
12:10:53     INFO -  (xpcshell/head.js) | test test_link_hover finished (2)
12:10:53     INFO -  netwerk/test/unit_ipc/test_predictor_wrap.js | Starting test_pageload
12:10:53     INFO -  (xpcshell/head.js) | test test_pageload pending (2)
12:10:53     INFO -  TEST-PASS | netwerk/test/unit_ipc/test_predictor_wrap.js | test_pageload - [test_pageload : 140] 0 == 0
12:10:53     INFO -  (xpcshell/head.js) | test run_next_test 2 finished (2)
12:10:53     INFO -  <<<<<<<
12:10:53     INFO -  xpcshell return code: None
12:10:53     INFO -  netwerk/test/unit_ipc/test_predictor_wrap.js | Process still running after test!
12:10:53     INFO -  >>>>>>>
12:10:53     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
12:10:53     INFO -  (xpcshell/head.js) | test pending (2)
12:10:53     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
12:10:53     INFO -  running event loop
12:10:53     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cc" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 1}]"
12:10:53     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Ci" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 2}]"
12:10:53     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cu" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 3}]"
12:10:53     INFO -  "CONSOLE_MESSAGE: (warn) [JavaScript Warning: "TypeError: "Cr" is read-only" {file: "/builds/slave/test/build/tests/xpcshell/tests/netwerk/test/unit/test_predictor.js" line: 4}]"
12:10:53     INFO -  "CONSOLE_MESSAGE: (info) [JavaScript Warning: "ReferenceError: assignment to undeclared variable _XPCSHELL_PROCESS" {file: "/builds/slave/test/build/tests/xpcshell/head.js" line: 1212}]"
12:10:53     INFO -  PROCESS | 1810 | Xlib:  extension "RANDR" missing on display ":0".
12:10:53     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
12:10:53     INFO -  (xpcshell/head.js) | test finished (2)
12:10:53     INFO -  netwerk/test/unit_ipc/test_predictor_wrap.js | Starting reset_predictor
12:10:53     INFO -  (xpcshell/head.js) | test reset_predictor pending (2)
12:10:53     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
12:10:53     INFO -  (xpcshell/head.js) | test run_next_test 1 pending (2)
12:10:53     INFO -  (xpcshell/head.js) | test reset_predictor finished (2)
12:10:53     INFO -  netwerk/test/unit_ipc/test_predictor_wrap.js | Starting test_link_hover
12:10:53     INFO -  (xpcshell/head.js) | test test_link_hover pending (2)
12:10:53     INFO -  (xpcshell/head.js) | test run_next_test 1 finished (2)
12:10:53     INFO -  TEST-PASS | netwerk/test/unit_ipc/test_predictor_wrap.js | verifier_maybe_run_next_test - [verifier_maybe_run_next_test : 76] true == true
12:10:53     INFO -  (xpcshell/head.js) | test run_next_test 2 pending (2)
12:10:53     INFO -  (xpcshell/head.js) | test test_link_hover finished (2)
12:10:53     INFO -  netwerk/test/unit_ipc/test_predictor_wrap.js | Starting test_pageload
12:10:53     INFO -  (xpcshell/head.js) | test test_pageload pending (2)
Indeed, this is a dupe of bug 1176612.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1176612
You need to log in before you can comment on or make changes to this bug.