[e10s] width of dropdown list doesn't match the <select> element width on OS X/Linux (and theoretically some Windows)

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: gw280, Assigned: mconley)

Tracking

(Blocks: 1 bug, {polish})

Trunk
polish
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox41 affected)

Details

+++ This bug was initially created as a clone of Bug #1128159 +++

We allow dropdown widths to exceed the anchoring element if it is necessary to display the text in the dropdown. This is because the XUL menupopup has pretty large padding.

This bug is not particularly visible on Windows because menupopups don't have much padding there, and so we mostly match the width properly.
(Reporter)

Updated

3 years ago
Assignee: nobody → gwright
Assignee: gwright → mconley
I'm not convinced this is M8-worthy. Kicking out to triage.
tracking-e10s: m8+ → ?

Comment 2

3 years ago
this want for release if we can fit it in.
tracking-e10s: ? → +
Keywords: polish

Comment 3

3 years ago
er - "this is a want to fix before release if we can fit it in"
Now that we have M9 and M10, I guess based on comment 3 this maybe could fit into one of those.
tracking-e10s: + → ?
tracking-e10s: ? → +
Hi,

I couldn't reproduce this issue on the latest Aurora (46.0a2) using the testcase from Bug #1128159. I've tried to reproduce this on Windows 10, Windows 7, Ubuntu 14.04, Mac OS X 10.6.8 and 10.10.5 and in all cases the width of the dropdown menu properly fits the anchoring element.

Build ID    20160204004009
User Agent  Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
User Agent  Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
User Agent  Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
User Agent  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:46.0) Gecko/20100101 Firefox/46.0

Considering this I will mark this issue as Resolved-WFM.

Thanks,
Cipri
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.