Keyworded bookmarks have no favicon, title or bookmark-star in awesomebar-results

RESOLVED WONTFIX

Status

()

Firefox
Address Bar
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: Elbart, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8626989 [details]
Keyword-result: before - after

Set an unique keyword for any bookmark and enter it into the locationbar. The keyword is used a static shortcut, not as a way to use a search-engine.


Before the regression, the result for the keyword shows the title (not domain!) and the favicon. With unifiedcomplete turned off, title, favicon and the bookmark-star are shown.


After the regression, the result has no favicon, no star and shows the domain instead of the title.
With UC turned off, the favicon is there, but not the title or the star.


Regression-window, tested with forcing browser.urlbar.unifiedcomplete;true and false:

m-c:
Last good revision: e046475a75cb (2015-03-27)
First bad revision: ad587ca628cf (2015-03-28)
Pushlog:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e046475a75cb&tochange=ad587ca628cf

m-i:
Last good revision: aef75ff8a911
First bad revision: 44e454b5e93b
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=aef75ff8a911&tochange=44e454b5e93b

fx-team:
Last good revision: 08cef2ba28a0
First bad revision: e4496ef0ca0b
Pushlog:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=08cef2ba28a0&tochange=e4496ef0ca0b


e4496ef0ca0b	Marco Bonardo — Bug 1125117 - Use the new keywords API in autocomplete. r=ttaubert

Affected Versions:
39.0b and newer
(Reporter)

Updated

3 years ago
Component: Places → Location Bar
Product: Toolkit → Firefox
(Reporter)

Updated

3 years ago
Blocks: 1125117, 1071461
See Also: → bug 1178045
(Reporter)

Comment 1

3 years ago
Created attachment 8626990 [details]
keyword unifiedcomplete off.png
since keywords are no more bookmarks, it's expected they don't have a favicon nor a star. We'll just move the magnifier lens in bug 1178045.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

3 years ago
Why should mere shortcuts have a magnifier lens?
What about the title?
there's no title. keywords only have keyword, uri and eventually POST data.
btw, from your screenshot I see you are using keywords as aliases for uris, that's not their intended scope, keywords are intended to be used from "Add a Keyword For This Search". It works but still unintended functionality.

Updated

a year ago
See Also: → bug 1235645
You need to log in before you can comment on or make changes to this bug.