Closed Bug 1178385 Opened 5 years ago Closed 4 years ago

DXVA doesn't work on G41/G45

Categories

(Core :: Audio/Video: Playback, defect)

Unspecified
All
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla47
Tracking Status
firefox47 --- fixed

People

(Reporter: jrmuizel, Assigned: jrmuizel)

References

(Depends on 1 open bug)

Details

Attachments

(2 files, 1 obsolete file)

It is unclear why.
Component: Audio/Video → Audio/Video: Playback
Jeff, is this still an issue? Is DXVA blacklisted on G41/G45?
Flags: needinfo?(jmuizelaar)
So it looks like G45 is blacklisted here: https://dxr.mozilla.org/mozilla-central/source/widget/windows/GfxInfo.cpp#1100. This comes from bug 1155608. It would be nice if there was a pref to override the blacklist so that we could do testing to see what if anything is actually wrong with DXVA on the G45. 
On the G45 playing http://people.mozilla.org/~jmuizelaar/video/hobbit-23.9fps.mp4 in DXVAChecker uses 5-11% CPU. Playing it in FF gives 56% CPU

The G41 does not appear to be blacklisted, but gives false in about:support. It's not clear what's happening on the G41.
Flags: needinfo?(jmuizelaar)
So what do we need to do to resolve this?
Figure out if it's practical to use DXVA on the G45.
DXVA is disabled for the same reason as https://dxr.mozilla.org/mozilla-central/source/widget/windows/GfxInfo.cpp#1004 where the video reads back OK but doesn't composite correctly.
Attachment #8712330 - Flags: review?(ajones)
Comment on attachment 8712330 [details] [diff] [review]
Add a pref to force enable hw video decode

This patch doesn't seem to work for me.
Attachment #8712330 - Flags: review?(ajones)
(In reply to Jeff Muizelaar [:jrmuizel] from comment #8)
> Comment on attachment 8712330 [details] [diff] [review]
> Add a pref to force enable hw video decode
> 
> This patch doesn't seem to work for me.
Hmm, maybe disable this stupid dropped frames detector first?
https://bugzilla.mozilla.org/show_bug.cgi?id=1208415#c7
https://bugzilla.mozilla.org/show_bug.cgi?id=1198202#c6
https://bugzilla.mozilla.org/attachment.cgi?id=8656218&action=diff
This version actually works.
Attachment #8712330 - Attachment is obsolete: true
Attachment #8712820 - Flags: review?(milan)
Attachment #8712820 - Flags: review?(milan) → review+
We also have gfx.blocklist.all preference, which, when set to -1, will turn off all blocklisting.  That may not be what we need in this scenario, but I thought I'd mention it.
OS: Unspecified → All
https://hg.mozilla.org/mozilla-central/rev/52ad2fa6b79b
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Can you do hardware decoding on G41/G45 hardware now or are you still failing the self test and on the test page? 

http://people.mozilla.org/~ajones/blank-video/
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #15)
> Can you do hardware decoding on G41/G45 hardware now or are you still
> failing the self test and on the test page? 
> 
> http://people.mozilla.org/~ajones/blank-video/

DXVA works well on the G45 hardware. I've been running Youtube for most of the day without any issues. I've noticed a large drop in CPU usage on Vimeo (Youtube uses VP9 when without DXVA so isn't that comparable).

I can check out the G41 tomorrow.
The G41 doesn't support full H264 acceleration just IDCT+MoComp. I don't know if there's any easy way for us to use that support and it's probably not be worth the effort.
IIUC it isn't an intermittent issue. Can you reproduce the issue on the original offending version? It would be great to unblacklist it. You could also ask the original filer to test the latest nightly. Do you have reason to suspect that the issue has been fixed?
I can not reproduce the issue in FF38. Reading through the original bug 1155608 though it looks like the reporter could reproduce the problem even after the blacklist landed. This suggest that the blacklisting was didn't actually solve the problem and my suggestion is that we reduce it.
Comment on attachment 8715048 [details] [diff] [review]
Accept the latest driver on G45 for hardware video decoding.

Review of attachment 8715048 [details] [diff] [review]:
-----------------------------------------------------------------

I'm OK with this patch as is but I'd also accept a patch to remove this blacklist rule. It was blacklisted for a case that is now covered by our self test code.
Attachment #8715048 - Flags: review?(ajones) → review+
https://hg.mozilla.org/mozilla-central/rev/d9c33b851ac1
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.