MP3 podcast doesn't play, throws errer "could not be decoded"

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Playback
P2
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: donrhummy, Unassigned)

Tracking

(Depends on: 1 bug)

38 Branch
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150525141253

Steps to reproduce:

Tried to play MP3 podcast (via the HTML5 UI provided by the website): https://audioboom.com/boos/3327394-the-2015-tour-de-france-preview-show


Actual results:

It failed to play and the console shows:

    Media resource https://audioboom.com/boos/3327394-the-2015-tour-de-france-preview-show.mp3?smartclient=1 could not be decoded.

Attempting to play that mp3 directly in a tab results in the error: "Video can't be played because the content is corrupt"

However, downloading the MP3 and playing it in VLC works perfectly.


Expected results:

It should have played as VLC can play it on the same system.

Comment 1

2 years ago
Same here:
Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 Iceweasel/38.2.0
It seem this happens with all html5 mp3 audio, another example is SoundCloud.

Media resource https://cf-media.sndcdn.com/d0o4nFttGQPu.128.mp3?Policy=... could not be decoded.

Should I install some decoder to mozilla plugins? I expected mp3 as default.

Thanks

Comment 2

2 years ago
Probably duplicit of https://bugzilla.mozilla.org/show_bug.cgi?id=1149961
Marked as not high-enough priority there (
As I know, firefox does not support mp3 audio. To decode mp3 files, you have to install appropriate plugging. In my case, install gstreamer1.0-plugins-ugly would fix this.

Hope this helps.

Comment 4

2 years ago
Yes, thanks. In my case it was gstreamer0.10-plugins-ugly 0.10.19-2+b2 (oldstable) because otherwise I will have broken dependencies with other packages installed. However worked.

Ok, proven as platform specific.
(Reporter)

Comment 5

2 years ago
I still get an error:

    audio error occurred MediaError { code: 3 }
 20150508094354
 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 - Not Reproducible
 20150508094354
 Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 - Not Reproducible

Is anyone still experiencing this issue?
Please send your current platform and FF browser version.
Flags: needinfo?(donrhummy)
(Reporter)

Comment 7

2 years ago
(In reply to Michelle Funches - QA from comment #6)
>  20150508094354
>  Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 -
> Not Reproducible
>  20150508094354
>  Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0 - Not
> Reproducible
> 
> Is anyone still experiencing this issue?
> Please send your current platform and FF browser version.

Yes, it still happens on Linux (openSUSE 13.2), FF 42
Flags: needinfo?(donrhummy)
@Reporter - Thank you for response/details, I will schedule investigation for Linux openSUSE 13.2 x86_64
@Reporter - Audioboom video is playing without error for me using openSUSE 13.2-x86_64
Build ID 	20150508094354
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0

Please access Extensions in Firefox Troubleshooting Information - do you see the following?
Extensions
Name 	                        Version Enabled 	ID
openSUSE Firefox Extensions	1.0.2	true	susefox@opensuse.org
Flags: needinfo?(donrhummy)
(Reporter)

Comment 10

2 years ago
(In reply to Michelle Funches - QA from comment #9)
> @Reporter - Audioboom video is playing without error for me using openSUSE
> 13.2-x86_64
> Build ID 	20150508094354
> User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101
> Firefox/38.0
> 
> Please access Extensions in Firefox Troubleshooting Information - do you see
> the following?
> Extensions
> Name 	                        Version Enabled 	ID
> openSUSE Firefox Extensions	1.0.2	true	susefox@opensuse.org

I disabled the openSUSE extensions so that updating FF directly would not have any issues.
Flags: needinfo?(donrhummy)
@Reporter - Clarity request: did disabling the openSUSE extensions, help rectify the problem for you? Are you now able to successfully access and play Audioboom video while using openSUSE?
Flags: needinfo?(donrhummy)
(Reporter)

Comment 12

2 years ago
(In reply to Michelle Funches - QA from comment #11)
> @Reporter - Clarity request: did disabling the openSUSE extensions, help
> rectify the problem for you? Are you now able to successfully access and
> play Audioboom video while using openSUSE?

it did not fix it
Flags: needinfo?(donrhummy)

Updated

2 years ago
Component: Untriaged → Audio/Video
Product: Firefox → Core
Confirming the error still exist in openSUSE
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Audio/Video → Audio/Video: Playback
Blocks: 1208910, 1188676
Priority: -- → P2
No longer blocks: 1188676
Depends on: 1188676
(In reply to Michelle Funches - QA from comment #13)
> Confirming the error still exist in openSUSE

Try with nightly where gstreamer support is removed.
(Reporter)

Comment 15

2 years ago
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #14)
> (In reply to Michelle Funches - QA from comment #13)
> > Confirming the error still exist in openSUSE
> 
> Try with nightly where gstreamer support is removed.

It works with Nightly! I tried it on 46 and 47 and both play it correctly.
Thanks all,
I am updating to Resolved WFM, please add any additional notes and close when appropriate.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.