Closed Bug 1178787 Opened 5 years ago Closed 5 years ago

[meta] Add a Sync Now button

Categories

(Firefox for iOS :: Sync, defect)

All
iOS 8
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: rnewman, Assigned: bmunar)

References

(Blocks 1 open bug)

Details

(Whiteboard: [meta])

Attachments

(1 file)

PR
47 bytes, text/x-github-pull-request
nalexander
: feedback+
Details | Review
We'd love for things to be super mega automatic and seamless. But they're not, and folks need to test. So let's do this for now.

(Maybe this is already done in FxA?)
Blocking Bug 1168395 'cos this adds strings.

Robin: just "Sync now"? Sentence case or title case?
Blocks: ioscopy
Flags: needinfo?(randersen)
Assignee: nobody → bmunar
will work on right after finished with openInFirefox
what're your thoughts on this tecgirl? (for when you get back from pto hehe), do you have some mocks in mind?
:rnewman I prefer sentence case but UX needs to discuss it more. 
: bkmunar Note the timestamp, blue a-link color (I think this is iOS native, we can make it 'Firefox blue', will check with darrin), and that each section of that cell has a different action. See this: http://cl.ly/image/1x2o2J1u3n0g (the caret takes you to FxA)
Flags: needinfo?(randersen)
Won't this need strings?
:bkmunar after talking with Darrin, we're going with Title Case for "Sync Now". He also confirmed that we are using a custom blue for the tint-color, that is defined in UIConstants.swift (line 31).
Going to have someone review without timestamp and then issue a follow up bug (waiting for newman to get back from fun town)
Attached file PR
nalexander for the UI stuff
rnewman for the Sync stuff
Attachment #8631261 - Flags: review?(rnewman)
Attachment #8631261 - Flags: review?(nalexander)
Comment on attachment 8631261 [details] [review]
PR

This is reasonable work in progress, but I have questions:

1) the disclosure indicators seem wrong.  The account status shouldn't show a disclosure indicator when no action is required.  (I think you changed it to do so.)

2) the l10n should be the same as Synced Tabs.

3) I'm not confident `syncEverything() -> Success` is correct.  At the very least, rnewman should weight in -- we talked about aggregating Sync results differently.  I guess the real Sync's method must be `syncEverything() -> Success`; if it's good with Richard, it's good with me.
Attachment #8631261 - Flags: review?(nalexander) → feedback+
Oh, and: sorry for the delayed review.  I'm trying to catch up.
Depends on: 1183905, 1184700
Comment on attachment 8631261 [details] [review]
PR

Looks like Nick reviewed this.
Attachment #8631261 - Flags: review?(rnewman)
tracking-fxios: + → ---
Summary: Add a Sync Now button → [meta] Add a Sync Now button
Whiteboard: [meta]
There's a follow-up for styling (Bug 1210775) but I think this can be closed out.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.