Closed Bug 1178859 Opened 7 years ago Closed 6 years ago

test_browser_bookmark.py: "IOError: Connection to Marionette server is lost."

Categories

(Firefox OS Graveyard :: Gaia::UI Tests, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: onelson, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [319MB-Flame-Support])

Attachments

(2 files)

Description:
test_browser_bookmark.py is failing on multiple tracebacks today on Jenkins servers. When attempting to perform this test on local machines, the test does not timeout on occasion, making it difficult to pull consistent failures. Seems like it may be related to a memory issue on returning to homescreen (bug 1166449), as icons are not drawn on returning and there is a large delay in setting up the homescreen after attempting to add a bookmark. Scrolling down after the test "added" a bookmark revealed that no new bookmark is present.

* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk-319.mozilla-central.nightly.ui.functional.non-smoke.1.bitbar/132/HTML_Report/
* http://jenkins1.qa.scl3.mozilla.com/view/UI/job/flame-kk.ui.adhoc.bitbar/112/HTML_Report/

Tracebacks Final Line:
0) IOError: Connection to Marionette server is lost. Check gecko.log (desktop firefox) or logcat (b2g) for errors.inputWindow not interpreted as displayed. Debug is_displayed(): True, class: inputWindow top-most active.
2) IOError: Connection to Marionette server is lost. Check gecko.log (desktop firefox) or logcat (b2g) for errors.
3) IOError: Connection to Marionette server is lost. Check gecko.log (desktop firefox) or logcat (b2g) for errors.
4) Pass
5) IOError: Connection to Marionette server is lost. Check gecko.log (desktop firefox) or logcat (b2g) for errors.


Repro Steps:
1) Update a Flame to 20150629134017
2) Open the Browser app
3) Open webpage: 	self.test_url = self.marionette.absolute_url('mozilla.html')
4) Add to homescreen and change name
5) Return to homescreen

Actual:
Homescreen is revealed and test times out

Expected:
Bookmark is added to homescreen, renamed and deleted

Issue DOES NOT REPRODUCE manually

Traceback (most recent call last):
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_client-0.16-py2.7.egg/marionette/marionette_test.py", line 296, in run
testMethod()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/tests/functional/browser/test_browser_bookmark.py", line 33, in test_browser_bookmark
bookmark.type_bookmark_title(self.bookmark_title)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/apps/homescreen/regions/bookmark_menu.py", line 46, in type_bookmark_title
self.keyboard.send(value)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/apps/keyboard/app.py", line 252, in send
self._tap(val)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/tests/python/gaia-ui-tests/gaiatest/apps/keyboard/app.py", line 188, in _tap
Actions(self.marionette).press(key).release().perform()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 452, in perform
self.current_id = self.marionette._send_message('actionChain', 'value', chain=self.action_chain, nextId=self.current_id)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/decorators.py", line 36, in _
return func(*args, **kwargs)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_driver-0.9-py2.7.egg/marionette_driver/marionette.py", line 691, in _send_message
response = self.client.send(message)
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_transport-0.5-py2.7.egg/marionette_transport/transport.py", line 117, in send
response = self.receive()
File "/var/lib/jenkins/jobs/flame-kk.ui.adhoc.bitbar/workspace/.env/lib/python2.7/site-packages/marionette_transport-0.5-py2.7.egg/marionette_transport/transport.py", line 73, in receive
    raise IOError(self.connection_lost_msg)
IOError: Connection to Marionette server is lost. Check gecko.log (desktop firefox) or logcat (b2g) for errors.



Environmental Variables:
------------------------------
Device: Flame Master
Build ID: 20150629134017
Gaia: 27fe0f4261e3685187769411f2f74cff19287b19
Gecko: c26dbd63604d
Gonk: a4f6f31d1fe213ac935ca8ede7d05e47324101a4
Version: 42.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0
------------------------------

Repro frequency: 4/5 failing
Assignee: nobody → martijn.martijn
Ok, I can see this too and it happens manually for me once too. In that case, the "Edit bookmark" dialog just disappeared while typing in the input.
Attached file logcat.txt
This is a logcat of when this issue happens.
Works
Build ID               20150624010204
Gaia Revision          311c4e59936a407e64509f54fecb440d8a78e3c8
Gaia Date              2015-06-20 20:21:42
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/be81b8d6fae9
Gecko Version          41.0a1

Fails in:
Build ID               20150624080416
Gaia Revision          eb0d4aefa62b20420d6fa0642515a110daca5d97
Gaia Date              2015-06-24 01:48:14
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4cdc1a95a672
Gecko Version          41.0a1

https://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2015-06-22+12%3A00%3A42&enddate=2015-06-24+14%3A21%3A42
I guess that makes this a regression from bug 1144132, since an Activity window is involved here (which is lmk-ed) and bug 1178226 is a similar bug which was also caused by bug 1144132.

Gabriele, can  you take a look at this?
Assignee: martijn.martijn → nobody
Blocks: 1144132
Flags: needinfo?(gsvelto)
I started looking into this but I'm not sure how to reproduce this manually, which URL am I supposed to use for step 3 in comment 0? Not clearing my NI until I can reproduce this myself.
Flags: needinfo?(martijn.martijn)
1) You have to use the latest engineering build on the Flame, using 319MB internally.
2) Open the Browser app
3) Open webpage, any webpage will do, e.g. http://google.com (but a more memory intensive site will increase the likelyhood, I think. It happened a lot with me, using http://nu.nl )
4) Add to homescreen and change name

Result:
- While trying to change the name, the "Add to Home" activity will suddenly disappear.
Flags: needinfo?(martijn.martijn)
OK, I've managed to understand why this is happening. For some reason the browser app is not being marked as an activity opener, this causes the priority of it to drop far enough that it's getting killed by the LMK. I'm now trying to figure out why the normal mechanism used to mark activities is failing.
Flags: needinfo?(gsvelto)
(In reply to Autolander from comment #7)
> Created attachment 8632061 [details] [review]
> [gaia] mwargers:1178859_disable > mozilla-b2g:master

Merged: https://github.com/mozilla-b2g/gaia/commit/fd4112427f6fbd289cca1479f7b3af9b91427b49
This test is disabled for now (until this bug gets fixed).
Depends on: 1182457
Filed bug 1182457 to track the root cause of this issue.
QA Whiteboard: [memory-failure]
Whiteboard: [319MB-Flame-Support]
We now have browser pinning and a test for that will be written in bug 1217404.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.