Crash on retrieving Gecko profile

RESOLVED FIXED in Firefox 42

Status

()

Core
Gecko Profiler
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: snorp, Assigned: snorp)

Tracking

41 Branch
mozilla42
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox42 fixed)

Details

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #1167230 +++

STR:
1. Install Gecko Profiler add-on.
2. Connect to Android device via USB.
3. Press "Analyze" in the add-on to retrieve the profile.

Expected: Profile is retrieved and displayed.
Actual: Fennec crashes (see stack trace), no profile is being retrieved.

Workaround: Removing mUniqueStacks.reset() in ThreadProfile::StreamJSON prevents the crash.
We lost one of the fixes in bug 1167230 when the standalone stuff happened
Created attachment 8627859 [details] [diff] [review]
Restore the std::string fix from bug 1167230
Attachment #8627859 - Flags: review?(bgirard)
Comment on attachment 8627859 [details] [diff] [review]
Restore the std::string fix from bug 1167230

Review of attachment 8627859 [details] [diff] [review]:
-----------------------------------------------------------------

Blahhh. This is terrible :(

But thanks for doing this, not your fault!
Attachment #8627859 - Flags: review?(bgirard) → review+
Duplicate of this bug: 1178647

Comment 5

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/1ba35f411eee
https://hg.mozilla.org/mozilla-central/rev/1ba35f411eee
Assignee: nobody → snorp
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Duplicate of this bug: 1154851
You need to log in before you can comment on or make changes to this bug.