Closed Bug 1179408 Opened 6 years ago Closed 6 years ago

Alias -webkit-animation* CSS properties

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 837211

People

(Reporter: miketaylr, Unassigned)

References

(Blocks 1 open bug)

Details

We should alias the following -webkit- prefixed CSS animation properties to their standards equivalents (either via CSS Unprefixing or otherwise) in Gecko.

-webkit-animation
-webkit-animation-delay
-webkit-animation-direction
-webkit-animation-duration
-webkit-animation-fill-mode
-webkit-animation-iteration-count
-webkit-animatio-name
-webkit-animation-play-state
-webkit-animation-timing-function

Source <https://docs.google.com/spreadsheets/d/173d1p3LkW_LWk-VMnrxGPhTobtKSpED30Fys5ZJLttA/edit?pli=1#gid=51341101>
Blocks: 1170789
See Also: → 1132754
Presumably "@-webkit-keyframes" would be needed here, too.
Duplicate of this bug: 1132754
Yeah, that too. Thx
This is fixed by Bug 837211. See Bug 1213126 to track enabling these by default. 

(Flip layout.css.prefixes.webkit to true for testing)
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 837211
You need to log in before you can comment on or make changes to this bug.