Addresses Disappear when scrolling addressing widget

VERIFIED FIXED in mozilla0.9.8

Status

MailNews Core
Composition
P1
blocker
VERIFIED FIXED
16 years ago
9 years ago

People

(Reporter: scottputterman, Assigned: David Hyatt)

Tracking

({regression})

Trunk
mozilla0.9.8
x86
Windows 2000
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
I'm using this morning's build: 2002010303 on Win 2000.

Open the compose window.
Type in enough email addresses to cause it to scroll.
Scroll back up.
Email addresses have disappeared.  

I've also noticed that I see them disappear from the bottom.

I don't know if they are still there, but invisible, because I haven't tried
sending a message yet.

I'm also using the recycled compose window.  I don't know if that makes any
difference.
(Reporter)

Updated

16 years ago
Severity: normal → blocker
Status: NEW → ASSIGNED
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9.8
(Reporter)

Comment 1

16 years ago
The good news is that it appears to send it to the ones that are missing.  So it
looks like they are just invisible.  I'm still leaving as a blocker since I
don't feel comfortable sending emails to addresses I can't see, even if they do
get sent.
This is a very very bad and scary regression.
Keywords: regression, smoketest

Comment 3

16 years ago
I was using a build from 2001-12-21-06 (Win32) and saw this problem so I'm not
sure if this is a new regression.
I don't see this on a recent Linux build (CVS tip from around 2002/01/01).
Is it Win2k-only? Does it only happen with the recycled compose window?

Comment 5

16 years ago
my checkin was to remove some unused variables; removing myself from cc list

p.s.  Personally I disagree that this is a smoketest bug but I do agree that it
is a very serious regression that should be investigated and fixed ASAP.
i don't see this on today's MacOS 9 mozilla bits in either classic or modern.
lower to critical...
Severity: blocker → critical
Keywords: smoketest
oops, looks like my early comment doesn't make it. Again:

This problem occurs on my MacOS X debug build from today but not on my Window
debug build from Tuesday night. However, I can reproduce this problem on MacOS X
using a release build from December 27. Therfore it's an "old" regression, don't
need to keep the tree close for it!

Comment 9

16 years ago
I could not repro this on 2002-01-03 build on win98
Using MacOS X release builds, I found that the regression has been introduced
between 12/18-04 and 12/19-04.
I can always reproduce the problem under MacOS X but it's not consistent under
Windows! The regression seems to have been caused by the Hewitt rewrite or the
theme. Joe, David, can you take a look at it?

Comment 12

16 years ago
I'm able to repro this on win2k easily, so hopefully I can figure this out shortly
(Reporter)

Comment 13

16 years ago
Any luck on this?  Unfortunately, when you get into this state, future entries
don't autocomplete. So, I've already seen a case of unsent mail because someone
typed in something like "John Smith" and ended up sending it to
john@netscape.com and smith@netscape.com.  This really is a blocker for mail.
Severity: critical → blocker
hewitt promise me yesterday to send me a patch for testing, still waiting...
*** Bug 119123 has been marked as a duplicate of this bug. ***
here's something I've observed:

when I get into this state, if I make the window wider, the text starts to show 
up.

it's as if the text is in a box that a fixed percentage. 

I'll attach a screen shot, and see what the dom inspector tells me.
(Assignee)

Comment 17

16 years ago
This bug was around earlier, and it was caused by a <popupset> being given
width.  I added an !important rule to autocomplete.css that fixed this problem,
and that rule disappeared after hewitt's landing I think.
Created attachment 64335 [details]
screen shot

those addresses are supposed to be:

putterman@netscape.com
jglick@netscape.com
Dan Mosedale <dmose@netscape.com>
Rajiv Dayal <rdayal@netscape.com>
Srilatha Moturi <srilatha@netscape.com>

note, when I select a partial address, copy and paste, it gets the whole thing.
(Assignee)

Comment 19

16 years ago
This is definitely the exact same bug that I had before.  Bug 96899.  Note that
the fix for that bug was removed.
testing out dave's fix for that other bug again, verifying it fixes this.

if it does, I'll land it.

thanks hyatt!
Created attachment 64354 [details] [diff] [review]
hyatt's patch, again.
over to hyatt.

dave, I'll land this for you when the tree is open.

thanks for the heads up about the original bug.
Assignee: ducarroz → hyatt
Status: ASSIGNED → NEW
(Assignee)

Comment 23

16 years ago
Did it work?
yes, it worked.
fixed.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 26

16 years ago
Verified on today's build that the address does not disappear when scrolling the 
addressing widget. However, we do crash when we scroll the addressing widget 
which is bug 110165.

verifying this bug that address does not disappear anymore while scrolling. 
build id:  2002-01-14-06 win98, Mac os x, linux
Status: RESOLVED → VERIFIED
(Reporter)

Comment 27

16 years ago
*** Bug 117129 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.