Closed Bug 1180298 Opened 5 years ago Closed 5 years ago

Populate about:newtab iframe with remotely fetched newtab layout and injected user data

Categories

(Firefox :: New Tab Page, defect)

40 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1183206

People

(Reporter: emtwo, Unassigned)

References

(Blocks 1 open bug)

Details

about:newtab will be a simple page that consists solely of an iframe. When a user opens about:newtab, the iframe will be populated with the pre-fetched layout and user data (frecent sites, a suggested tile, etc.).

This will be very similar to the way about:healthreport is displayed: 
https://dxr.mozilla.org/mozilla-central/source/browser/base/content/abouthealthreport/abouthealth.js#15
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1183206
You need to log in before you can comment on or make changes to this bug.