Closed Bug 1181238 Opened 5 years ago Closed 5 years ago

Navigating to a new URL while focused on a text field breaks browser layout

Categories

(Firefox for iOS :: Browser, defect)

All
iOS
defect
Not set
major

Tracking

()

RESOLVED FIXED
Tracking Status
fxios + ---

People

(Reporter: bnicholson, Assigned: bmunar)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

PR
47 bytes, text/x-github-pull-request
bnicholson
: review+
fluffyemily
: feedback+
Details | Review
STR:
1) Go to google.com.
2) Tap the search text field.
3) Tap the URL bar and navigate to another URL.

After these steps, a bunch of SnapKit errors appear in the log, the toolbar floats to the middle of the screen, and scrolling is broken.
Severity: normal → major
Keywords: reproducible
Assignee: nobody → bmunar
Think I know the problem since this also happens:

STR:
1) Go to yahoo.com
2) Tap the search text field.
3) Tap the URL bar, cancel, then same error happens
Attached file PR
Attachment #8633312 - Flags: review?(bnicholson)
Comment on attachment 8633312 [details] [review]
PR

Still breaks in a number of other situations as pointed out. Rather than trying to hide the input switcher, we should figure out why the input switcher is breaking constraints to begin with.
Attachment #8633312 - Flags: review?(bnicholson) → review-
Changed it!
Also, emily wrote the function so she will add some backup review
Attachment #8633312 - Flags: review?
Attachment #8633312 - Flags: review-
Attachment #8633312 - Flags: feedback?(etoop)
Blocks: 1168490
Keywords: regression
Attachment #8633312 - Flags: review? → review?(bnicholson)
Comment on attachment 8633312 [details] [review]
PR

Nice fix! Looks good to me with a suggestion in the PR.
Attachment #8633312 - Flags: review?(bnicholson) → review+
Attachment #8633312 - Flags: review+ → review?(bnicholson)
Attachment #8633312 - Flags: review?(bnicholson) → review+
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1183080
You need to log in before you can comment on or make changes to this bug.