Intermittent test_browserElement_oop_AppWindowNamespace.html | application crashed [@ nsFrameMessageManager::DispatchAsyncMessageInternal(JSContext *,nsAString_internal const &,mozilla::dom::StructuredCloneData const &,JS::Handle<JSObject *>,nsIPrincipal

RESOLVED FIXED in Firefox 42

Status

()

Core
DOM: Content Processes
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: RyanVM, Assigned: Yoric)

Tracking

(Blocks: 1 bug, {crash, intermittent-failure})

Trunk
mozilla42
crash, intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s+, firefox40 unaffected, firefox41 unaffected, firefox42 fixed, firefox-esr31 unaffected, firefox-esr38 unaffected)

Details

(Reporter)

Description

3 years ago
10:06:10 WARNING - PROCESS-CRASH | Main app process exited normally | application crashed [@ nsFrameMessageManager::DispatchAsyncMessageInternal(JSContext *,nsAString_internal const &,mozilla::dom::StructuredCloneData const &,JS::Handle<JSObject *>,nsIPrincipal *)]
10:06:10 INFO - Crash dump filename: c:\users\cltbld\appdata\local\temp\tmpzvw9_k.mozrunner\minidumps\f423216e-5a45-44e8-868e-599063af6a4a.dmp
10:06:10 INFO - Operating system: Windows NT
10:06:10 INFO - 6.1.7601 Service Pack 1
10:06:10 INFO - CPU: x86
10:06:10 INFO - GenuineIntel family 6 model 30 stepping 5
10:06:10 INFO - 8 CPUs
10:06:10 INFO - Crash reason: EXCEPTION_ACCESS_VIOLATION_READ
10:06:10 INFO - Crash address: 0x5a5a5a66
10:06:10 INFO - Assertion: Unknown assertion type 0x00000000
10:06:10 INFO - Thread 0 (crashed)
10:06:10 INFO - 0 xul.dll!nsFrameMessageManager::DispatchAsyncMessageInternal(JSContext *,nsAString_internal const &,mozilla::dom::StructuredCloneData const &,JS::Handle<JSObject *>,nsIPrincipal *) [nsFrameMessageManager.cpp:b2709be0bee3 : 804 + 0x11]
10:06:10 INFO - eip = 0x6467dc9c esp = 0x0034aaf8 ebp = 0x0034ab0c ebx = 0x00000002
10:06:10 INFO - esi = 0x00000001 edi = 0x06b5d6e0 eax = 0x5a5a5a5a ecx = 0x04ac2d8c
10:06:10 INFO - edx = 0x02a08400 efl = 0x00010202
10:06:10 INFO - Found by: given as instruction pointer in context
10:06:10 INFO - 1 xul.dll!nsFrameMessageManager::DispatchAsyncMessageInternal(JSContext *,nsAString_internal const &,mozilla::dom::StructuredCloneData const &,JS::Handle<JSObject *>,nsIPrincipal *) [nsFrameMessageManager.cpp:b2709be0bee3 : 798 + 0x1d]
10:06:10 INFO - eip = 0x6467dc58 esp = 0x0034ab14 ebp = 0x0034ab34
10:06:10 INFO - Found by: call frame info
10:06:10 INFO - 2 xul.dll!nsFrameMessageManager::DispatchAsyncMessage(nsAString_internal const &,JS::Value const &,JS::Value const &,nsIPrincipal *,JSContext *,unsigned char) [nsFrameMessageManager.cpp:b2709be0bee3 : 835 + 0x12]
10:06:10 INFO - eip = 0x6467dbf8 esp = 0x0034ab3c ebp = 0x0034ab98
10:06:10 INFO - Found by: call frame info
10:06:10 INFO - 3 xul.dll!nsFrameMessageManager::BroadcastAsyncMessage(nsAString_internal const &,JS::Handle<JS::Value>,JS::Handle<JS::Value>,JSContext *,unsigned char) [nsFrameMessageManager.cpp:b2709be0bee3 : 864 + 0x1b]
10:06:10 INFO - eip = 0x6467d179 esp = 0x0034aba0 ebp = 0x0034abb8
10:06:10 INFO - Found by: call frame info
10:06:10 INFO - 4 xul.dll!NS_InvokeByIndex [xptcinvoke.cpp:b2709be0bee3 : 70 + 0x2]
10:06:10 INFO - eip = 0x63c87654 esp = 0x0034abc0 ebp = 0x0034abec
10:06:10 INFO - Found by: call frame info
10:06:10 INFO - 5 xul.dll!CallMethodHelper::Invoke() [XPCWrappedNative.cpp:b2709be0bee3 : 2080 + 0xe]
10:06:10 INFO - eip = 0x642c6821 esp = 0x0034abf4 ebp = 0x0034ac18
10:06:10 INFO - Found by: call frame info
10:06:10 INFO - 6 xul.dll!CallMethodHelper::Call() [XPCWrappedNative.cpp:b2709be0bee3 : 1417 + 0x6]
10:06:10 INFO - eip = 0x642b9744 esp = 0x0034ac08 ebp = 0x0034ac18
10:06:10 INFO - Found by: call frame info
10:06:10 INFO - 7 xul.dll!XPCWrappedNative::CallMethod(XPCCallContext &,XPCWrappedNative::CallMode) [XPCWrappedNative.cpp:b2709be0bee3 : 1384 + 0x11]
10:06:10 INFO - eip = 0x642b9818 esp = 0x0034ac20 ebp = 0x0034acf0
10:06:10 INFO - Found by: call frame info
10:06:10 INFO - 8 xul.dll!js::jit::EffectlesslyLookupProperty [BaselineIC.cpp:b2709be0bee3 : 2692 + 0x1b]
10:06:10 INFO - eip = 0x668720bc esp = 0x0034ac28 ebp = 0x0034acf0
10:06:10 INFO - Found by: stack scanning
10:06:10 INFO - 9 xul.dll!XPC_WN_CallMethod(JSContext *,unsigned int,JS::Value *) [XPCWrappedNativeJSOps.cpp:b2709be0bee3 : 1144 + 0xc]
10:06:10 INFO - eip = 0x642ceac5 esp = 0x0034acf8 ebp = 0x0034adc4
10:06:10 INFO - Found by: call frame info
Comment hidden (Treeherder Robot)

Updated

3 years ago
Blocks: 984139
tracking-e10s: ? → +
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 14

3 years ago
This seems to be spiking lately. Can we please get someone to investigate?
Flags: needinfo?(kchen)
OS: Windows 7 → All
Hardware: x86 → All
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Yes, I was looking at this. I was unable to reproduce at the first attempt though.
Assignee: nobody → kchen
Flags: needinfo?(kchen)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

3 years ago
Duplicate of this bug: 1185146
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 57

3 years ago
This is frequent enough that I'm strongly considering skipping the entire dom/browser-element/mochitest/ directory until the issue is fixed or the regressor is backed out.
(Reporter)

Comment 58

3 years ago
I'm suspecting bug 1174733 as the cause of this otherwise.
(Reporter)

Comment 59

3 years ago
Actually, the first instance on fx-team was right after a merge that included Bug 1113086. Also seems plausible.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Backing out bug 1175098 makes the try greenish.
Flags: needinfo?(ryanvm)
(Reporter)

Updated

3 years ago
Flags: needinfo?(ryanvm) → needinfo?(dteller)
If I read this correctly, this is a crash in the content process. If so, I'm almost sure that this is caused by bug 1184115. I have a workaround in bug 1175098, which is apparently not sufficient, and a better workaround bug 1184486, so we'll try the latter.
Flags: needinfo?(dteller)
Assignee: kchen → nobody
Duplicate of this bug: 1185718
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Updated

3 years ago
Depends on: 1184486
(Reporter)

Comment 87

3 years ago
(In reply to David Rajchenbach-Teller [:Yoric] (use "needinfo") from comment #79)
> If I read this correctly, this is a crash in the content process. If so, I'm
> almost sure that this is caused by bug 1184115. I have a workaround in bug
> 1175098, which is apparently not sufficient, and a better workaround bug
> 1184486, so we'll try the latter.

If we can land bug 1184486 today, that'll work. Otherwise, I'm inclined to backout given the frequency. The Try run looks green.
Comment hidden (Treeherder Robot)
(Reporter)

Updated

3 years ago
Blocks: 1175098
status-firefox40: --- → unaffected
status-firefox41: --- → unaffected
status-firefox-esr31: --- → unaffected
status-firefox-esr38: --- → unaffected
No longer depends on: 1184486
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 101

3 years ago
Initial results on fx-team with the follow-up from bug 1175098 are looking very promising. I'm needinfo?ing myself to double-check this tomorrow once it's been merged around and things have had a chance to cycle.
Flags: needinfo?(ryanvm)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 105

3 years ago
Victory \m/
Assignee: nobody → dteller
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox42: affected → fixed
Flags: needinfo?(ryanvm)
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
You need to log in before you can comment on or make changes to this bug.