System partition size should be updated

RESOLVED FIXED in FxOS-S3 (24Jul)

Status

Firefox OS
GonkIntegration
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: gerard, Assigned: gerard)

Tracking

unspecified
FxOS-S3 (24Jul)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
As documented in bug 1085230 comment 12, we should use 439877632 (419.5*1024*1024).
(Assignee)

Comment 1

2 years ago
Created attachment 8635324 [details] [review]
Flame KK PR

The size of 419.5 comes from the output of gdisk on the gpt_bothO_big.bin.
Attachment #8635324 - Flags: review?(mwu)
Attachment #8635324 - Flags: feedback?(nhirata.bugzilla)
(Assignee)

Updated

2 years ago
Target Milestone: --- → FxOS-S3 (24Jul)

Comment 2

2 years ago
Comment on attachment 8635324 [details] [review]
Flame KK PR

Slightly concerned about people getting confused from this..
Attachment #8635324 - Flags: review?(mwu) → review+
We placed in the partitioning in the partition sector, we had not updated the system partition size; hence we still had the issue in bug 1181372

Made a build and flashed it.  Build is located here:
https://drive.google.com/a/mozilla.com/file/d/0B_0LdM1CVycIdWRLdUJkQ2lXb3c/view?usp=sharing
You will need the latest contributor build flashed first : http://bit.ly/1NWi45L

Output of adb shell df /system
Filesystem               Size     Used     Free   Blksize
/system                412.5M   209.5M   203.0M   4096
Comment on attachment 8635324 [details] [review]
Flame KK PR

see https://bugzilla.mozilla.org/show_bug.cgi?id=1184980#c3
Attachment #8635324 - Flags: feedback?(nhirata.bugzilla) → feedback+
(Assignee)

Comment 5

2 years ago
https://github.com/mozilla-b2g/device-flame/commit/41d3e221039d1c4486fc13ff26793a7a39226423
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

2 years ago
Chris, I think we should make it clear on MDN that users without the proper partitionning will not be able to flash system.img now :).

The error they will get is:
> Flashing out/target/product/flame/system.img failed because the image was too large.

They should update base image in this case.
Flags: needinfo?(cmills)
(In reply to Alexandre LISSY :gerard-majax from comment #6)
> Chris, I think we should make it clear on MDN that users without the proper
> partitionning will not be able to flash system.img now :).
> 
> The error they will get is:
> > Flashing out/target/product/flame/system.img failed because the image was too large.
> 
> They should update base image in this case.

Ok, so I've added a note to cover this at the bottom of the following section of the Flame guide:

https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/Updating_your_Flame#Updating_your_Flame_to_a_nightly_build

Is this ok?
Flags: needinfo?(cmills)
(Assignee)

Comment 8

2 years ago
That looks good to me :) Thanks !
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1189333

Comment 10

2 years ago
I encountered a weird case. Bug 1214298. FYI.
You need to log in before you can comment on or make changes to this bug.