Nightly update adb push fails & device fails to boot

RESOLVED WORKSFORME

Status

defect
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: davross, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:39.0) Gecko/20100101 Firefox/39.0
Build ID: 20150630154324

Steps to reproduce:

Using nightly build from https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/latest-mozilla-central-flame-kk/

adb push fails and Flame fails to boot. This also reproduced after a fresh base image. Did stable first then the nightly. Phone started each time and I skip through wizard, finally enabling developer option and select the dual adb option in the dev menu. (can't recall the name as well.. the screen's black hey)


Actual results:

PANIC. Black screen. Reboot phone & Thundersoft logo comes up but returns to black screen.


Expected results:

No panic.

Seeking the previous version so I can reinstate but boy that ftp list is LONG. I might need help on that actually. Can anyone point me to an ftp for the Flame prior to this error, 17 or 16 July for example?
Reporter

Comment 1

4 years ago
OK just done a shallow flash using the image from 16 July and same error:
### Failed: Pushing Gaia to device failed.
Gone back to flash nightly base image and phone again boots fine into the ffos wizard.
Started the shallow flash to push gaia and gecko FAILS. Yes the dev menu & adb tool enabled before I try.

Going to try 15 July image.
Reporter

Comment 2

4 years ago
The nightly build from 15 July this time also FAILS.
Copied the console print through:

[removed the gecko portion as it seems to be fine]
### Push Done.
### Processing Gaia: gaia.zip
### Unzip gaia.zip to /tmp/shallowflashgaia.TF6JkMjDcd0K ...
### Cleaning Gaia and Profiles ...
rm failed for /data/local/storage/persistent/*, No such file or directory
rm failed for /data/local/svoperapps, No such file or directory
rm failed for /data/local/user.js, No such file or directory
rm failed for /data/local/OfflineCache, No such file or directory
rm failed for /data/local/indexedDB, No such file or directory
### Cleaning Done.
### Pushing Gaia to device ...
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/clock.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/clock.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/clock.gaiamobile.org/application.zip -> /system/b2g/webapps/clock.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/keyboard.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/keyboard.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/keyboard.gaiamobile.org/application.zip -> /system/b2g/webapps/keyboard.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/calendar.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/calendar.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/calendar.gaiamobile.org/application.zip -> /system/b2g/webapps/calendar.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/bluetooth.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/bluetooth.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/bluetooth.gaiamobile.org/application.zip -> /system/b2g/webapps/bluetooth.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/pdfjs.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/pdfjs.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/pdfjs.gaiamobile.org/application.zip -> /system/b2g/webapps/pdfjs.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/camera.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/camera.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/camera.gaiamobile.org/application.zip -> /system/b2g/webapps/camera.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/video.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/video.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/video.gaiamobile.org/application.zip -> /system/b2g/webapps/video.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/sms.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/sms.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/sms.gaiamobile.org/application.zip -> /system/b2g/webapps/sms.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/music.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/music.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/music.gaiamobile.org/application.zip -> /system/b2g/webapps/music.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/wappush.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/wappush.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/wappush.gaiamobile.org/application.zip -> /system/b2g/webapps/wappush.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/marketplace.firefox.com/update.webapp -> /system/b2g/webapps/marketplace.firefox.com/update.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/marketplace.firefox.com/application.zip -> /system/b2g/webapps/marketplace.firefox.com/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/emergency-call.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/emergency-call.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/emergency-call.gaiamobile.org/application.zip -> /system/b2g/webapps/emergency-call.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/operatorvariant.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/operatorvariant.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/operatorvariant.gaiamobile.org/application.zip -> /system/b2g/webapps/operatorvariant.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/ringtones.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/ringtones.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/ringtones.gaiamobile.org/application.zip -> /system/b2g/webapps/ringtones.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/network-alerts.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/network-alerts.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/network-alerts.gaiamobile.org/application.zip -> /system/b2g/webapps/network-alerts.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/callscreen.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/callscreen.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/callscreen.gaiamobile.org/application.zip -> /system/b2g/webapps/callscreen.gaiamobile.org/application.zip
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/settings.gaiamobile.org/manifest.webapp -> /system/b2g/webapps/settings.gaiamobile.org/manifest.webapp
push: /tmp/shallowflashgaia.TF6JkMjDcd0K/gaia/profile/webapps/settings.gaiamobile.org/application.zip -> /system/b2g/webapps/settings.gaiamobile.org/application.zip
### Failed: Pushing Gaia to device failed.
Reporter

Comment 3

4 years ago
Did a fresh download of gaia due to the error from the same date, 15 July. This SUCCEEDS.
Trying to adb push the 16 july versions of both gaia and gecko again has gaia FAIL.
Done a flash back to nightly boot image. Working phone. Again shallow flash brings error.

One last try using the gaia zip from 15 July with 16 july gecko nightly..
SUCCEEDS

using the same gaia zip from 15 July tried 17 July gecko nightly..
HANGS
at precisely:
push: /tmp/shallowflashgaia.nzeshgOyrF7E/gaia/profile/webapps/communications.gaiamobile.org/application.zip -> /system/b2g/webapps/communications.gaiamobile.org/application.zip

waited a few minutes.. right going back to 16 July gecko using 15 july gaia.
Reporter

Comment 4

4 years ago
That fails btw.
As does trying the nightly base image then the 15 July gaia/gecko.
Only way to fix is doing the stable base image again then installing everything again on top of that.
I am SO not going to touch this for a few days lol.
Reporter

Comment 5

4 years ago
Oh no. Imported sim card contacts fine, then when about to import Gmail contacts an update notification pops up & the wizard freezes. This is because until now I was not connected to data or wifi. 

Oh I haven't looked for that bug yet that I've noticed for a little while. The marketplace tries to do an OTA update but never seems download anything and tries to update daily. Anyway.. buggy or not I'm glad to have the phone back in action.
Reporter

Comment 6

4 years ago
I reverted back to base image (stable then the nightly installed on top) and every was set up fine.

To reproduce https://bugzilla.mozilla.org/show_bug.cgi?id=1144557 I attempted to shallow flash the 15 July nightly builds. 

And the screen goes black again after the Thundersoft logo. Reboot does the same. Going to AGAIN flash the base images then try the 20 July nightly builds.
Reporter

Comment 7

4 years ago
Hangs again at
push: /tmp/shallowflashgaia.nzeshgOyrF7E/gaia/profile/webapps/communications.gaiamobile.org/application.zip -> /system/b2g/webapps/communications.gaiamobile.org/application.zip

so I've reverted to Base image v18D_nightly_v3 found at https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/Updating_your_Flame

OTA seems to notify but even on this base image when attempting download the pending marketplace update it fails. Seems like nothing is downloaded looking at the kb stats. The download status disappears. Not sure if it connects to OTA for the nightly update. It's been months seen I've been able to do an update OTA so have been doing them via shallow flash.

could someone explain something to me please?
These base images are regularly updated to reflect the current nightly builds?
Is there a way to run a test or see in menus or the settings.json file which precise build I am using?

Comment 8

4 years ago
Hi David.

I also have a flame with the base image v18D_nightly_v3. I updated the base image because I wasn't sure why I wasn't receiving OTA updates.

Since updating the base image, I still have the same problem. I don't receive OTA updates either and like you I have had to update each time via shallow flash from the Updating your Flame page.

I'm not sure if I understand your question about checking the 'precise build' you are using. All the same, I've noticed if you click 'Device information' from settings and then click 'More information' you'll find the build number and build identifier. I'm just a community member so I may be wrong, but going by the date, it seems like the 'Build number' is linked to the base image, while the 'Build identifier' is linked to the nightly build you download and shallow flash.

I was considering opening a bug for the 'Check for updates' to be a little more informative. At the moment you click, 'Check now' and nothing happens. You don't get told that OTA is temporarily unavailable or any visual feedback at all.
Reporter

Comment 9

4 years ago
Hey thank you Nick!

That's exactly the info I needed. Have you opened a bug?
Flags: needinfo?(nick.cumbo)

Comment 10

4 years ago
Yes, it's here:
https://bugzilla.mozilla.org/show_bug.cgi?id=1187550
Flags: needinfo?(nick.cumbo)
Reporter

Comment 11

4 years ago
Is there a central repo for base images similar to nightlies https://ftp.mozilla.org/pub/mozilla.org/b2g/nightly/ where in the files are clearly time stamped?

Comment 12

4 years ago
I'm not sure. It seems as though some discussion goes on in the mozilla.dev.b2g group though.

https://groups.google.com/forum/#!topic/mozilla.dev.b2g/uK5kzQ_m4_A
Reporter

Comment 13

4 years ago
Thanks matey! Closing this one now. Have an entirely amazing weekend!
Reporter

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.