Smart Collection unable to 'connect to the internet to get apps for' after OTA.

RESOLVED FIXED in 2.2 S5 (6feb)

Status

defect
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: davross, Assigned: kgrandon)

Tracking

({foxfood, regression})

unspecified
2.2 S5 (6feb)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-master fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(6 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 Iceweasel/31.5.0
Build ID: 20150225035911

Steps to reproduce:

Nightly build 20150316160204 selecting any 'Smart Collection'


Actual results:

Installed apps display correctly but suggested apps list at bottom is empty and displays eg "Unable to connect to internet to get apps for Social". Happens also for the Games, Utilities & Weather smart collections.


Expected results:

Smart Collections should have installed apps and a variety of recommended apps under those.
Whiteboard: [systemsfe]
(Reporter)

Comment 1

4 years ago
Posted image Screen capture of this occuring (obsolete) —
this is also occurring for me on the flame

appid 	{3c2e2abc-06d4-11e1-ac3b-374f68613e61}
apptype	b2g
vendor	Mozilla
name 	B2G
version	3.0.0.0-prerelease
appbuildid	20150326160206
platformbuildid	20150326160206
platformversion	39.0a1
geckobuildid	20150326160206
geckoversion	39.0a1
changeset   	59554288b4eb
locale	                en-US
os             	B2G
hardware    	qcom
processor   	arm
compiler     	eabi
Same problem here. I don't know if it's something complicated to fix, but if not, I'd like to be assigned to work with it

Build ID               20150329010203
Gaia Revision          67ad91f3f660b1f16b354ee4c5159ddc5a74d149
Gaia Date              2015-03-28 10:02:40
Gecko Revision         n/a
Gecko Version          39.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  39
Firmware Date          Thu Oct 16 18:19:14 CST 2014
Bootloader             L1TC00011880
this may be caused by Bug 1149286
When I installed the nightly v18D I had no problems.  After OTA update, I had this issue.
I reset the phone and I can see the icons again.

I think the bug is that it's storing some sort of info via the OTA and not updating the smart collection portion correctly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
1. install the v18Dv2 nightly
2. set wifi on
3. OTA 
4. try to launch a smart collection

for actual/expected see comment 0.
Having some people check out OTA from 2.1 to 2.2 and 2.2 to 3.0 testing to see if we run into this issue and filing it as a separate bug as this one covers from 3.0 older to 3.0 OTA latest.
blocking-b2g: --- → 3.0?
Keywords: qawanted
I have checked the simulator and my device, on the device I have only check 3.0 and it will not connect and on the simulator it does not connect when adding smart collections on 2.0 and 3.0. All I see is just a black screen and the home button still works.
Summary: Smart Collection unable to 'connect to the internet to get apps for' → Smart Collection unable to 'connect to the internet to get apps for' after OTA.
I cannot reproduce this bug on Central. I flashed to a 3/31 build, connected to Wifi, OTA'ed to 4/1 build, and all smart collection icons were showing. After I OTA'ed to 4/1 build, today's OTA was then enabled, so I OTA'ed again to today's build, and smart collection icons were still showing.

For the QAwanted request, I flashed to v2.2 (4/2's) and OTA'ed to v3.0 (today's) and all smart collection icons were showing after OTA.

The OTA failed when I flashed to v2.1 (4/2's) and OTA'ed to v2.2 (supposedly today's). Looking into bugging this.

Leaving QAwanted tag for others to attempt.
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
(Reporter)

Comment 11

4 years ago
The problem is NOT surrounding whether or not smart collections show. They function accordingly. As the OP suggests it's the TEXT within the smart collection at issue and any subsequent marketplace algorithmic 'suggestions' based upon what you have placed within them.

Currently the text shows "Connect to the internet to apps for Social" in the example I will add in a moment.

3.0.0.0-prerelease
Build ID: 20150411010203
(Reporter)

Comment 12

4 years ago
Posted image Fresh screen capture
from Build ID 20150411010203. Unable to grab latest build on this public network.
(Reporter)

Updated

4 years ago
Attachment #8579996 - Attachment is obsolete: true
The issue is more or less the change in the client code and client setting for the server.
We changed the setting to appsearch; if you have an older build, you will have the different variable of everythingme.api.url. see Bug 1129637  

If you restore that setting or if you OTA from an older build, then you will see the e.me collection failing. I'm not sure what we can do other than get people updated or have them put in the proper variable in the settings somewhow...

Maybe Kevin might know better.
Flags: needinfo?(kgrandon)
(Assignee)

Comment 14

4 years ago
It's possible that we just need a settings DB version bump for this?
Flags: needinfo?(kgrandon)
(Assignee)

Comment 15

4 years ago
(In reply to Kevin Grandon :kgrandon from comment #14)
> It's possible that we just need a settings DB version bump for this?

To verify if this is the case, we would need to know the value of the 'appsearch.url' setting on an affected device.
(Reporter)

Comment 16

4 years ago
Happy to do so if you can advise or direct me to the 'how'
I was unable to reproduce this issue after 3 attempts.  I attempted this from the following Flame 3.0 builds:

20150310010227
20150316010202
20150410010202

Smart Collections properly displayed app suggestions after the OTA on each attempt.
Flags: needinfo?(ktucker)
Flags: needinfo?(ktucker)
I'm still not able to view smart collection items after the update with Build ID: 20150414072436 with a Git Commit of 2015-04-13 15:03:34
With the information on comment 13, I tried to OTA from a much older 2/4 master build, and was finally able to repro it

STR:
1) Flash to a 2/4/2015 central nightly build
2) Connect to wifi, and observe everything in smart collection can be viewed (no internet connection error)
3) Perform an OTA
4) Ensure internet is connected, and observe smart collections again (bug reproduces)

As for the qawanted request, we are unable to perform cross branch OTA due to our current methods are invalid - See bug 1151006. Clearing qawanted keyword.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Duplicate of this bug: 1146126
Duplicate of this bug: 1152535
(Reporter)

Comment 22

4 years ago
Was having another unrelated issue surrounding an update loop so updated my Flame using these intructions https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/Updating_your_Flame

I seem to recall that the smart collections worked fine using the base image (v18D_v2.zip). Adding the Production Build Nightly shallow flash (Build 2015418160202 via b2g-40.0a1.en-US.android-arm.tar.gz & gaia.zip) brings me back to this same "connect to the internet" issue.
blocking-b2g: 3.0? → 3.0+
I just OTA to build ID: 20150423160207, and am still experiencing the same issues. Also, I installed the Thesaurus app the other day, and it appeared in Games for the smart collections..
See Also: → 1160007
David, you can find the appsearch.url several ways.

I think the easiest might be:
1) connect the device to your computer
2) go into settings -> device information -> more information -> turn on Developer Menu
3) go back to the main settings -> developer -> set to ADB and Devtools in the Debugging via USB
4) on your desktop computer, open Firefox browser
5) go to tools -> Web Developer -> WebIDE
6) connect to Flame (Usb device )
7) accept on the device
8) from the menu on the desktop select runtime -> device settings
9) in the first box type : appsearch
you should see the url in the second box on the line that appears

Comment 26

4 years ago
(In reply to Kevin Grandon :kgrandon from comment #15)
> (In reply to Kevin Grandon :kgrandon from comment #14)
> > It's possible that we just need a settings DB version bump for this?
> 
> To verify if this is the case, we would need to know the value of the
> 'appsearch.url' setting on an affected device.

18D base and Nightly, and WebIDE doesn't find any appsearch.url variable at all.
(Reporter)

Comment 27

4 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #24)

I can't get webIDE to connect to the Flame despite it showing in ADB. Nor over WiFi Debugging. I'm using Debian Jessie on an ancient netbook. 

Can I get this url over ADB?
Flags: needinfo?(nhirata.bugzilla)
David, 
the settings on the device has to be set to "ADB and Devtools"; "ADB only" will not work with Web IDE.
The information is in a database so it's messy to try to extract the info otherwise.

There is a settings.json which your device will reset to in /system/b2g/defaults/
You can pull that and see if you can find the url.

Matěj, if you don't have the "appsearch.url" do you see a setting for "everythingme.api.url" ?

Please set needinfo to me once again when you respond.  Thanks!
Flags: needinfo?(sw1ayfe)
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(mcepl)

Comment 29

4 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #28)
> David, 
> the settings on the device has to be set to "ADB and Devtools"; "ADB only"
> will not work with Web IDE.

I have both ADB and Devtools allowed.

> Matěj, if you don't have the "appsearch.url" do you see a setting for
> "everythingme.api.url" ?

I do. It is https://api.everything.me/partners/1.0/{resource}/
Flags: needinfo?(mcepl) → needinfo?(nhirata.bugzilla)

Updated

4 years ago
Flags: needinfo?(nhirata.bugzilla)
(Reporter)

Comment 30

4 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #28)
> There is a settings.json which your device will reset to in
> /system/b2g/defaults/
> You can pull that and see if you can find the url.

Hmm, that created an empty file. Instead tried 
cat -n /system/b2g/defaults/settings.json
in the adb shell, which ended up filling the terminal screen with a ton of characters. Can't send to a local editor? Swift copy/paste into an editor, search for url only shows "homescreen.manifestURL" towards the end :(

cat -n /system/b2g/defaults/settings.json | less 
doesn't work as the bin for less can't be found in the adb shell :(..
Flags: needinfo?(nhirata.bugzilla)
(Reporter)

Comment 31

4 years ago
oops
Flags: needinfo?(sw1ayfe)
David, it might just be easier to pull the file then and then open it in a text editor on the desktop and do a find in page.

Matěj, Ah.  Just as a I suspected.  it's part of the old code.

Could you try changing the url in everythingme.api.url from "https://api.everything.me/partners/1.0/{resource}/" to "https://appsearch.services.mozilla.com/partners/1.0/{resource}/"

ie change the url from api.everything.me to appsearch.services.mozilla.com
[ context : Bug 1129637 ]
Flags: needinfo?(sw1ayfe)
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(mcepl)
(Reporter)

Comment 33

4 years ago
I was overcomplicating the pull request attempting to rename and force a directory. Left it as is and it worked. Wahoo! Right, mine already is:

appsearch.url":"https://appsearch.services.mozilla.com/partners/1.0/{resource}/"
Flags: needinfo?(sw1ayfe) → needinfo?(nhirata.bugzilla)

Comment 34

4 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #32)
> David, it might just be easier to pull the file then and then open it in a
> text editor on the desktop and do a find in page.
> 
> Matěj, Ah.  Just as a I suspected.  it's part of the old code.
> 
> Could you try changing the url in everythingme.api.url from
> "https://api.everything.me/partners/1.0/{resource}/" to
> "https://appsearch.services.mozilla.com/partners/1.0/{resource}/"
> 
> ie change the url from api.everything.me to appsearch.services.mozilla.com
> [ context : Bug 1129637 ]

I have in meantime (for unrealted reasons) had to reinstall from scratch. So, now I have appsearch.* key, but still Games Smart Folder doesn't show anything (see attached logcat).
Flags: needinfo?(mcepl)
So apparently we're going to be removing e.me/smart collection all together soon in v3.
Also bug 1164772 was fixed; so it boggles me that this is still an issue if we have the correct builds...
The good news is basically you're both in the same spot.  The bad news is... it doesn't work.

Can we take a look at the logcat after you try to open up the smart collection with the builds that you currently have now please?  It might be different outputs than the ones you had before.
Flags: needinfo?(sw1ayfe)
Flags: needinfo?(mcepl)
(Reporter)

Comment 36

4 years ago
Here you go. The only app I have installed since another clean install is Twitter and it doesn't show up in the smart collection when I open 'Social', along with the error "Connect to the internet to get apps for Social".
Flags: needinfo?(sw1ayfe)
Flags: needinfo?(nhirata.bugzilla)
(Reporter)

Comment 37

4 years ago
Posted file logcat-2015-06-15
another logcat as requested
(Reporter)

Updated

4 years ago
Flags: needinfo?(nhirata.bugzilla)

Comment 38

4 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #35)
> Can we take a look at the logcat after you try to open up the smart
> collection with the builds that you currently have now please?  It might be
> different outputs than the ones you had before.

Is the point wearing me out? (see attachment 8617320 [details] for six days old logcat; and no, OTA update is broken ATM so I don't have anything more recent on my phone).
Flags: needinfo?(mcepl)
David, hrm, I think I need the gaia debug and the console debug turned on to tell.  What I'm looking for is something like : https://appsearch.services.mozilla.com/partners/1.0/Apps/search/?limit=24&categoryId=207&iconFormat=20&apiKey=79011a035b40ef3d7baeabc8f85b862f&deviceId=fxos-app://collection.gaiamobile.org/ec59eefe-91d0-453a-87b2-d923806037ab&ctx={"lc":"cs","tz":"2","v":"3.0.0.0-prerelease","dn":"flame","cr":"O2-CZ","ct":"wifi","mcc":"230","mnc":"02","sr":"480x853.5"}& 

Matěj, going to the url works for me in a web browser that has an user agent of a firefox os 3.0 mobile device.  We fixed some stuff on the server side so the only thing I can think of is something on the client end causing the issue...  Can you check your user agent please?
Flags: needinfo?(sw1ayfe)
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(mcepl)

Comment 40

4 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #39)
> Matěj, going to the url works for me in a web browser that has an user agent
> of a firefox os 3.0 mobile device.  We fixed some stuff on the server side
> so the only thing I can think of is something on the client end causing the
> issue...  Can you check your user agent please?

And really ... it seems to work. Rather slowly, but that's probably either issue of transport or server, right?
Flags: needinfo?(mcepl)
(Reporter)

Comment 41

4 years ago
Posted file logcat-2015-06-19
Flags: needinfo?(sw1ayfe) → needinfo?(nhirata.bugzilla)
The server guys had checked their side and they say it seems to be working fine.  I can ping them again for a check.
Flags: needinfo?(ran)
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(jlaz)
I need more information in order to help.
The logcats show no sign of http request to the api server.

It would be best to use the WebIDE in order to trace the http request and see what becomes of it. 404? Wrong response? No response?
Flags: needinfo?(ran)
(Reporter)

Comment 44

4 years ago
I had previously been unable to get WebIDE to recognise my Flame on this Debian Jessie Netbook. Updated to Firefox 38.0.5 (it was previously 38.0.1), rebooted with the phone still connected, and this time it is recognised. Woohaa!!

Right:
1) can not find anything with 'appsearch'
2) 'everything.me' returns: https://api.everything.me/partners/1.0/{resource}/
3) as per [comment 32] I edited it to https://appsearch.services.mozilla.com/partners/1.0/%7Bresource%7D/
4) rebooted the flame
5) still prints "Connect to the internet.." and unable to add a new smart collection

So this gets me up to your question, Ran. I did just try looking through WebIDE instructions & intro video. None of them yet help me answer your question to 'trace the http request'. 

How would I go about this? 

My testing knowledge is truly slim & my Javascript based on one brief training session. Sorry if it's made this bug process mega slow. I'm learning a ton which is totally a win! Thanks for your patience folks.
Flags: needinfo?(ran)
Flags: needinfo?(nhirata.bugzilla)
I don't know if there's another way to see the requests. Perhaps an http sniffer (e.g. Charles) but since it's ssl requests, I'm not sure they'll show up.

Naoki maybe you can assist?
Flags: needinfo?(ran)
Well, now that the server has transition inside Mozilla, can we take a look again please?
The end point should be pointing to our server at : appsearch.services.mozilla.com
Flags: needinfo?(nhirata.bugzilla) → needinfo?(sw1ayfe)
Flags: needinfo?(jlaz)
(Reporter)

Comment 47

4 years ago
There's a bug the moment I should scan the QR code on the Flame. Will raise that issue now.
Flags: needinfo?(sw1ayfe)
(Reporter)

Comment 48

4 years ago
Over the weekend I had this issue https://bugzilla.mozilla.org/show_bug.cgi?id=1185290 In that thread you can see I stepped back one nightly at a time each with it's own issue. 15 July had issue surrounding logging into Gmail accounts in the end so kept it as base image for now.

Back to this specific issue: using the base images (stable then the nightly on top) I pulled the settings.json file locally and can confirm..
https://appsearch.services.mozilla.com/partners/1.0/{resource}/
and the smartfolders actually connect to the internet without this error.

I am concerned though that I am not getting OTA updates. Doing to push the working 15 July nightly back on it in the hope that as I already have Gmail accounts linked that particular error will simply vanish.

Will report back the situation re the smart folders once I do so.
(Reporter)

Comment 49

4 years ago
Finally I can report that this big is no longer replicating.
Build ID 20150724160206
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(In reply to David Ross from comment #49)
> Finally I can report that this big is no longer replicating.
> Build ID 20150724160206

So, this probably have some server-side part.
I was on latest OTA update (06/29), and hence flashed to latest nightly to check. I still have the issue reproducing.

Reopening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to Clément Lefèvre from comment #50)
> (In reply to David Ross from comment #49)
> > Finally I can report that this big is no longer replicating.
> > Build ID 20150724160206
> 
> So, this probably have some server-side part.
> I was on latest OTA update (06/29), and hence flashed to latest nightly to
> check. I still have the issue reproducing.
> 
> Reopening.

Forgot the build informations:

Build ID               20150724160206
Build Type             userdebug
Gaia Revision          ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
Gaia Date              2015-07-24 11:53:36
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/706318c7d595
Gecko Version          42.0a1
Build Name             flame-userdebug 4.4.2 KOT49H eng.cltbld.20150527.043015 test-keys
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150527.043015
Firmware Date          Wed May 27 04:30:24 EDT 2015
Bootloader             L1TC000118D0

Updated

4 years ago
Keywords: foxfood, regression
(Reporter)

Comment 52

4 years ago
That was precisely the build I had. I first though install the latest base image which was updated recently https://developer.mozilla.org/en-US/Firefox_OS/Phone_guide/Flame/Updating_your_Flame#Base_Image

On bug 1185290 I think I potentially inherited something that was also from the earlier base image.

NOTE: there is some clash going on with shallowflashing. I just updated to the 20150726 of both Gaia & B2G at once and the phone goes black, the B2G succeeds & Gaia shallowflash fails. I had another bug reporting this but mention a workaround here. I simply shallowflashed the Gaia image on its own and the Flame reboots as expected. And again the Smart Collections are fully operational.
(Reporter)

Comment 53

4 years ago
That new nightly base image was approved and published July 12
https://groups.google.com/forum/#!topic/mozilla.dev.b2g/uK5kzQ_m4_A
(In reply to David Ross from comment #53)
> That new nightly base image was approved and published July 12
> https://groups.google.com/forum/#!topic/mozilla.dev.b2g/uK5kzQ_m4_A

My Flame is currently already running v18D v3 for several days ago, and then the flash was Gecko + Gaia in the same time.
Hi Clement, Are you behind any firewall?  Also which country are you located in?
Flags: needinfo?(clement.lefevre)
Please also provide a logcat information when attempting to connect to the e.me server.
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #56)
> Please also provide a logcat information when attempting to connect to the
> e.me server.

So, no I'm not behind a firewall. I'm located in France.

While this issue is reproducing everytime on Flame and master, this is still working on my Open C on Firefox OS 1.3 on the same place, which discard the possibility it comes from my connection (this, and because I tried it from phone network and 2 or 3 different Wi-Fi).

Here are joined for example logs from when I try to open the Music Smart Collection.

Let me know if you need more or for other Smart Collections.
Flags: needinfo?(clement.lefevre) → needinfo?(nhirata.bugzilla)
Hrm.  
1) I think Johan can check as well if this is happening to him as well, since he's out in France.
2) In the meantime, can you check using the WebIDE to see what your preferences are set to?  ( see comment 24 for instructions )
I have a feeling that if you have an old profile that you carried over that you may have the old settings locked in your device.  The old setting won't work for 2.x
3) also the logcat information doesn't contain the information I need.  I think the developer -> console enabled and the developer -> Gaia debug traces need to be turned on.  If you can turn those on and redo the adb logcat, I would appreciate it.  :) see comment 39 for an example of what I am looking for.
Flags: needinfo?(nhirata.bugzilla)
Flags: needinfo?(jlorenzo)
Flags: needinfo?(clement.lefevre)
Hey guigs, jsavage, could you see comment 58 and follow the troubleshooting steps for e.me connectivity issues please?  

I have a feeling we can write a SUMO support article here to help out other people that are having e.me connectivity issues.
Flags: needinfo?(rmcguigan)
Flags: needinfo?(jsavage)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #58)
> Hrm.  
> 1) I think Johan can check as well if this is happening to him as well,
> since he's out in France.
> 2) In the meantime, can you check using the WebIDE to see what your
> preferences are set to?  ( see comment 24 for instructions )
> I have a feeling that if you have an old profile that you carried over that
> you may have the old settings locked in your device.  The old setting won't
> work for 2.x
> 3) also the logcat information doesn't contain the information I need.  I
> think the developer -> console enabled and the developer -> Gaia debug
> traces need to be turned on.  If you can turn those on and redo the adb
> logcat, I would appreciate it.  :) see comment 39 for an example of what I
> am looking for.

So, nothing found with appsearch as for comment 24, but I found rocketbar.searchAppURL with value app://search.gaiamobile.org/index.html

For the logcat, Gaia debug was already activated. Console was not, so here is joined a new logcat with Console, because I don't really understood what was you needing with comment 39.

This still would be strange this happens because of an URL change I should have in the system: why, in this case, would a Firefox OS 1.3 still works? It shouldn't if it doesn't have the right URL?
Flags: needinfo?(clement.lefevre) → needinfo?(nhirata.bugzilla)
If you don't see a value for app.searchurl then you have an outdated setting.  We changed this for 2.x.

1.x was not affected with this change because the url is hardcoded in the app.  The reason why 1.x is working is because we have URL redirects server side to point to the appropriate server.

Also I am still not seeing the result, I think partially because you need to close the collections using task manager and relaunch it.  Having said that I think I know what the exact issue is based on your last response.

Please add a setting using webide:
"appsearch.url":"https://appsearch.stage.mozaws.net/partners/1.0/{resource}/"

You may have to reboot the device after making this change.  Could you try that and check again please?
Flags: needinfo?(nhirata.bugzilla) → needinfo?(sw1ayfe)
Flags: needinfo?(sw1ayfe) → needinfo?(clement.lefevre)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #61)
> If you don't see a value for app.searchurl then you have an outdated
> setting.  We changed this for 2.x.
> 
> 1.x was not affected with this change because the url is hardcoded in the
> app.  The reason why 1.x is working is because we have URL redirects server
> side to point to the appropriate server.
> 
> Also I am still not seeing the result, I think partially because you need to
> close the collections using task manager and relaunch it.  Having said that
> I think I know what the exact issue is based on your last response.
> 
> Please add a setting using webide:
> "appsearch.url":"https://appsearch.stage.mozaws.net/partners/1.0/{resource}/"
> 
> You may have to reboot the device after making this change.  Could you try
> that and check again please?

So, I added this and did a reboot. Still nothing.
I checked after the reboot using WebIDE that this value was really here, it was the case.
Flags: needinfo?(clement.lefevre)
(In reply to Clément Lefèvre from comment #62)
> So, I added this and did a reboot. Still nothing.
> I checked after the reboot using WebIDE that this value was really here, it
> was the case.

Okay, so I must correct myself here. Copying the URL you gave me from the webpage to paste it into the WebIDE converted '{' and '}' by their HTML equivalent, breaking the network communication.
I manually corrected those, and Smart Collections now works correctly.

Now, this bring me to two questions:

- Why this new parameter was not added and things correctly updated following the updates? (~6 months this Flame is on master updating either with OTA or flashing but always doing a backup and restoring profiles with QA tools)

- Shouldn't Smart Collections or other Firefox OS parts be able to contact the server even if some characters are replaced by their HTML equivalents, like here for '{' and '}'?
Flags: needinfo?(nhirata.bugzilla)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #58)
> 1) I think Johan can check as well if this is happening to him as well,
> since he's out in France.

Like infered the comments after 58, there's likely something wrong within the profile. I freshly flashed a Flame to [1] and [2], I wasn't able to repro. I tried:
* Wi-Fi vs 3G
* Social vs Games vs Music
* Eng vs userdebug


[1] Build ID               20150729150205
Gaia Revision          088f350b39baf8f86c7c1161fd4be178ce822b7b
Gaia Date              2015-07-29 15:33:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/62cd40885e93
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150729.183952
Firmware Date          Wed Jul 29 18:40:04 EDT 2015
Bootloader             L1TC000118D0

[2] Build ID               20150724160206
Gaia Revision          ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
Gaia Date              2015-07-24 11:53:36
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/706318c7d595
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150724.193751
Firmware Date          Fri Jul 24 19:38:02 EDT 2015
Bootloader             L1TC000118D0
Flags: needinfo?(jlorenzo)
(In reply to Johan Lorenzo [:jlorenzo] (QA) from comment #64)
> (In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from
> comment #58)
> > 1) I think Johan can check as well if this is happening to him as well,
> > since he's out in France.
> 
> Like infered the comments after 58, there's likely something wrong within
> the profile. I freshly flashed a Flame to [1] and [2], I wasn't able to
> repro. I tried:
> * Wi-Fi vs 3G
> * Social vs Games vs Music
> * Eng vs userdebug
> 
> 
> [1] Build ID               20150729150205
> Gaia Revision          088f350b39baf8f86c7c1161fd4be178ce822b7b
> Gaia Date              2015-07-29 15:33:30
> Gecko Revision        
> https://hg.mozilla.org/mozilla-central/rev/62cd40885e93
> Gecko Version          42.0a1
> Device Name            flame
> Firmware(Release)      4.4.2
> Firmware(Incremental)  eng.cltbld.20150729.183952
> Firmware Date          Wed Jul 29 18:40:04 EDT 2015
> Bootloader             L1TC000118D0
> 
> [2] Build ID               20150724160206
> Gaia Revision          ade1ef5249cfab921e00ed67b30f3d03c2e24b5e
> Gaia Date              2015-07-24 11:53:36
> Gecko Revision        
> https://hg.mozilla.org/mozilla-central/rev/706318c7d595
> Gecko Version          42.0a1
> Device Name            flame
> Firmware(Release)      4.4.2
> Firmware(Incremental)  eng.cltbld.20150724.193751
> Firmware Date          Fri Jul 24 19:38:02 EDT 2015
> Bootloader             L1TC000118D0

Yeah, by adding the setting Naoki pointed out, it does work, but the question is: why this setting didn't came on phone updates? Not to mention, maybe other important settings didn't came up with updates and cause different problems.
Old preferences are kept on OTA.  If you store old profiles and backup/restore or strictly OTA, you will never see the new preferences that are introduced and hence run into the issue you ran into.

The code change happened a while ago: https://github.com/mozilla-b2g/gaia/commit/134ffd7f11be8ac52223ac6ac34b966604e2e368
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Flags: needinfo?(nhirata.bugzilla)
Resolution: --- → FIXED
NI just to answer your question.  No questions remain.  I am marking this as fixed.  Thanks.
Flags: needinfo?(clement.lefevre)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #66)
> Old preferences are kept on OTA.  If you store old profiles and
> backup/restore or strictly OTA, you will never see the new preferences that
> are introduced and hence run into the issue you ran into.
> 
> The code change happened a while ago:
> https://github.com/mozilla-b2g/gaia/commit/
> 134ffd7f11be8ac52223ac6ac34b966604e2e368

And there would be no way to have this profile evolve and get new preferences? Using my phone to dogfood as my everyday phone, it would be annoying to have the obligation to fully reset the profile often to dogfood correctly and not having such wrong problems.
Flags: needinfo?(clement.lefevre) → needinfo?(nhirata.bugzilla)
Assignee: nobody → kevingrandon
Target Milestone: --- → 2.2 S5 (6feb)
It might be possible.  I filed bug 1191697 for this issue.  Let's carry the conversation over there rather than in this bug please.
Flags: needinfo?(nhirata.bugzilla) → needinfo?(clement.lefevre)

Updated

4 years ago
Flags: needinfo?(clement.lefevre)
Do we still need an article for this, Naoki?
Flags: needinfo?(jsavage)

Updated

3 years ago
Duplicate of this bug: 1168047
Flags: needinfo?(rmcguigan)
You need to log in before you can comment on or make changes to this bug.