Closed Bug 1186108 Opened 4 years ago Closed 4 years ago

[Contacts] Cannot share contact via MMS.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.2 affected, b2g-master verified)

VERIFIED FIXED
FxOS-S5 (21Aug)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- affected
b2g-master --- verified

People

(Reporter: NicholasN, Assigned: arcturus)

References

()

Details

(Keywords: regression, Whiteboard: [2.5-Daily-Testing][Spark])

Attachments

(5 files)

Attached file logcat_share.txt
Description:
The user goes to Contacts, and selects a contact. They tap the share icon, and select Messages. After they send the message to another device, there is an error message that occurs in the thread for both devices which reads, "There is a problem with the attached file and it cannot be downloaded." This occurred for Aries to Flame and Aries to Aries. Sending an image in an MMS worked appropriately.


Repro Steps:
1) Update an Aries to 20150721140411
2) Go to Contacts.
3) Ensure there is at least one contact saved.
4) Open the contact, tap the share icon, and select Messages.


Actual:
An error message occurs and the contact cannot be shared.


Expected:
The contact is shared successfully.


Notes:

Environmental Variables:
Device: Aries 2.5
Build ID: 20150721140411
Gaia: 4fe0507781f3ed56c8ae5e66dd9489165d1ff68e
Gecko: d7a9e44717b7
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0


Repro frequency: 5/5
See attached: video clip, logcat
Note: Sharing a contact from inside an MMS thread via "Communications" icon works correctly, it's only sharing from Contacts that causes the issue.

Issue also occurs on Flame 2.5 and Flame 2.2, but not on Flame 2.1

Flame 2.5

Actual:
An error message occurs and the contact cannot be shared.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150721010202
Gaia: 4fe0507781f3ed56c8ae5e66dd9489165d1ff68e
Gecko: 3a4bfa5d2d02
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Flame 2.2

Actual:
An error message occurs and the contact cannot be shared.

Environmental Variables:
Device: Flame 2.2
BuildID: 20150721002506
Gaia: e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gecko: 1bc400014f71
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Flame 2.1


Actual:
The share icon is not present in Contacts.

Environmental Variables:
Device: Flame 2.1
BuildID: 20150721001206
Gaia: cc24cce17ab2ebf79f6505103da714fc65bc5ec1
Gecko: 3856aebece7b
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 34.0 (2.1) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regression
Summary: [Aries][Contacts] Cannot share contact via MMS. → [Contacts] Cannot share contact via MMS.
Whiteboard: [2.5-Daily-Testing][Spark]
Feature introduced in bug 1113605. I don't find a dupe for it. That sounds like a regression, but it would have happened within the 2.2 branch.
Blocks: 1113605
[Blocking Requested - why for this release]:
Functional regression of a supported feature.

According to https://bugzilla.mozilla.org/show_bug.cgi?id=1007932#c51 this was working at one point, requesting a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: ddixon
Comms triage: Broken feature.
blocking-b2g: 2.5? → 2.5+
B2G Inbound Regression Window

Last Working

Device: Flame 2.5
BuildID: 20150330033918
Gaia: fd48899451df1a735c1ccb3244c126c7d8dd1c26
Gecko: 07da0404a450
Version: 39.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

First Broken

Device: Flame 2.5
BuildID: 20150330060316
Gaia: 5c546a319e22e1e0b20608cd82069a8aeb05d5ca
Gecko: 8da5d927c19f
Version: 39.0a1 (2.5) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0

Last Working Gecko and First Broken Gaia
Issue DOES occur here: 
Gaia: 5c546a319e22e1e0b20608cd82069a8aeb05d5ca
Gecko: 07da0404a450

Last Working Gaia and First Broken Gecko
Issue DOES NOT occur here: 
Gaia: fd48899451df1a735c1ccb3244c126c7d8dd1c26
Gecko: 8da5d927c19f

B2G Inbound Gaia Pushlog: 
https://github.com/mozilla-b2g/gaia/compare/fd48899451df1a735c1ccb3244c126c7d8dd1c26...5c546a319e22e1e0b20608cd82069a8aeb05d5ca

Possible Cause: 
Bug 1144610 - Unable to share contact info via bluetooth from contact…
Blocks: 1144610
No longer blocks: 1113605
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Adrián, can you take a look at this please? This looks to have been caused by the work done for bug 1144610.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(hola)
Unfortunately, Adrian is not working in FxOS right now.
Fernando, can you have a look at it? Thanks a lot
Flags: needinfo?(hola) → needinfo?(fernando.campo)
Assignee: nobody → fernando.campo
Status: NEW → ASSIGNED
yep, it seems related to bug 1185090, so I'll take a look
Flags: needinfo?(fernando.campo)
Any progress here?
If I remember correctly, this bug was solved in Paris with Julien, but never commited, the solution was quite simple. When creating the share activity on the file object we needed to specify the content type.

Will upload a simple patch right now, the solution was pretty straight forward.
Assignee: fernando.campo → francisco
Comment on attachment 8649895 [details] [review]
[gaia] arcturus:bug-1186108 > mozilla-b2g:master

This code actually comes from a live coding session Julien and myself did r=me.
Attachment #8649895 - Flags: review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/066d6925da82dafbff140875c8699e7bbfe32b33
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S5 (21Aug)
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: The contact is shared to MMS successfully in contact detail page.
See attachment: verified_FlameKK_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150820150207
Gaia Revision          c6705f739fb605031eb2a0b943ba55c64bee5a03
Gaia Date              2015-08-20 14:36:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/095988abdc560bf8ba07a94a425c6922a3e9bfd6
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150820.183055
Firmware Date          Thu Aug 20 18:31:07 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5(Pass)
Build ID               20150820204657
Gaia Revision          c6705f739fb605031eb2a0b943ba55c64bee5a03
Gaia Date              2015-08-20 14:36:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/095988abdc560bf8ba07a94a425c6922a3e9bfd6
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150820.200928
Firmware Date          Thu Aug 20 20:09:36 UTC 2015
Bootloader             s1
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
Reopening this bug because after reverting the commits that gave us separated views in Contacts (as part of the NGA work) the issue can be reproduced again in master.

Although this issue was already raised in 2.2, before the NGA work, the solution uses the detail_controller, that after the back out is not used in master.

Be aware that the issue is not happening in NGA branch so ONLY a specific patch for master is necessary now.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8662480 [details] [review]
[gaia] arcturus:bug-1186108 > mozilla-b2g:master

Version against master, same solution.
Attachment #8662480 - Flags: review?(borja.bugzilla)
Attachment #8662480 - Flags: review?(borja.bugzilla) → review?(ferjmoreno)
Attachment #8662480 - Flags: review?(ferjmoreno) → review+
Landed in master:

https://github.com/mozilla-b2g/gaia/commit/156bcfd59534ea5c072390b5505eec63f98df30f
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Tested in latest master build (9/22) and working fine! Thanks Francisco!

Environmental Variables (9/22):
flame master (2.5 version)
Build ID: 20150922134824
Gecko: 651a168
Gaia: 3857a7e
Platform version: 44.0a1
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: The contact is shared by MMS successfully in contact detail page.
See attachment: verified_Aries_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150922150204
Gaia Revision          68361828ae88dffd04b250121b5f2472a63f4bf0
Gaia Date              2015-09-22 03:46:57
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a1ccea59e254a88f7bb44b0ad8a58b77b7eca339
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150922.183124
Firmware Date          Tue Sep 22 18:31:40 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20150923004630
Gaia Revision          864500d40633bbf0e9a83c92a03cea46bb901906
Gaia Date              2015-09-22 17:27:46
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/05a7ee49d40a4cfabf2479337fd5e1312e178b6d
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150923.000647
Firmware Date          Wed Sep 23 00:06:55 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1164805
You need to log in before you can comment on or make changes to this bug.