[Gallery] When transitioning from portrait to landscape half of the screen is black.

VERIFIED FIXED in Firefox 42, Firefox OS master

Status

()

Core
Graphics
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: AdamA, Assigned: jerry)

Tracking

(Blocks: 1 bug, {regression})

unspecified
mozilla42
ARM
Gonk (Firefox OS)
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, firefox42 fixed, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [2.5-Daily-Testing][Spark], URL)

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8636828 [details]
logcat

Description:
When in the main gallery screen if the user turns the phone into landscape mode half of the screen will be black while it is transitioning.

Repro Steps:
1) Update a Aries to 20150721140411
2) Open gallery in portrait
3) Turn phone into landscape mode
4) Observe screen during transition

Actual:
Half the screen will be black during transition

Expected:
It is expected that the whole screen is visible during transition

Environmental Variables:
Device: Aries 2.5 [Full Flash]
Build ID: 20150721140411
Gaia: 4fe0507781f3ed56c8ae5e66dd9489165d1ff68e
Gecko: d7a9e44717b7
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 42.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Repro frequency: 10/10
See attached: video clip(https://youtu.be/S6Sx89rRN4E), logcat
(Reporter)

Comment 1

2 years ago
This issue DOES occur on flame 2.5.

Environmental Variables:
Device: Flame 2.5 [Full Flash]
BuildID: 20150721010202
Gaia: 4fe0507781f3ed56c8ae5e66dd9489165d1ff68e
Gecko: 3a4bfa5d2d02
Gonk: 41d3e221039d1c4486fc13ff26793a7a39226423
Version: 42.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:42.0) Gecko/42.0 Firefox/42.0

Result:
Half the screen will be black during transition
-------------------------------------
This issue DOES NOT occur on Flame 2.2.

Environmental Variables:
Device: Flame 2.2 [Full Flash]
BuildID: 20150721002506
Gaia: e1e6317f17a840b19af9dbb25f5a771d8d9fa161
Gecko: 1bc400014f71
Gonk: bd9cb3af2a0354577a6903917bc826489050b40d
Version: 37.0 (2.2) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Result:
Whole screen is visible during transition.
Blocks: 1171119
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
Flags: needinfo?(pbylenga)
Keywords: regression
Whiteboard: [2.5-Daily-Testing][Spark]
[Blocking Requested - why for this release]:
We've blocked on graphical regressions similar to this in the past, nominating for quality.

Requesting a window.
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Keywords: regressionwindow-wanted
QA Contact: xiongfuchao
Mozilla-Inbound Regression Window

Last Working Environmental Variables:
Device: Flame Master
Gaia-Rev        0b166043ef2a1f235a4d7d4f40a51b625784195a
Gecko-Rev       https://hg.mozilla.org/integration/mozilla-inbound/rev/9749a0c63d81
Build-ID        20150629153945
Version         41.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150630.193722
FW-Date         Tue Jun 30 19:37:34 EDT 2015
Bootloader      L1TC000118D0

First Broken Environmental Variables:
Device: Flame Master
Gaia-Rev        0b166043ef2a1f235a4d7d4f40a51b625784195a
Gecko-Rev       https://hg.mozilla.org/integration/mozilla-inbound/rev/609e17393e2e
Build-ID        20150629164745
Version         41.0a1
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150630.193722
FW-Date         Tue Jun 30 19:37:34 EDT 2015
Bootloader      L1TC000118D0

First Broken Gecko & Last Working Gaia - issue DOES repro
Gaia: 0b166043ef2a1f235a4d7d4f40a51b625784195a
Gecko: https://hg.mozilla.org/integration/mozilla-inbound/rev/609e17393e2e

First Broken Gaia & Last Working Gecko - issue dose NOT repro
Gaia: 0b166043ef2a1f235a4d7d4f40a51b625784195a
Gecko: https://hg.mozilla.org/integration/mozilla-inbound/rev/9749a0c63

Mozilla-inbound pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9749a0c63d81&tochange=609e17393e2e
QA Whiteboard: [MGSEI-Triage+]
Keywords: regressionwindow-wanted
QA Contact: xiongfuchao

Comment 4

2 years ago
Blocking for regression

David, can you do a quick investigation and route to core/layout if it is a regression from there.
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(dflanagan)
[Blocking Requested - why for this release]:

Watching the video, this doesn't look that bad to me. In general, it is hard to handle orientation changes. At some point the app has to completely change the way it is displayed. In this case it is switching from three columns of smallish thumbnails to four columns of bigger thumbnails.

Relatively recently gecko switched so that the orientation change was animated and you see the screen rotate a bit before switching to the new orientation. Before that it would just flash from one orientation to the other all at once. Perhaps this bug is the result of that change?

Before we decide to block on this or ask the graphcs or layout teams to look at it, I think we need to have a before video to compare with the after video that is currently attached, because as I said, just looking at the video here, it doesn't seem that bad to me.

Let's reconsider the blocking decision after we have two videos to compare.
Adam or Verson: would one of you record a video of the case where this bug does not reproduce (based on the regression range in comment #3) please?
blocking-b2g: 2.5+ → 2.5?
Flags: needinfo?(xiongfuchao)
Flags: needinfo?(dflanagan)
Flags: needinfo?(aalldredge)
Created attachment 8639672 [details]
Flame_master.3gp

Hi David,
I recorded a new contrast video, there are two Flame devices in video.
Left one flashed 20150629153945(issue dose NOT repro) 
Right one flashed 20150629164745(issue DOES repro)
See attachment:Flame_master.3gp
Flags: needinfo?(xiongfuchao)

Updated

2 years ago
Component: Gaia::Gallery → Graphics
Product: Firefox OS → Core
(Reporter)

Updated

2 years ago
Flags: needinfo?(aalldredge)
milan, could you help to comment on this?
Flags: needinfo?(milan)
To me it looks like different path for the animation of the orientation, if anything.  In particular, the different scaling for a frame or two.  I'm not particularly disturbed by it, so I'll leave the blocking decision to others, but if I was guessing, I'd check patch 4 from bug 1122526.  :dbaron, what do you think?
Flags: needinfo?(milan) → needinfo?(dbaron)
It's not clear to me how bug 1122526 would have led to this, but it's clearly the only sensible thing in the regression window.  (I'd have expected failure modes from that to be fuzzy/pixelated rather than half-black.)
Blocks: 1122526
... though it could also be leading to different appearance by changing (hopefully improving) the performance of the animation
(Assignee)

Comment 11

2 years ago
I think I find the root cause. When I remove my culling method at bug 1170966, the result seems good. :(
Assignee: nobody → hshih
Status: NEW → ASSIGNED
Flags: needinfo?(dbaron)
(Assignee)

Comment 12

2 years ago
Created attachment 8642978 [details] [diff] [review]
fix drawQuad culling bug. v1

Consider the render target size for drawQuad culling.
I only check the widget's rect before. It will get the wrong culling result if we change to another render target.
Attachment #8642978 - Flags: review?(nical.bugzilla)
(Assignee)

Comment 13

2 years ago
Wait the try result:

https://treeherder.mozilla.org/#/jobs?repo=try&revision=af5f542ca670

Updated

2 years ago
Attachment #8642978 - Flags: review?(nical.bugzilla) → review+
(Assignee)

Comment 14

2 years ago
Please land the attachment 8642978 [details] [diff] [review] to m-c.
Try link: https://treeherder.mozilla.org/#/jobs?repo=try&revision=af5f542ca670
Keywords: checkin-needed
See Also: → bug 1170966

Comment 15

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/28fac8d7cdde
Keywords: checkin-needed

Updated

2 years ago
blocking-b2g: 2.5? → 2.5+
https://hg.mozilla.org/mozilla-central/rev/28fac8d7cdde
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox42: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Depends on: 1192633
(Assignee)

Updated

2 years ago
See Also: → bug 1192192
(Assignee)

Updated

2 years ago
No longer depends on: 1192633
This issue is verified fixed on the latest Flame and Spark 2.5 builds.
The screen does not flash or flicker black during the transition. All gallery items are properly visible as they transition from a 3 column to 4 column layout during the orientation transition.

Environmental Variables:
Device: Flame 2.5
BuildID: 20150813030210
Gaia: 52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gecko: 7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Environmental Variables:
Device: Aries 2.5
BuildID: 20150812231434
Gaia: 52f3ea58df38e5427f6afeb636bc6ad01d24022f
Gecko: 7649ffe28b67aa2dad0f67ea01500c0ff91b2bac
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][QAnalyst-Triage?]
status-b2g-master: affected → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [MGSEI-Triage+][QAnalyst-Triage?] → [MGSEI-Triage+][QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Depends on: 1199600
You need to log in before you can comment on or make changes to this bug.