Closed Bug 1187210 Opened 4 years ago Closed 4 years ago

Path2D.arc hang

Categories

(Core :: Canvas: 2D, defect, critical)

defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla42
Tracking Status
firefox42 --- verified

People

(Reporter: jruderman, Assigned: lsalzman)

References

(Blocks 1 open bug)

Details

(Keywords: hang, testcase)

Attachments

(2 files, 1 obsolete file)

Might be related to bug 943587.
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Due to floating point inaccuracies, large angles would cause the angle correction step to modify aStartAngle and aEndAngle such that arcSweepLeft still resulted in a huge value, much larger than 2*PI, thus causing ArcToBezier to iterate far more than the expected number of times.
Attachment #8638755 - Flags: review?(jmuizelaar)
OS: Unspecified → All
Hardware: Unspecified → All
Attachment #8638755 - Flags: review?(jmuizelaar) → review+
Duplicate of this bug: 943587
Fix some mochitest issues with reverse sweeps and Skia canvas precision issues.

Try run: https://treeherder.mozilla.org/#/jobs?repo=try&revision=47d0b14e7330
Attachment #8638755 - Attachment is obsolete: true
Attachment #8638885 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/5a03eaa2db9f
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla42
Duplicate of this bug: 1199169
Flags: qe-verify+
Reproduced the initial issue on Win 10 x32, Ubuntu 14.04 x32 and Mac OS X 10.11 using Firefox 40.0.2 (20150812163655)build using the attached testcase. Verified that the issues does not reproduce on Firefox 42.0 Beta 4 (20151005144425) on the same environment.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.