[meta] Performance issues with tiles on top-sites panel (about:home)

RESOLVED FIXED

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: sleroux)

Tracking

({perf, reproducible})

unspecified
All
iOS
perf, reproducible
Dependency tree / graph

Firefox Tracking Flags

(fxios2.0+)

Details

(Reporter)

Description

3 years ago
Currently there are visible performance issues on the top-sites panel that affect the responsiveness of the application. The overall dips in frame-rate and UI responsiveness can be seen either filling up the panel with a Sync or by manual browsing 

The above is filed against testing on my iPhone 6 (8.3)

* Notice a large dip in frame-rate after a device rotation on about:home (compare against any other application)

* Notice a large dip in frame-rate and responsiveness when deleting a bunch of top-sites in a row; when all tiles are removed things naturally speed up (visible via animation) 

Currently the panel is very taxing on the hardware.
(Assignee)

Comment 1

3 years ago
I can run a quick profile on it but I would put my money on the blurs as they are computationally expensive to render. Just curious, how important is it to use blurring instead of a flat or alpha faded color?
Flags: needinfo?(dhenein)
Getting the right color from the favicons proved tricky, and less reliably well than the blurred version. Can we cache the blurred image so we only generate it once per favicon (favicons aren't likely to change often...)
Flags: needinfo?(dhenein)
(Assignee)

Comment 3

3 years ago
Ya good idea - we can take a snapshot of the rendered blur and use that instead of dynamically blurring it since we don't need dynamic blurring.
Assignee: nobody → sleroux
Status: NEW → ASSIGNED
tracking-fxios: ? → +
(Assignee)

Comment 4

3 years ago
Add perf test for timing on blur render
(Assignee)

Comment 5

3 years ago
I know there was some discussion going on last Friday about which approach to take with this bug. NI'ing
Flags: needinfo?(dhenein)
I think we're done with this for v1, now we've killed the background blur. Punting to 1.x.
tracking-fxios: + → 1.1+
Assignee: sleroux → nobody
Status: ASSIGNED → NEW
Component: General → Home screen
Flags: needinfo?(dhenein)
(Reporter)

Comment 7

3 years ago
Still reproducible without background blur, especially seen on rotation
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 8

3 years ago
What's incomplete about this?
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Stefan and I considered this "just about fixed enough but not going to be acted on further unless someone screams", which is the definition of INCOMPLETE.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
tracking-fxios: 1.1+ → +
Resolution: --- → FIXED
(Reporter)

Comment 10

3 years ago
This is even more noticeably worse on iOS9 IMO.
(Reporter)

Comment 11

3 years ago
No patch here, re-opening
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 12

3 years ago
This also causes a terrible drop in frames when cycling through open applications on ones device and passing by Firefox on about:home, the application listing slows down to a crawl.
Status: REOPENED → NEW
(Assignee)

Comment 13

3 years ago
So interesting note: Yesterday we were talking about how when in the application switcher, the app is showing a screenshot instead of the actual app. Well this morning while using the messages app, I definitely saw the UI update while in the app switcher so I think that while in the switcher after being in Firefox we are rendering the blurs and everything which would cause the performance hit.
Assignee: nobody → bnicholson
Status: NEW → ASSIGNED
tracking-fxios: + → 1.1+
Hardware: ARM → All
(Assignee)

Updated

3 years ago
Flags: needinfo?(sleroux)
(Assignee)

Updated

3 years ago
Flags: needinfo?(sleroux)
Summary: Performance issues with tiles on top-sites panel (about:home) → [meta] Performance issues with tiles on top-sites panel (about:home)
(Assignee)

Updated

3 years ago
Depends on: 1211982
(Assignee)

Updated

3 years ago
Depends on: 1211984
(Assignee)

Updated

3 years ago
Depends on: 1211986
(Assignee)

Updated

3 years ago
Depends on: 1211988
(Assignee)

Updated

3 years ago
Depends on: 1211991
(Assignee)

Comment 14

3 years ago
I'm going to start chipping away at some of the smaller sub-bugs to see if we can get something in for 1.1
(Assignee)

Updated

3 years ago
Assignee: bnicholson → sleroux
(Assignee)

Comment 15

3 years ago
Removing 1.1+ tracking since this meta won't be completed for 1.1 and is scheduled for 2.0
tracking-fxios: 1.1+ → 2.0+
(Assignee)

Updated

3 years ago
Blocks: 1213016
(Assignee)

Updated

3 years ago
Depends on: 1216000
(Assignee)

Updated

3 years ago
Depends on: 1220798
(Assignee)

Updated

3 years ago
Depends on: 1221118
(Assignee)

Comment 16

3 years ago
Majority of this bug is complete with the blur fixes. Micro perf improvement can be found here: https://bugzilla.mozilla.org/show_bug.cgi?id=1220798
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.