[meta] To fix xpcshell orange on emu-x86-kk, TaskCluster

RESOLVED WONTFIX

Status

Taskcluster
Platform and Services
P1
normal
RESOLVED WONTFIX
3 years ago
a year ago

People

(Reporter: hsinyi, Unassigned)

Tracking

(Depends on: 1 bug)

Details

(Whiteboard: [EMU] [CI])

(Reporter)

Comment 1

3 years ago
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #0)
> recent try:
> https://treeherder.allizom.org/#/jobs?repo=try&revision=b1cff608589c

Error message:

05:23:10     INFO - trying --xre-url
05:23:10     INFO - Downloading --xre-url to /home/worker/build/--xre-url
05:23:10     INFO - retry: Calling _download_file with args: ('--xre-url', '/home/worker/build/--xre-url'), kwargs: {}, attempt #1
05:23:10    FATAL - The file --xre-url does not exist
05:23:10    FATAL - Running post_fatal callback...
05:23:10    FATAL - Exiting -1

Comment 2

3 years ago
(In reply to Hsin-Yi Tsai [:hsinyi] from comment #1)
> (In reply to Hsin-Yi Tsai [:hsinyi] from comment #0)
> > recent try:
> > https://treeherder.allizom.org/#/jobs?repo=try&revision=b1cff608589c
> 
> Error message:
> 
> 05:23:10     INFO - trying --xre-url
> 05:23:10     INFO - Downloading --xre-url to /home/worker/build/--xre-url
> 05:23:10     INFO - retry: Calling _download_file with args: ('--xre-url',
> '/home/worker/build/--xre-url'), kwargs: {}, attempt #1
> 05:23:10    FATAL - The file --xre-url does not exist
> 05:23:10    FATAL - Running post_fatal callback...
> 05:23:10    FATAL - Exiting -1

Same root cause as Bug 1192121.
It is because b2g_emulator_xpcshell.yml requires "test_packages_url"[1] argument, but b2g_emulator_x86_base.yml misses defining "test_packages"[2][3].

[1] https://dxr.mozilla.org/mozilla-central/source/testing/taskcluster/tasks/tests/b2g_emulator_xpcshell.yml#22
[2] https://dxr.mozilla.org/mozilla-central/source/testing/taskcluster/mach_commands.py#354-360
[3] https://dxr.mozilla.org/mozilla-central/source/testing/taskcluster/tasks/builds/b2g_emulator_base.yml#30

Try Link:
https://treeherder.allizom.org/#/jobs?repo=try&revision=fff32fe0138b
(Reporter)

Comment 3

3 years ago
(In reply to John Dai[:johnz][:jdai] from comment #2)
> (In reply to Hsin-Yi Tsai [:hsinyi] from comment #1)
> > (In reply to Hsin-Yi Tsai [:hsinyi] from comment #0)
> > > recent try:
> > > https://treeherder.allizom.org/#/jobs?repo=try&revision=b1cff608589c
> > 
> > Error message:
> > 
> > 05:23:10     INFO - trying --xre-url
> > 05:23:10     INFO - Downloading --xre-url to /home/worker/build/--xre-url
> > 05:23:10     INFO - retry: Calling _download_file with args: ('--xre-url',
> > '/home/worker/build/--xre-url'), kwargs: {}, attempt #1
> > 05:23:10    FATAL - The file --xre-url does not exist
> > 05:23:10    FATAL - Running post_fatal callback...
> > 05:23:10    FATAL - Exiting -1
> 
> Same root cause as Bug 1192121.
> It is because b2g_emulator_xpcshell.yml requires "test_packages_url"[1]
> argument, but b2g_emulator_x86_base.yml misses defining
> "test_packages"[2][3].
> 
> [1]
> https://dxr.mozilla.org/mozilla-central/source/testing/taskcluster/tasks/
> tests/b2g_emulator_xpcshell.yml#22
> [2]
> https://dxr.mozilla.org/mozilla-central/source/testing/taskcluster/
> mach_commands.py#354-360
> [3]
> https://dxr.mozilla.org/mozilla-central/source/testing/taskcluster/tasks/
> builds/b2g_emulator_base.yml#30
> 
> Try Link:
> https://treeherder.allizom.org/#/jobs?repo=try&revision=fff32fe0138b

Thanks, John.
Could you help file another bug, and let's treat this one as a meta which depends on that new one?
(Reporter)

Updated

3 years ago
Depends on: 1192125
Summary: To fix xpcshell orange on emu-x86-kk, TaskCluster → [meta] To fix xpcshell orange on emu-x86-kk, TaskCluster

Comment 4

3 years ago
Now xpcshell can be ran on emulator-x86-kk [1], but most of them are timeout due to it takes too much time to push the necessary files to device.

==
09:34:51     INFO -  mozdevice Timeout exceeded for _runCmd call '/home/worker/build/emulator/b2g-distro/out/host/linux-x86/bin/adb -s emulator-5554 push /home/worker/build/tests/xpcshell/tests/xpcom/tests/unit/TestTArray /data/local/tests/xpcshell/xpcom/tests/unit/TestTArray'
09:34:51     INFO -  Traceback (most recent call last):
09:34:51     INFO -    File "runtestsb2g.py", line 228, in <module>
09:34:51     INFO -      main()
09:34:51     INFO -    File "runtestsb2g.py", line 221, in main
09:34:51     INFO -      run_remote_xpcshell(parser, options, args, log)
09:34:51     INFO -    File "runtestsb2g.py", line 198, in run_remote_xpcshell
09:34:51     INFO -      xpcsh = B2GXPCShellRemote(dm, options, args, log)
09:34:51     INFO -    File "/home/worker/build/tests/xpcshell/remotexpcshelltests.py", line 269, in __init__
09:34:51     INFO -      self.setupTestDir()
09:34:51     INFO -    File "runtestsb2g.py", line 67, in setupTestDir
09:34:51     INFO -      self.device.pushFile(os.path.join(root, filename), test_file, retryLimit=10)
09:34:51     INFO -    File "/home/worker/build/venv/local/lib/python2.7/site-packages/mozdevice/devicemanagerADB.py", line 216, in pushFile
09:34:51     INFO -      raise DMError("Error pushing file %s -> %s; output: %s" % (localname, destname, proc.output))
09:34:51     INFO -  mozdevice.devicemanager.DMError: Error pushing file /home/worker/build/tests/xpcshell/tests/xpcom/tests/unit/TestTArray -> /data/local/tests/xpcshell/xpcom/tests/unit/TestTArray; output: []
=========

[1] https://treeherder.allizom.org/#/jobs?repo=try&revision=b15a154b3144&filter-searchStr=X

Comment 5

3 years ago
If we specify the `--busybox` argument to runtestsb2g.py [1], mozdevice will zip all necessary files and push the zip one which can make the pushing much faster.

[1] http://ftp.mozilla.org/pub/mozilla.org/b2g/tinderbox-builds/b2g-inbound-emulator/1441082363/b2g-inbound_ubuntu64_vm-b2g-emulator_test-xpcshell-bm122-tests1-linux64-build133.txt.gz

Updated

3 years ago
Depends on: 1200928

Comment 6

3 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #5)
> If we specify the `--busybox` argument to runtestsb2g.py [1], mozdevice will
> zip all necessary files and push the zip one which can make the pushing much
> faster.
> 
> [1]
> http://ftp.mozilla.org/pub/mozilla.org/b2g/tinderbox-builds/b2g-inbound-
> emulator/1441082363/b2g-inbound_ubuntu64_vm-b2g-emulator_test-xpcshell-bm122-
> tests1-linux64-build133.txt.gz

File bug 1200928 for this.

Updated

3 years ago
Depends on: 1202310, 1202311
Thanks for the info!
(In reply to Thomas Zimmermann [:tzimmermann] [:tdz] from comment #7)
> Thanks for the info!

Oh, that was supposed to go into bug 1205694.

Updated

3 years ago
Depends on: 1207039
(Reporter)

Updated

2 years ago
Assignee: nobody → htsai

Updated

2 years ago
Depends on: 1213724

Updated

2 years ago
Depends on: 1213725

Updated

2 years ago
Status: NEW → ASSIGNED

Updated

2 years ago
Depends on: 1234972
Whiteboard: [EMU] [CI]

Updated

2 years ago
Depends on: 1215084

Updated

2 years ago
Depends on: 1206586

Updated

2 years ago
Depends on: 1235089

Updated

2 years ago
No longer depends on: 1206586

Updated

2 years ago
Depends on: 1166032

Updated

2 years ago
Depends on: 1241011

Updated

2 years ago
Depends on: 1199472
No longer depends on: 1241011
(Reporter)

Comment 9

2 years ago
I am un-assigning myself from this bug since a) the scope of this bug now is different from that when I took this, and b) this meta is blocked by several modules.
Assignee: htsai → nobody
Status: ASSIGNED → NEW
(Reporter)

Updated

2 years ago
Depends on: 1212393

Updated

2 years ago
Priority: -- → P1

Updated

2 years ago
Depends on: 1241831

Updated

2 years ago
Depends on: 1242820
Moving to TaskCluster component...
Component: TaskCluster → Integration
Product: Testing → Taskcluster
Component: Integration → Platform and Services
(Reporter)

Comment 11

a year ago
I don't think we are going to move this on due to the latest B2G announcement.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.