Restore about:privatebrowsing UI to before it was messed up by Project Chameleon styles

RESOLVED FIXED in seamonkey2.40

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: philip.chee, Assigned: philip.chee)

Tracking

(Blocks 1 bug, {regression})

Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.35 wontfix, seamonkey2.36 wontfix, seamonkey2.37 fixed, seamonkey2.38 fixed, seamonkey2.39 fixed, seamonkey2.40 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

4 years ago
+++ This bug was initially created as a clone of Bug #1133380 +++
> Bug 1125636 changed the theming of about:config which we were borrowing from.
Assignee

Comment 1

4 years ago
Restore the UI to before Project Chameleon
1. Revert XUL
1.1. Stop using in-content/info-pages.css and global/config.css
2. Copy styles that we need from the old config.css to aboutPrivateBrowsing.css
3. Copy PNGs from toolkit that we were using - some of which don't exist any more. I managed to find them in mozilla-release.

The result is that we don't depend on anything in toolkit theme for about:privatebrowsing
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #8645000 - Flags: ui-review?(stefanh)
Attachment #8645000 - Flags: review?(neil)

Comment 2

4 years ago
Comment on attachment 8645000 [details] [diff] [review]
Patch v1.0 Proposed fix.

I won't be able to look at this until after August 25. Karsten might be an option if you're in a hurry.
Comment on attachment 8645000 [details] [diff] [review]
Patch v1.0 Proposed fix.

Which version of aboutPrivateBrowsing.xul will third-party themes prefer?

Should Modern @import its config.css to avoid the duplication?

Speaking of which, are there plans to revert the look of about:config?
Attachment #8645000 - Flags: feedback?(kairo)
Attachment #8645000 - Flags: feedback?(alfredkayser)

Comment 4

4 years ago
I am ok with this change. This will make seamonkey less dependent on all the changes that are being done for Firefox (which I also don't like that much...)

Updated

4 years ago
Attachment #8645000 - Flags: feedback?(alfredkayser) → feedback+
Assignee

Comment 5

4 years ago
(In reply to neil@parkwaycc.co.uk from comment #3)
> Comment on attachment 8645000 [details] [diff] [review]
> Patch v1.0 Proposed fix.
> 
> Which version of aboutPrivateBrowsing.xul will third-party themes prefer?
I suspect the reverted version in my patch. I could ask the in the Theme Dev forum in Mozillazine.

> Should Modern @import its config.css to avoid the duplication?
I think misusing config.css to style the private browsing was sub-optimal. In Modern we could use in-content/info-pages.css if you want to avoid duplication. Plus in classic we override the toolkit info-pages.css

> Speaking of which, are there plans to revert the look of about:config?
It's on my TODO list but not exactly at the top of of the list. If someone else wants to do this, welcome.
Assignee

Comment 6

4 years ago
I've asked for comments from third party themers in Mozillazine:
http://forums.mozillazine.org/viewtopic.php?f=18&t=2954291
Comment on attachment 8645000 [details] [diff] [review]
Patch v1.0 Proposed fix.

I tested this on Windows, Mac and Linux, and it seems to be fine. You even restored an underline which had gone missing in the Modern theme!
Attachment #8645000 - Flags: review?(neil)
Attachment #8645000 - Flags: review+
Attachment #8645000 - Flags: feedback?(kairo)

Comment 8

4 years ago
FWIW, I prefer us keeping everything as close to Firefox as possible, as I'm following that with my theming work (also has the upside of actually releasing builds to the public), but as long as Firefox and SeaMonkey don't expect different content at the same chrome address, I can deal with differences.
Assignee

Comment 9

4 years ago
Patrick Dempsey agrees with Alfred Kayser.
Comment on attachment 8645000 [details] [diff] [review]
Patch v1.0 Proposed fix.

Yeah, this looks now like current release.
Attachment #8645000 - Flags: ui-review?(stefanh) → ui-review+
Assignee

Comment 11

4 years ago
http://hg.mozilla.org/comm-central/rev/87e3cb843f65
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.40
Assignee

Comment 12

4 years ago
Comment on attachment 8645000 [details] [diff] [review]
Patch v1.0 Proposed fix.

[Approval Request Comment]
Regression caused by (bug #): Bug 1097111 - Update all about: pages to Project Chameleon
User impact if declined: awful looking about:privatebrowsing in classic theme.
Testing completed (on m-c, etc.): baked on comm-central for a while.
Risk to taking this patch (and alternatives if risky): Low risk mostly CSS changes.
String changes made by this patch: None
Attachment #8645000 - Flags: approval-comm-release?
Attachment #8645000 - Flags: approval-comm-beta?
Attachment #8645000 - Flags: approval-comm-aurora?

Comment 13

4 years ago
Comment on attachment 8645000 [details] [diff] [review]
Patch v1.0 Proposed fix.

a=me
Attachment #8645000 - Flags: approval-comm-release?
Attachment #8645000 - Flags: approval-comm-release+
Attachment #8645000 - Flags: approval-comm-beta?
Attachment #8645000 - Flags: approval-comm-beta+
Attachment #8645000 - Flags: approval-comm-aurora?
Attachment #8645000 - Flags: approval-comm-aurora+

Comment 15

4 years ago
(In reply to neil@parkwaycc.co.uk from comment #3)
> Should Modern @import its config.css to avoid the duplication?
> Speaking of which, are there plans to revert the look of about:config?

Is there a bug for reverting about:config appearance in Classic already?

Also, about:support and about:addons are other shared Toolkit pages recently redesigned.

If there is consensus that the Chameleon style isn't wanted for SeaMonkey it should be consistently reverted (and adaptions are needed for Modern anyway whenever Toolkit makes any layout changes).

[I'm commenting here rather than in meta bug 1133743 given that more people are watching this bug.]
Assignee

Comment 16

4 years ago
There are two patches that need to land first:
1. comm-central Bug 1022354 Move override for defaultFavicon from content to classic skin now that Bug 1170207 is fixed
2. mozilla central Bug 1189918 - Theme overrides should work in safe mode for comm-central applications too.

Once these two bugs land we can safely use override directives in theme manifests without screwing up third party themes.
You need to log in before you can comment on or make changes to this bug.