Use HTTPS for Yahoo! Japan search provider

RESOLVED FIXED in Firefox 55

Status

Mozilla Localizations
ja / Japanese
RESOLVED FIXED
2 years ago
2 months ago

People

(Reporter: m_kato, Assigned: dynamis (Tomoya ASAI))

Tracking

unspecified
mozilla55

Firefox Tracking Flags

(firefox55 fixed)

Details

(URL)

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

2 years ago
Yahoo! Japan will provide HTTPS search page after 18 August.  (Now, it is still HTTP only yet)

http://promo.search.yahoo.co.jp/news/service/SSL.html

So could we change to HTTPS for Yahoo! Japan's search provider?
I'd say it's a dupe of bug 997215.
(Reporter)

Comment 2

2 years ago
(In reply to Francesco Lodolo [:flod] from comment #1)
> I'd say it's a dupe of bug 997215.

Yahoo Japan is NOT Yahoo!'s company.  It is Softbank (owner of Sprint).  Also, we don't use suggestion etc by Y! Japan.
(In reply to Makoto Kato [:m_kato] from comment #2)
> Yahoo Japan is NOT Yahoo!'s company.  It is Softbank (owner of Sprint). 

I don't understand what that changes. We need to update Yahoo searchplugins for ja and ja-JP-mac, and that request was originally done in bug 997215.

Also note that this is not the only issue we have with Yahoo searchplugins for Japanese: we'd need to update icons on desktop (16+32px), and mobile (bug 1179109), since the branding is still the old non-purple one.
(Reporter)

Comment 4

2 years ago
(In reply to Francesco Lodolo [:flod] from comment #3)
>
> Also note that this is not the only issue we have with Yahoo searchplugins
> for Japanese: we'd need to update icons on desktop (16+32px), and mobile
> (bug 1179109), since the branding is still the old non-purple one.

Incorrect.  The purple icon is Yahoo! US and their branches.  But Yahoo! Japan isn't

Current Yahoo! Japan logo is http://k.yimg.jp/images/top/sp2/cmn/logo-ns-131205.png.  Because Yahoo! Japan is Softbank's company and Yahoo! US is licensing logo and brand name to Softbank.
I suggest to re-read my previous comment.

(In reply to Francesco Lodolo [:flod] from comment #3)
> since the branding is still the old non-purple one.

Let me rephrase it: since Yahoo! in Japan still uses the old branding (red Y! on white background), not the new purple one, we need a 96px icon for Fennec. Also, white background won't work it.

I checked and realized that I already fixed the icon on desktop, embedding both 16px and 32px
http://hg.mozilla.org/releases/l10n/mozilla-aurora/ja/rev/4a4a60f00204
(Reporter)

Comment 6

2 years ago
(In reply to Francesco Lodolo [:flod] from comment #5)
> I suggest to re-read my previous comment.
> 
> (In reply to Francesco Lodolo [:flod] from comment #3)
> > since the branding is still the old non-purple one.
> 
> Let me rephrase it: since Yahoo! in Japan still uses the old branding (red
> Y! on white background), not the new purple one, we need a 96px icon for
> Fennec. Also, white background won't work it.
> 
> I checked and realized that I already fixed the icon on desktop, embedding
> both 16px and 32px
> http://hg.mozilla.org/releases/l10n/mozilla-aurora/ja/rev/4a4a60f00204

But current Yahoo! Japan logo into Firefox search box is old.  See bug 1119706.
(In reply to Makoto Kato [:m_kato] from comment #6)
> But current Yahoo! Japan logo into Firefox search box is old.  See bug
> 1119706.

Thanks, I missed that bug.
(Reporter)

Updated

2 months ago
Duplicate of this bug: 1351955
(Reporter)

Updated

2 months ago
Flags: needinfo?(bugzilla)
(Reporter)

Comment 9

2 months ago
(ASAI-san won't read bugzilla mail :-<, but I believe he is biz owner of this issue)
I was very disappointed when I filed (In reply to Makoto Kato [:m_kato] from comment #9)
> (ASAI-san won't read bugzilla mail :-<, but I believe he is biz owner of
> this issue)

Where is the contact, then?

If external contributors have no official contact at the moment, Mozilla Japan should either
1. publish an official contact,
2. change the owner to someone that read bugmail, or
3. have the current owner read bugmail.
Flags: needinfo?(m_kato)
(Reporter)

Comment 11

2 months ago
(In reply to Masatoshi Kimura [:emk] from comment #10)
> I was very disappointed when I filed (In reply to Makoto Kato [:m_kato] from
> comment #9)
> > (ASAI-san won't read bugzilla mail :-<, but I believe he is biz owner of
> > this issue)
> 
> Where is the contact, then?

I don't know.  If I know it, I will contact to him about this before filing this bug.  As long as I knew, he had a meeting with Yahoo Japan last year.  As long as I talked with him 2 years ago about this, he didn't still handle this...
Flags: needinfo?(m_kato)

Comment 12

2 months ago
I introduced a Yahoo!Japan person to Asai san, and held a meeting last August.
I was there for different agenda, so I am not in charge of this, but I have a meeting log.

From their answer, 
 - Search: we can change to HTTPS when we are ready after August 21th 2016.(No change in parameters)
 - Auction: Please wait until end of March 2017.(Changes in parameters are not decided.)

Therefore, we can just change to HTTPS for regular search. Also it is good chance to contact Yahoo!Japan again about Yahoo! Auction.
(Reporter)

Comment 13

2 months ago
Good news.

Kudo-san, we should update yahoo auction's icon design (bug 1278189) since they use 'ヤフオク' icon (background color is yellow) now.  Could you get current icon design of Yahoo Auction?

And, we don't update mobile icon of Yahoo Japan search yet. (bug 1259461).  So we need update status whether we can use high res icon.
(Reporter)

Comment 14

2 months ago
Francesco, could you change yahoo-jp.xml to HTTPS per comment #12?
Flags: needinfo?(francesco.lodolo)
(Assignee)

Comment 15

2 months ago
Created attachment 8853289 [details] [diff] [review]
Patch1: use HTTPS for Yahoo! Japan for fennec (for ja/ja-JP-mac l10n repo)

This is the patch to update Yahoo! search for Fennec in l10n (ja/ja-JP-mac) repo.
I'll add another patch to update search for Desktop in mozilla-central repo.
Flags: needinfo?(bugzilla)
Attachment #8853289 - Flags: review?(francesco.lodolo)
(Assignee)

Comment 16

2 months ago
Created attachment 8853291 [details] [diff] [review]
Patch1: use HTTPS for Yahoo! Japan for Firefox (for mozilla-central repo)

This is the patch to update Yahoo! search for Desktop Firefox in mozilla-central repo.
Please check and commit to mozilla-central repo.
Attachment #8853291 - Flags: review?(francesco.lodolo)
(Assignee)

Comment 17

2 months ago
Created attachment 8853302 [details] [diff] [review]
Patch3: use HTTPS for Yahoo! Japan for iOS Firefox (for firefox-ios repo)

This is the patch to update Yahoo! search for ios Firefox in firefox-ios repo.
Please review and commit to firefox-ios github repo.

search engine file:
https://github.com/mozilla-mobile/firefox-ios/blob/master/Client/Assets/Search/SearchPlugins/ja/yahoo-jp.xml

# sorry, previous patch was "patch2", not 2nd version of "patch1"
Attachment #8853302 - Flags: review?(francesco.lodolo)
Comment on attachment 8853302 [details] [diff] [review]
Patch3: use HTTPS for Yahoo! Japan for iOS Firefox (for firefox-ios repo)

Review of attachment 8853302 [details] [diff] [review]:
-----------------------------------------------------------------

We don't make direct changes to iOS, they're take from the mobile repository via script, and destined to change soon
Attachment #8853302 - Flags: review?(francesco.lodolo) → review-
Comment on attachment 8853291 [details] [diff] [review]
Patch1: use HTTPS for Yahoo! Japan for Firefox (for mozilla-central repo)

Review of attachment 8853291 [details] [diff] [review]:
-----------------------------------------------------------------

Changes look sane, but I'd prefer Mike to stamp them, since this is a partner.
Attachment #8853291 - Flags: review?(francesco.lodolo) → review?(mozilla)
Flags: needinfo?(francesco.lodolo)
Attachment #8853289 - Flags: review?(francesco.lodolo) → review?(mozilla)
Assignee: nobody → bugzilla

Updated

2 months ago
Attachment #8853291 - Flags: review?(mozilla) → review+

Comment 20

2 months ago
As stated, iOS is unnecessary right now.

Fennec patch should wait and go in after bug 1324045 into central.
(In reply to Mike Kaply [:mkaply] from comment #20)
> Fennec patch should wait and go in after bug 1324045 into central.

I think that we can land this in mozilla-aurora, I'll file a follow-up bug and assign it to myself to keep track of these changes after bug 1324045 lands.
Blocks: 1352450
Attachment #8853302 - Attachment is obsolete: true
Comment on attachment 8853289 [details] [diff] [review]
Patch1: use HTTPS for Yahoo! Japan for fennec (for ja/ja-JP-mac l10n repo)

I'm going to take care of this in bug 1352450, so we can land the desktop stuff and close this bug.
Attachment #8853289 - Flags: review?(mozilla)
Attachment #8853289 - Attachment is obsolete: true
Keywords: checkin-needed

Comment 23

2 months ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/dcade1e36862
"Use HTTPS for Yahoo! Japan search provider" r=mkaply
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/dcade1e36862
Status: NEW → RESOLVED
Last Resolved: 2 months ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.