Use standard modifier keys for the Mute Tab keyboard shortcut

VERIFIED FIXED in Firefox 42

Status

()

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: jaramat, Assigned: Ehsan)

Tracking

Trunk
Firefox 43
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox42 verified, firefox43 verified)

Details

Attachments

(1 attachment)

Reporter

Description

4 years ago
Current keyboard shortcut for muting a tab is Alt+Shift+M. While that may be acceptable on Mac or even Linux, Windows and Windows programs rarely use Alt+Shift as a keyboard combo.

Proposed change: Change it to Ctrl+M. Ctrl+M isn't a system-wide shortcut nor is it used internally in Firefox, so it's available. It's also easier to memorize and easier to hit with one hand (Alt+Shift+M is nearly impossible to hit).

Updated

4 years ago
Blocks: 486262
(In reply to jaramat from comment #0)
> Current keyboard shortcut for muting a tab is Alt+Shift+M. While that may be
> acceptable on Mac or even Linux, Windows and Windows programs rarely use
> Alt+Shift as a keyboard combo.

It's similarly odd on Linux as far as I can tell.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Change the Mute Tab keyboard shortcut to something else on Windows → Use standard modifier keys for the Mute Tab keyboard shortcut
Assignee

Comment 2

4 years ago
If Ctrl+M is free, this is reasonable.  I'll write a patch.
Assignee: nobody → ehsan
Assignee

Comment 3

4 years ago
(Note that Cmd+M minimizes the window on OSX, but we can use Ctrl+M there.)
Assignee

Comment 4

4 years ago
Also adding a test since I realized that I didn't do that before for some reason.
Attachment #8647196 - Flags: review?(jaws)
Assignee

Comment 5

4 years ago
Ping?
Comment on attachment 8647196 [details] [diff] [review]
Switch the keyboard shortcut to toggle the mute state of a tab to Ctrl+M

Review of attachment 8647196 [details] [diff] [review]:
-----------------------------------------------------------------

Weird, I already reviewed this but must not have hit Publish. Thanks for the ping.

::: browser/base/content/test/general/browser_audioTabIcon.js
@@ +275,5 @@
> +  }
> +  function* test_on_browser(browser) {
> +    let tab = gBrowser.getTabForBrowser(browser);
> +
> +    // Make sure it's possible to mute before the tab is playing.

This is a neat feature and I could see myself maybe using this, but I don't see a way for people to find out about it. Out of curiosity, is there any way to access this feature outside of the keyboard shortcut?
Attachment #8647196 - Flags: review?(jaws) → review+
Assignee

Comment 7

4 years ago
Not currently, no.  I've thought about it, and maybe we should add a context menu entry for muting a tab?
Assignee

Comment 8

4 years ago
(Note that users have asked for this too, see bug 1193848.)
Assignee

Comment 10

4 years ago
Comment on attachment 8647196 [details] [diff] [review]
Switch the keyboard shortcut to toggle the mute state of a tab to Ctrl+M

Approval Request Comment
[Feature/regressing bug #]: Tab audio indicators
[User impact if declined]: The current keyboard shortcut is hard to use.
[Describe test coverage new/current, TreeHerder]: Has test.
[Risks and why]: Not risky at all
[String/UUID change made/needed]: This doesn't have a string change, but it affects a string shown in the UI (the keyboard shortcut string in the tooltip message.)  Therefore I'd like to take it on Aurora ASAP.  Thanks!
Attachment #8647196 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/6930b12ee1d1
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Comment on attachment 8647196 [details] [diff] [review]
Switch the keyboard shortcut to toggle the mute state of a tab to Ctrl+M

Let's take this patch. We want to polish this feature!
Attachment #8647196 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed using latest Aurora 42.0a2 (buildID: 20150917004025) and latest Nightly 43.0a1 (buildID: 20150917030229).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.