Direct calls hang if the contact hasn't connected to the server at all

VERIFIED FIXED in Firefox 41

Status

defect
P1
normal
Rank:
15
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

({regression})

unspecified
mozilla43
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox40 wontfix, firefox41 verified, firefox42 verified, firefox43 verified)

Details

Attachments

(1 attachment)

STR

1) Start up a browser and sign-into FxA via Hello
2) Create a contact to an email address that should never have tried to connect to the system
3) Start a direct call to that contact

Actual Results

=> The conversation window appears and stays at "Connecting..."

Expected Results

=> The conversation window appears, shows "Connecting..." for a while, and then shows "user unavailable" (or whatever we should show).
The basic issue here is that we're trying to squeeze a number into a string which the action validator doesn't like, and so nothing the connection failure isn't being handled.

I've done some changes to use the failure details rather than the rest errnos - so one less place that's being used in the UI. Also included is extra test coverage to make sure we cover that branch.
Attachment #8647013 - Flags: review?(dmose)
Interestingly, the failure mode I see without this patch is not "user unavailable", but "there was a problem" (approximate german translation :-).
Comment on attachment 8647013 [details] [diff] [review]
Loop's Direct calls hang if the contact hasn't connected to the server at all.

Review of attachment 8647013 [details] [diff] [review]:
-----------------------------------------------------------------

r=dmose
Attachment #8647013 - Flags: review?(dmose) → review+
Comment on attachment 8647013 [details] [diff] [review]
Loop's Direct calls hang if the contact hasn't connected to the server at all.

Approval Request Comment
[Feature/regressing bug #]: Bug 1120003
[User impact if declined]: When attempting a direct call, in some circumstances the window may stop at "Connecting" and not report that the callee is unavailable.
[Describe test coverage new/current, TreeHerder]: Includes increased unit test coverage to handle this case.
[Risks and why]: Low, simple small fix to handle the failure reason properly
[String/UUID change made/needed]: None
Attachment #8647013 - Flags: approval-mozilla-beta?
Attachment #8647013 - Flags: approval-mozilla-aurora?
Rank: 15
Flags: qe-verify+
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/5c3a49360f3b
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Comment on attachment 8647013 [details] [diff] [review]
Loop's Direct calls hang if the contact hasn't connected to the server at all.

Patch has been in Nightly for a few days, seems safe to uplift to Aurora and Beta.
Attachment #8647013 - Flags: approval-mozilla-beta?
Attachment #8647013 - Flags: approval-mozilla-beta+
Attachment #8647013 - Flags: approval-mozilla-aurora?
Attachment #8647013 - Flags: approval-mozilla-aurora+
Reproduced the initial issue using old Nightly from 2015-08-12, verified that the issue is fixed using Firefox 41 beta 3, latest Developer Edition 42.0a2 and latest Nightly 43.0a1 across platforms (Windows 7 64-bit, Ubuntu 14.04 32-bit and Mac OS X 10.10.4).
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Duplicate of this bug: 1175090
Duplicate of this bug: 1189436
You need to log in before you can comment on or make changes to this bug.