Closed Bug 1194833 Opened 5 years ago Closed 5 years ago

Videos using Google IMA are broken by async plugin load #1116806

Categories

(Core :: Plug-ins, defect)

40 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1194600

People

(Reporter: nathan, Unassigned, NeedInfo)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.155 Safari/537.36

Steps to reproduce:

1) Go to https://google-developers.appspot.com/interactive-media-ads/docs/sdks/flash/vastinspector 
2) Click the Sample to fill in a sample VAST config
3) Click Test Ad
4) Most of the time the video will not play and the ad will not play (intermittently it works)
5) set dom.ipc.plugins.asyncInit to false
6) Repeat steps and ad will play and then video plays


Actual results:

No ad and no video played. Google's IMA-Flash toolkit is used all over the web for video ads and this breaks not only the ad, but also the video playback.


Expected results:

The ad should play followed by the sample video
(In reply to nathan from comment #0)
> User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_0)
> AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.155 Safari/537.36
> 
> Steps to reproduce:
> 
> 1) Go to
> https://google-developers.appspot.com/interactive-media-ads/docs/sdks/flash/
> vastinspector 
> 2) Click the Sample to fill in a sample VAST config
> 3) Click Test Ad
> 4) Most of the time the video will not play and the ad will not play
> (intermittently it works)
> 5) set dom.ipc.plugins.asyncInit to false
> 6) Repeat steps and ad will play and then video plays

To properly ascertain whether asyncInit is the cause, the browser should be restarted between steps (5) and (6). Can you please retest and include a restart?

Also, can you please provide more information about the computer that you were seeing this on? Firefox version? OS? Hardware specs? I ask because the video loads fine on my development machine, but I've fixed bugs before that would only appear on specific configurations.
Flags: needinfo?(nathan)
Hardware/Software:
Firefox 40.0.2 on OS 10.11
MacBook Pro (Retina, Mid 2012)/2.6 GHz Intel Core i7
8 GB 1600 MHz DDR3/NVIDIA GeForce GT 650M 1024 MB

ALSO: Our developer confirmed the bug earlier on Ubuntu(Not sure on Ubuntu version)/Firefox 40.0.2.
I can get more info on his machine on Monday if you are still not able to reproduce.

I restarted inbetween that setting and reconfirmed that with the default setting of the async load to true, the bug occurs and setting it to false, then restarting Firefox will make the bug go away.

Essentially when the bug happens, clicking the Test Ad button will make the video play button turn to pause, but nothing is playing. You can click the pause button and then play again, and then the video will play, but not the sample ad.

Our developer had the bug occur most times he refreshed, but occasionally the video played fine for him.
Flags: needinfo?(nathan)
Component: Untriaged → Plug-ins
Product: Firefox → Core
same here, confirmed with a coworker as well.

-- go to http://www.cbssports.com/video/player/golf/506374723784/0/pga-championship-recap
-- The page loads fine. The screen shows the flash loading animation.
-- The thumb for the CBS Simulcast fades out, indicating the player is trying to play a pre-roll.
-- Nothing happens beyond this point. No video (pre-roll or content) loads.

I've tried this four times with the same results(works fine on other browsers).

ff version 40.0.2

I'm also on a MacBook Air OS 10.7.5
We also have hundred automated test cases and it seems all firefox tests will be broken when the infrastructure for tests will update firefox to 40 next week.
Blocks: asyncplugininit-compat
No longer blocks: asyncplugininit
It would be good to verify the links in this bug in the next 41 beta.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Flags: qe-verify+
Resolution: --- → DUPLICATE
Duplicate of bug: 1194600
(In reply to Aaron Klotz [:aklotz] (please use needinfo) from comment #5)
> It would be good to verify the links in this bug in the next 41 beta.

Florin, can your team take a look at that?
Flags: needinfo?(florin.mezei)
I couldn't reproduce the initial issue with the links from comment 0 and comment 3 using Firefox 40RC (Win 7 64-bit and Mac OS X 10.9.5) and the async pref set to true. Could be because the websites were changed in the meantime.

Nathan, gdambrauskas is this fixed for you with latest Firefox beta 5? Thank you!  (https://ftp.mozilla.org/pub/mozilla.org/firefox/candidates/41.0b5-candidates/build1/ )
Flags: needinfo?(nathan)
Flags: needinfo?(gdambrauskas)
You need to log in before you can comment on or make changes to this bug.