Open Bug 1195138 Opened 4 years ago Updated 18 days ago

Dark GUI theme support

Categories

(Firefox for Android :: Theme and Visual Design, defect)

defect
Not set

Tracking

()

REOPENED

People

(Reporter: m_khvoinitsky, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150814092310
Valid request. Though it seems like a lot of work and light weight themes can substitute for feature request. https://addons.mozilla.org/en-US/android/search/?q=dark&cat=themes
Status: UNCONFIRMED → NEW
Ever confirmed: true
I imagine we'd just ship a default dark lightweight theme so I'm inclined to WONTFIX this.
FWIW, the icons and text are designed to change color to compensate for a dark background so the only improvements we could make by shipping a dark GUI not using lightweight themes would be to use more specific colors, maybe darken the content area in some way (e.g. inverse colors), and maybe change some of the other screens (e.g. tabs tray, which is already dark, or the infrequently used settings so it's not worth it).

The more I think about this, the more I'm thinking WONTFIX.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
And we wouldn't want to ship a dark theme by default to save APK size (e.g. bug 942609).

Though, maybe we can create a preference for a dark GUI and download the theme at runtime, after prompting the user...
Dark persona is very poor solution. It makes dark only top bar. A number of fennec's parts remain light:
* new tab page with all of its panels
* main and context menus
* search dialogs (both)
* addressbar
* settings (I agree that it is less important because of rare using)
* something that I've missed
Dark content can be achieved by addons (I'm a developer of such one).

There are a number of reasons why people can prefer dark themes including accessibility. For some people looking at light screens may be hard and/or painful or even harmful.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → WONTFIX
(In reply to Khvoinitsky Mikhail from comment #5)
> Dark persona is very poor solution. It makes dark only top bar. A number of
> fennec's parts remain light:

Okay, that's fair.

> Dark content can be achieved by addons (I'm a developer of such one).

Good to know.

> There are a number of reasons why people can prefer dark themes including
> accessibility. For some people looking at light screens may be hard and/or
> painful or even harmful.

And I am generally one of them so I would agree this seems worthwhile.

I think the best way to do this would be to have everything be a ThemedView and we declare the colors in XML. It'd be a bit of a pain because every view would need "setDarkMode" or similar called on them, though I suppose we can always just traverse the tree.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
This would be very nice to have now that the default theme is white in Nightly 57.
See Also: → 1388895
See Also: → 1389164
Private Browsing mode already sets a dark theme, right? Would this be a matter of adding a toggle which sets the same dark theme outside of Private Browsing too?
Duplicate of this bug: 1400592
(In reply to Khvoinitsky Mikhail from comment #5)
> Dark persona is very poor solution. It makes dark only top bar. A number of
> fennec's parts remain light:
> * new tab page with all of its panels
> * main and context menus
> * search dialogs (both)
> * addressbar
> * settings (I agree that it is less important because of rare using)
> * something that I've missed
> Dark content can be achieved by addons (I'm a developer of such one).
> 
> There are a number of reasons why people can prefer dark themes including
> accessibility. For some people looking at light screens may be hard and/or
> painful or even harmful.

Also statusbar remains white in firefox 57+
(In reply to Michael Smith [:mismith] from comment #8)
> Private Browsing mode already sets a dark theme, right? Would this be a
> matter of adding a toggle which sets the same dark theme outside of Private
> Browsing too?

As a first step probably yes - we could then always incrementally add Dark Theme support to more places (menus, home panels, etc.) as suggested in follow up bugs.

Also, any solution should probably be generic enough to allow this to be toggled
- for private tabs just as before (and maybe we want to keep some colour changes that are specific to just private mode, like using a different highlight colour (magenta?))
- through the settings menu
- through Reader View's dark mode
So any changes planned, implemented?
Atleast add a about:config entry to switch to private tab style theme in normal tabs before the photon ui lands in stable (please). Other details like highlight colour, menu, home panels can be sorted thereafter
Huge +1
I've just downloaded the latest beta and it's terribly white. Even current Fx has more greys which are more pleasant to the eye.
Please consider adding proper dark theme. On desktop FxDeveloperEdition has rather nice theme (though it lacks in some places).
Or at least consider using something less #FFFFFF...
Firefox 57 is going to stable branch. Has anything been planned? Personally i will hold on to 56 for some time
Firefox Nightly fixes the Android top bar for the most part, but the toolbar / address bar section still remains grey instead of the desired colour (e.g. black) when using a dark theme, as if the theme is only being drawn with 50% opacity.
Any news on this? Currently with substratum and https://play.google.com/store/apps/details?id=substratum.piereligio.bst we can get very nice result:
https://www.dropbox.com/s/oow9gn2my3u82d5/firefox-bookmarks.png?dl=0
https://www.dropbox.com/s/cy35zubufduv2t3/firefox-new_page.png?dl=0
https://www.dropbox.com/s/z5d2yu7sdja3gd7/firefox-settings.png?dl=0

But it would be very nice not to have use such solutions and have beautiful black (dark) theme natively…
Latest Firefox62 for iOS got dark theme support (vide https://blog.mozilla.org/blog/2018/09/05/latest-firefox-releases-available-today/). I do hope Android variant will get same treatment
Duplicate of this bug: 1578126
You need to log in before you can comment on or make changes to this bug.