Closed Bug 1195710 Opened 5 years ago Closed 4 years ago

[MAP]Implement PushMessage function

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.2r+, firefox43 fixed, b2g-v2.2r fixed)

RESOLVED FIXED
FxOS-S7 (18Sep)
feature-b2g 2.2r+
Tracking Status
firefox43 --- fixed
b2g-v2.2r --- fixed

People

(Reporter: shawnjohnjr, Assigned: shawnjohnjr)

References

Details

Attachments

(2 files, 4 obsolete files)

Implement PushMessage function.
Assignee: nobody → shuang
Comment on attachment 8649267 [details] [diff] [review]
bug1195710-mc.patch

I think I need to handle bMessage body first, cancel the review.
Attachment #8649267 - Attachment is obsolete: true
Attachment #8649267 - Flags: review?(btian)
Hi Ben,
I write bMessage parser in bug 1166647 which can take care of major work for parsing. For complete specification complaint, I prefer to keep some unused member variables/functions for native charset support.
Comment on attachment 8657715 [details] [diff] [review]
Bug 1195710 - [MAP]Implement PushMessage function

Review of attachment 8657715 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with comment addressed. Please confirm whether to rebase on bug 1195685 that removes BT_APPEND_NAMED_VALUE macro.

::: dom/bluetooth/BluetoothCommon.h
@@ +251,5 @@
>  /**
> + * When receiving a MAP request of 'push message' from a remote device,
> + * we'll dispatch an event.
> + */
> +#define MAP_PUSH_MESSAGE_REQ_ID              "mappushmessagereq"

Group MAP related ID as PBAP [1].

[1] https://dxr.mozilla.org/mozilla-central/source/dom/bluetooth/common/BluetoothCommon.h#198
Attachment #8657715 - Flags: review?(btian) → review+
Attachment #8660414 - Attachment description: Bug 1195710 - [MAP]Implement PushMessage function, r=btian → Bug 1195710 - [MAP]Implement PushMessage function, r=btian (v2.2r)
Attachment #8660413 - Attachment description: Bug 1195710 - [MAP]Implement PushMessage function, r=btian → Bug 1195710 - [MAP]Implement PushMessage function, r=btian (m-c)
https://hg.mozilla.org/mozilla-central/rev/af74f0f2ade6
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → FxOS-S7 (18Sep)
Wesley,
Could you please set feature v2.2r+?
Flags: needinfo?(whuang)
feature-b2g: --- → 2.2r+
Flags: needinfo?(whuang)
Hi, this failed to apply:

dding 1195710 to series file
renamed 1195710 -> bug1195710-v22r.patch
applying bug1195710-v22r.patch
patching file dom/bluetooth/BluetoothCommon.h
Hunk #1 FAILED at 118
1 out of 1 hunks FAILED -- saving rejects to file dom/bluetooth/BluetoothCommon.h.rej
patching file dom/bluetooth/bluedroid/BluetoothMapSmsManager.cpp
Hunk #1 FAILED at 326
Hunk #2 FAILED at 817
Hunk #3 FAILED at 982
3 out of 3 hunks FAILED -- saving rejects to file dom/bluetooth/bluedroid/BluetoothMapSmsManager.cpp.rej
patching file dom/bluetooth/bluedroid/BluetoothMapSmsManager.h
Hunk #1 FAILED at 93
1 out of 1 hunks FAILED -- saving rejects to file dom/bluetooth/bluedroid/BluetoothMapSmsManager.h.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working directory
errors during apply, please fix and refresh bug1195710-v22r.patch

could you take a look, thanks!
Flags: needinfo?(shuang)
Hi
It looks like the current v2.2r doesn't include patch sets:
1. bug1166679-v22r.patch
2. bug1186836-v22r.patch

bug1195710-v22r.patch depends on those two patches.
Flags: needinfo?(shuang)
Flags: needinfo?(cbook)
sorry i had to back this out in https://hg.mozilla.org/releases/mozilla-b2g37_v2_2r/rev/67d81601af97

seems one change here was causing a bustage like https://treeherder.mozilla.org/logviewer.html#?job_id=6599&repo=mozilla-b2g37_v2_2r
Status: RESOLVED → REOPENED
Flags: needinfo?(cbook) → needinfo?(shuang)
Resolution: FIXED → ---
Attachment #8660414 - Attachment is obsolete: true
Flags: needinfo?(shuang)
Attachment #8662131 - Attachment filename: bug1195710-v22r.patch → bug1195710-v22r.patch (v2.2r)
Attachment #8662131 - Attachment description: Bug 1195710 - [MAP]Implement PushMessage function, r=btian → Bug 1195710 - [MAP]Implement PushMessage function, r=btian (v2.2r)
Attachment #8662131 - Attachment filename: bug1195710-v22r.patch (v2.2r) → bug1195710-v22r.patch
(In reply to Carsten Book [:Tomcat] from comment #15)
> sorry i had to back this out in
> https://hg.mozilla.org/releases/mozilla-b2g37_v2_2r/rev/67d81601af97
> 
> seems one change here was causing a bustage like
> https://treeherder.mozilla.org/logviewer.html#?job_id=6599&repo=mozilla-
> b2g37_v2_2r

I found the bustage caused by this patch. I've rebase it again and it works locally. Sorry to increase your work load.
Flags: needinfo?(cbook)
(In reply to Shawn Huang [:shawnjohnjr] from comment #18)
> (In reply to Carsten Book [:Tomcat] from comment #15)
> > sorry i had to back this out in
> > https://hg.mozilla.org/releases/mozilla-b2g37_v2_2r/rev/67d81601af97
> > 
> > seems one change here was causing a bustage like
> > https://treeherder.mozilla.org/logviewer.html#?job_id=6599&repo=mozilla-
> > b2g37_v2_2r
> 
> I found the bustage caused by this patch. I've rebase it again and it works
> locally. Sorry to increase your work load.

no worries and absolutely no problem :)
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Flags: needinfo?(cbook)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.