Closed Bug 1195950 Opened 7 years ago Closed 7 years ago

Caching fails to reload large files completely like Silverlight xap files with Asynchronous Plugin Initialization enabled

Categories

(Core :: Plug-ins, defect)

40 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 1194600

People

(Reporter: jclgml, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150812163655

Steps to reproduce:

1) Goto a sight that has a large xap (silverlight file) and ok silverlight and let the app load. It should work fine the first time. 
Using FF 40 on Windows7 or Mac OS loading a silverlight xap file.

Example site that fails: http://www.scichart.com/Abt.Controls.SciChart.SL.ExampleTestPage.html
Our product is another SL app but it isn't on the public internet.

2) Click Reload and it fails to load. shows white screen.

Clicking reload many times it will eventually load sometimes.
Observed in debugger network tab the the size changes sometimes.


Actual results:

First time it works.
Second time it fails. Just a white screen. 
And reports this in the console:
Error: Unhandled Error in Silverlight Application 
Code: 2104    
Category: InitializeError       
Message: Could not download the Silverlight application. Check web server settings  
Also says XAP 206 Patial Content.
We believe this message is because the xap which is a zip file isn't a complete file and it can't uncompress it.

Clearing all cache can get it to work again.


Expected results:

It should load correctly each time and show loading spinner and then the SL app.

It works fine in FF 39. (Also 39 doesn't show xap in network tab but 40 does).
Downgraded to FF 39 and it works.
Lots of our customers use FF and they can't use our app so they are having to switch to another browser like Safari or IE to use our product.
Severity: normal → major
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Another Asynchronous Plugin Initialization issue.
Set about:config > dom.ipc.plugins.asyncInit=false (restart FF) as local workaround.

The hotfix will be in bug 1196000.
Status: UNCONFIRMED → NEW
Component: Untriaged → Plug-ins
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
Summary: Caching fails to reload large files completely like Silverlight xap files. → Caching fails to reload large files completely like Silverlight xap files with Asynchronous Plugin Initialization enabled
We should verify that this is fixed in the next 41 beta.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: qe-verify+
Resolution: --- → DUPLICATE
Duplicate of bug: 1194600
Reproduced with Firefox 40 RC.
Verified as fixed using Firefox 41 beta 5 under Win 7 64-bit and Mac OSX 10.9.5.
You need to log in before you can comment on or make changes to this bug.