Closed Bug 1196000 Opened 5 years ago Closed 5 years ago

Create hotfix addon to disable dom.ipc.plugins.asyncInit in Firefox 40

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Tracking Status
firefox40 + fixed

People

(Reporter: aklotz, Assigned: aklotz)

References

Details

Attachments

(1 file)

We need to disable this pref in 40 due to problems attached to bug 1195607.
Some documentation:
* https://developer.mozilla.org/en-US/Add-ons/Hotfix
* http://hg.mozilla.org/releases/firefox-hotfixes/file/tip/README

Previous pref-flip hotfix that you can `hg copy`:
* https://hg.mozilla.org/releases/firefox-hotfixes/file/tip/v20150402.01

Note that if you hotfix a pref-flip you likely should change the pref name for future builds so they users who have the pref flipped won't be stuck in that state for the future.
Aaron, does that help? 

Sylvestre, I tracked this and am needinfoing you so you don't miss it. 

We should probably file a followup bug to change the pref name for 41+.
Flags: needinfo?(sledru)
Attached patch PatchSplinter Review
Assignee: nobody → aklotz
Status: NEW → ASSIGNED
Attachment #8649582 - Flags: review?(felipc)
Attachment #8649582 - Flags: review?(felipc) → review+
The patch seems to be doing a rename instead of a copy. Please fix this before landing.
(In reply to Matthew N. [:MattN] from comment #4)
> The patch seems to be doing a rename instead of a copy. Please fix this
> before landing.

Fixed. Thanks for catching that.

Felipe, thanks for the prompt review!

https://hg.mozilla.org/releases/firefox-hotfixes/rev/856075827a2f
Blocks: 1196078
OK, thanks Liz! Please go ahead with the hotfix!
Flags: needinfo?(sledru)
Liz++
This fix would automatically reflect on all FF 40 clients irrespective of any firefox browser setting I assume? Is that correct? Or what needs to be enabled to see this fix?
Once it goes live it will be deployed to all versions of Firefox with automatic updates enabled. It hasn't gone live yet though.
This went live last night in bug 1196078, and should be in place now for Firefox 40 on all platforms.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Please change the default value of the prefs in beta41 and release40.0.3 tree.
Because the hotfix seems too slooooooooooooow to deployment through network for new profile.
Flags: needinfo?(aklotz)
See Bug 1198590. The pref has been disabled with Firefox 40.0.3.
Flags: needinfo?(aklotz)
Firefox 40.0.3 won't be proposed when i ask update from Firefox 40.0.2. Is it still beta?
(In reply to a_plancher from comment #13)
> Firefox 40.0.3 won't be proposed when i ask update from Firefox 40.0.2. Is
> it still beta?
40.0.3 is still building.
(In reply to Alice0775 White from comment #11)
> Because the hotfix seems too slooooooooooooow to deployment through network
> for new profile.

Hotfixes get out to users faster than Firefox updates do. That said, including a disabling patch in 40.0.3 was surely the right thing to do in any case.
Thanks for version 40.0.3, the problem is fixed
Welcome.
Fixing 40 as we pushed the hotfix & shipped 40.0.3
Depends on: 1202420
You need to log in before you can comment on or make changes to this bug.