Closed Bug 1197228 Opened 6 years ago Closed 6 years ago

Transparent BrowserSearch when searching on Android 2.3 phone when web content is in background

Categories

(Firefox for Android Graveyard :: Awesomescreen, defect)

43 Branch
All
Android
defect
Not set
normal

Tracking

(firefox41 unaffected, firefox42 unaffected, firefox43 affected, fennec43+)

RESOLVED WORKSFORME
Tracking Status
firefox41 --- unaffected
firefox42 --- unaffected
firefox43 --- affected
fennec 43+ ---

People

(Reporter: sebastian, Assigned: kats)

References

Details

(Keywords: regression)

Attachments

(1 file)

When searching on my Android 2.3 phone (HTC Desire HD) the search background is missing and you can see the website you have been visiting before (see attached screenshot).
Ioana please check if any of the SV devices repo this bug.
Flags: needinfo?(ioana.chiorean)
I removed the background as part of the search engine bar work (bug 1137483, landed in 41) – I guess I screwed up the styles. iirc, each item in the list should set it's own background color.
NI self to investigate.
Flags: needinfo?(michael.l.comella)
I'm able to reproduce on latest Nightly on HTC Desire HD (2.3.5) and HTC Desire S (2.3.3)
Flags: needinfo?(ioana.chiorean)
Duplicate of this bug: 1197802
I can reproduce. Notably, it does not repro with about:home – just web content.
Summary: No background when searching on Android 2.3 phone → Transparent BrowserSearch when searching on Android 2.3 phone when web content is in background
Assignee: nobody → michael.l.comella
Flags: needinfo?(michael.l.comella)
Ioana would the SV team find a rough regression range. Just the affected versions, no need to deep dive with mozregression.
tracking-fennec: --- → ?
Flags: needinfo?(ioana.chiorean)
Thanks Teodora for working on this one!
Flags: needinfo?(ioana.chiorean)
The only thing that stands out to me here is bug 1180295, the dynamic toolbar rewrite. Kats, any ideas if it might have affected this bug and how?
Flags: needinfo?(bugmail.mozilla)
I guess it's possible that bug 1180295 exposed this but it feels more like a pre-existing bug to me. None of my patches touched that view at all and also didn't fiddle with any view backgrounds.
Flags: needinfo?(bugmail.mozilla)
Sorry, I should have provided more context.

When we show BrowserSearch (i.e. click urlbar and start typing), we set the window's background drawable to white [1] to prevent graphical glitches from hiding the keyboard and the views on top of it are transparent in order to prevent overdraw. When BrowserSearch is hidden, we set the window's background drawable to null.

Presumably, the window's background drawable is not being set (or is being changed) on 2.3 devices – maybe it's an Android fragmentation discrepancy.

Kats, did you make any changes regarding the window's background drawable?

[1]: https://mxr.mozilla.org/mozilla-central/source/mobile/android/base/BrowserApp.java?rev=1c77317dd842#2811
Flags: needinfo?(bugmail.mozilla)
(In reply to Michael Comella (:mcomella) from comment #12)
> Kats, did you make any changes regarding the window's background drawable?

As far as I know I didn't touch any of this code.

> [1]:
> https://mxr.mozilla.org/mozilla-central/source/mobile/android/base/
> BrowserApp.java?rev=1c77317dd842#2811

I borrowed a Gingerbread device and can reproduce this bug. Adding some logging at this line of code shows that it is still getting hit as one would expect. So either it's not working (the Android fragmentation discrepancy you mentioned?) or the problem is elsewhere...
Flags: needinfo?(bugmail.mozilla)
Assignee: michael.l.comella → bugmail.mozilla
tracking-fennec: ? → 43+
I confirmed that this was caused by my patches; the bisection seemed to point to https://hg.mozilla.org/integration/mozilla-inbound/rev/b675e378dadf although that doesn't really make much sense. I'll dig into it.
The patches I posted to bug 1197811 seem to fix this as well.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.