Closed Bug 1197750 Opened 5 years ago Closed 5 years ago

[Contacts] After updating contacts, the old one and new one both exist, but they are same.

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master verified)

VERIFIED FIXED
FxOS-S6 (04Sep)
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- verified

People

(Reporter: yelanying, Assigned: mancas)

References

Details

(Keywords: regression, smoketest, Whiteboard: [NG Gaia Contacts][2.5-aries-test-run-1])

Attachments

(6 files)

Attached video Aries_KK v2.5.3gp
[1.Description]:
[Flame KK v2.5][Aries KK v2.5][Contacts] Add a contact and MO a call from it. Then update the contact, both the old contact and new contact exist. But they are same.
Time: 16:35
See attachments: Aries_KK v2.5.3gp and logcat_1635.txt

[2.Testing Steps]: 
Precondition: The DUT has an SIM card.
1.Launch Contacts.
2.New a contact with name and phone number.
3.Tap home button and tap contacts app.
4.Tap the contact and call the phone number.
5.Hang up the call and edit the contact.
6.Delete the old name and phone number, add the new name and phone number, then tap update button.
7.Go back to main view of Contacts, and enter the contact details view
8. Come back to main view of Contacts.

[3.Expected Result]: 
Step 7&8.It shows new one.

[4.Actual Result]: 
Step 7. It still shows former name in main view. 
Step 8. Two contacts are shown with different name on contact main view, but the header title is the same on these contacts' detail view.


[5.Reproduction build]: 
Device:FlameKK  v2.2 build (Unaffected)

Build ID               20150823032504
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/1effc4cb6414
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150823.065101
Firmware Date          Sun Aug 23 06:51:12 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: FlameKK v2.5 build (Affected)
Build ID               20150823150207
Gaia Revision          cddb9f610cbe03d0ca39d81bbdce46a0fca841ab
Gaia Date              2015-08-23 03:34:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4ccdd06e51d7209ba429196df7cab97bf66962db
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150823.184539
Firmware Date          Sun Aug 23 18:45:51 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device:AriesKK v2.5 build (Affected)
Build ID               20150823221817
Gaia Revision          cddb9f610cbe03d0ca39d81bbdce46a0fca841ab
Gaia Date              2015-08-23 03:34:38
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4ccdd06e51d7209ba429196df7cab97bf66962db
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150823.214038
Firmware Date          Sun Aug 23 21:40:46 UTC 2015
Bootloader             s1

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free test
Attached file logcat_1635.txt
That's likely a regression due to the NGA work. Let's proceed with a regression window. I'm pretty sure that a |git bisect| on the gaia repo will be fast enough.

[Blocking Requested - why for this release]: Functional regression.
blocking-b2g: --- → 2.5?
Side note: These STR would be a good integration test to have. Please ping me if you need any help in adding a Gij test, to catch this regression.
QA Contact: ddixon
B2G Inbound Regression Window

Last Working 

Device: Flame Master
BuildID: 20150819054940
Gaia: fa32b801f6d854e846ea8294dc37840450d36c1e
Gecko: 8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb
Version: 43.0a1 (Master) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

First Broken

Device: Flame Master
BuildID: 20150819061537
Gaia: b57de4c493b611dc70c27c7d78445fcb04b1491c
Gecko: 7feeb30abb6856d4176fd0e5eb7b45da18931c49
Version: 43.0a1 (Master) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Last Working Gaia and First Broken Gecko
Issue DOES NOT occur here:
Gaia: fa32b801f6d854e846ea8294dc37840450d36c1e
Gecko: 7feeb30abb6856d4176fd0e5eb7b45da18931c49

Last Working Gecko and First Broken Gaia
Issue DOES occur here: 
Gaia: b57de4c493b611dc70c27c7d78445fcb04b1491c
Gecko: 8643f1d9971c76c98bc32a07ae6d3760f3f3a4bb

B2G Inbound Pushlog (Gaia): 
https://github.com/mozilla-b2g/gaia/compare/fa32b801f6d854e846ea8294dc37840450d36c1e...b57de4c493b611dc70c27c7d78445fcb04b1491c

Possible Cause:

Bug 1183727 - [Contacts][NGA] Create #update view and connect it to #open within Contacts App
Blocks: 1183727
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Borja, can you have a look at it? Thanks a lot!
Flags: needinfo?(borja.bugzilla)
Whiteboard: [2.5-aries-test-run-1] → [NG Gaia Contacts][2.5-aries-test-run-1]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Target Milestone: --- → FxOS-S6 (04Sep)
Comms triage: Basic use case broken.
blocking-b2g: 2.5? → 2.5+
This bug can be reproduced on latest user build of Flame KK 2.5 and Aries KK 2.5 by another STR:
1. Launch Contacts App 
2. Navigate to an existing contact with a saved Name and Phone Number. 
3. Tap the Edit button in the top right corner.
4. Change the name of the contact then select the "Update" button.
5. Kill the Contacts App from task manager and reopen it.
6. Tap the contact and enter the contact detail page.  
7. Come back to main view of Contacts.
Actual Result: 
In step 5, It still shows former name in main view.
In step 6, It shows new name in main view.
In step 7, two contacts are shown with different name at "Contacts" view.

Rate: Flame KK 2.5 user build: 4/6; Aries KK 2.5 user build: 3/6
See attachment: logcat_2.5_user.txt, Flame KK_v2.5_user.3gp
Found time: 14:37

Device information:
Aries KK 2.5 user (Affected)
Build ID               20150827165844
Gaia Revision          d784c81961d82cbe9e111405468c590a8345856c
Gaia Date              2015-08-27 12:29:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ca086f9ef8bca2d6cdfa79bfc4c854f56a59859e
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150827.162200
Firmware Date          Thu Aug 27 16:22:07 UTC 2015
Bootloader             s1

Flame KK 2.5 user (Affected)
Build ID               20150827150209
Gaia Revision          d784c81961d82cbe9e111405468c590a8345856c
Gaia Date              2015-08-27 12:29:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ca086f9ef8bca2d6cdfa79bfc4c854f56a59859e
Gecko Version          43.0a1 
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150827.183006
Firmware Date          Thu Aug 27 18:30:19 EDT 2015
Bootloader             L1TC000118D0
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][MGSEI-Triage+]
It was failing TC-[1310]
Keywords: smoketest
Maria, is there someone else that you might be able to recommend to take a look at this please?  We would like to get this fixed before our next dogfood release.
Flags: needinfo?(oteo)
Sure, Manu is working on it.
Thanks!
Assignee: nobody → b.mcb
Status: NEW → ASSIGNED
Flags: needinfo?(oteo)
What happens when you kill and re-start the contacts app? Is the information updated?
I don't think we should block the next dogfood update if it works after you close the app.
Flags: needinfo?(yelanying)
Flags: needinfo?(borja.bugzilla)
(In reply to Gregor Wagner [:gwagner] from comment #13)
> What happens when you kill and re-start the contacts app? Is the information
> updated?

After step 7 in the STR described in comment 7, if you kill and restart the contacts app, the result is the same, the two contacts are shown with different name in the Contacts list. So the information is NOT properly updated and the issue is still there.
Flags: needinfo?(yelanying)
Comment on attachment 8656441 [details] [review]
[gaia] mancas:bug1197750 > mozilla-b2g:master

Hey Borja, take a look at the fix when you get a chance. Finally I've resolve the problem using cookies as you suggested =)
Attachment #8656441 - Flags: review?(borja.bugzilla)
Manuel, could this also fix bug 1201211?
Flags: needinfo?(b.mcb)
Attachment #8656441 - Flags: review?(borja.bugzilla) → review+
https://github.com/mozilla-b2g/gaia/commit/e17fc1581b24b1e42fad6ecf6325fecfa9c9a8ed
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Hi Jessica,

Please help to verify, thanks.
Flags: needinfo?(yelanying)
Keywords: verifyme
According to the STR of Comment 0 and Comment 7, this bug has been verified as pass on latest Flame KK v2.5 and Aries KK v2.5.

Actual results: It shows new one only.
See attachment: verified_Aries KK v2.5.3gp
Reproduce rate: 0/6


Device: Flame KK v2.5 (Pass)
Build ID               20150905150219
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.183746
Firmware Date          Sat Sep  5 18:38:03 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0


Device: Aries KK v2.5 (Pass)
Build ID               20150905112803
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150905.105729
Firmware Date          Sat Sep  5 10:57:37 UTC 2015
Bootloader             s1
Flags: needinfo?(yelanying)
Status: RESOLVED → VERIFIED
Keywords: verifyme
Depends on: 1206054
Flags: needinfo?(b.mcb)
You need to log in before you can comment on or make changes to this bug.