Closed Bug 1198724 Opened 5 years ago Closed 5 years ago

Update pdf.js to version 1.1.403

Categories

(Firefox :: PDF Viewer, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 43
Tracking Status
firefox41 --- fixed
firefox42 --- fixed
firefox43 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #1188344 +++

Changes since last update:
#6321 Removes PdfRedirector.js and PlayPreview support.
#6325 Version 1.1.366
#6314 Fix regressions affecting both the 'pagemode' hash parameter and certain 'namedaction' types (PR 5971)
#6327 Prevent switching to disabled views (i.e. outline or attachments) in the sidebar
#6329 cmaps: Use cmap.forEach instead of Array.forEach
#6354 Fix typo in `drawFigures`, in webgl.js, which causes shadingPatterns with `figure.type === triangles` to render incorrectly
#6349 Fixes supportsMozChunked for node.js
#6233 Improve support for viewing PDFs from file://-URLs in the Chrome extension
#6366 Only take the fast-path in `PDFImage_createImageData` for un-masked JPEG images with "standard" colour spaces (issue 6364)
#6141 Provide a fallback for font rendering when not allowed to use `eval`
#6332 Serialize errors before invoking postMessage
#6370 api/getDocument: handle ArrayBuffer check for PDF binary data (byteLength)
#6372 Also check `maybeLength` when deciding if a stream is empty in `Parser_makeFilter` (issue 6360, bug 1191694)
#6375 Make `XRef_indexObjects` more robust against bad PDF files (issue 5752)
#6337 Adjust which TrueType (3, 1) glyphs we attempt to skip mapping of (issue 6336)
For whoever wants to rubberstamp it first.
Attachment #8652830 - Flags: review?(ydelendik)
Attachment #8652830 - Flags: review?(bdahl)
Comment on attachment 8652830 [details] [diff] [review]
Update pdf.js to version 1.1.403

Review of attachment 8652830 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good
Attachment #8652830 - Flags: review?(ydelendik)
Attachment #8652830 - Flags: review?(bdahl)
Attachment #8652830 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/e4ac926b246b
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 43
Uplifts:
#6372 Also check `maybeLength` when deciding if a stream is empty in `Parser_makeFilter` (issue 6360, bug 1191694)
#6375 Make `XRef_indexObjects` more robust against bad PDF files (issue 5752)

Approval Request Comment
[Feature/regressing bug #]: Improves our ability to successfully parse and render various corrupt PDF files.
[User impact if declined]: Bug 1191694 will remain broken in Firefox 42.
[Describe test coverage new/current, TreeHerder]: Covered by the PDF.js test-suite on GitHub.
[Risks and why]: Low risk; this is already present in mozilla-central.
[String/UUID change made/needed]: None.
Attachment #8654841 - Flags: review?(ydelendik)
Attachment #8654841 - Flags: approval-mozilla-aurora?
Attachment #8654841 - Flags: review?(ydelendik) → review+
Comment on attachment 8654841 [details] [diff] [review]
bug-1198724-aurora-xref.patch

Looks like an interesting new upstream release, taking it.
Attachment #8654841 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Uplifts:
#6372 Also check `maybeLength` when deciding if a stream is empty in `Parser_makeFilter` (issue 6360, bug 1191694)
#6375 Make `XRef_indexObjects` more robust against bad PDF files (issue 5752)

Approval Request Comment
[Feature/regressing bug #]: Improves our ability to successfully parse and render various corrupt PDF files.
[User impact if declined]: Bug 1191694 will remain broken in Firefox 41.
[Describe test coverage new/current, TreeHerder]: Covered by the PDF.js test-suite on GitHub.
[Risks and why]: Low risk; this is already present in mozilla-central and mozilla-aurora.
[String/UUID change made/needed]: None.
Attachment #8655632 - Flags: review?(ydelendik)
Attachment #8655632 - Flags: approval-mozilla-beta?
Attachment #8655632 - Flags: review?(ydelendik) → review+
Comment on attachment 8655632 [details] [diff] [review]
bug-1198724-beta-xref.patch

PDF corrupt issue in bug 1191694 is pretty severe, seems like a good idea to take a fix in Beta41.
Attachment #8655632 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Just an archaeology note, note that Fx41/Fx42 are being marked "fixed" here even though they're receiving a few cherry-picked fixes rather than the entire 1.1.403 update that Fx43 received.
Blocks: 1205051
No longer blocks: 1205051
Type: defect → task
No longer depends on: 1188344
You need to log in before you can comment on or make changes to this bug.