[systems] notifications for incoming calls/sms doesn't show contact names

RESOLVED INVALID

Status

Firefox OS
Gaia::Feedback
P2
normal
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: amylee, Unassigned)

Tracking

({foxfood})

unspecified
foxfood

Firefox Tracking Flags

(blocking-b2g:2.5+)

Details

(Whiteboard: [bzlite])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User-Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Incoming calls/sms notifications doesn't show caller's name until you open the app even if they are in your contacts list.
Please add screenshot and logs. 

Thanks
Flags: needinfo?(amlee)
Keywords: qawanted
I was unable to reproduce this issue on the latest Flame or Aries builds.  Leaving the tag so someone else can try.

Results: The contact name was shown in the notifications for sms and calls.
	
Environmental Variables:
Device: Aries 2.5
BuildID: 20150901190824
Gaia: c2582f4be03cd12124b96a263c8d14c774f0ffe4
Gecko: e47423c019643792e6de894cfcee598dead4d3ba
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20150901110122
Gaia: c2582f4be03cd12124b96a263c8d14c774f0ffe4
Gecko: e47423c019643792e6de894cfcee598dead4d3ba
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20150826030209
Gaia: c1ae9f02f2a9cfb89bf67aeea97e467c41c3362c
Gecko: f61c3cc0eb8b7533818e7379ccc063b611015d9d
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
This bug looks similar to this scenario https://bugzilla.mozilla.org/show_bug.cgi?id=1185287#c5 however I wasn't able to reproduce this bug using our T Mobile SIM. Initially I tried with AT&T SIM and couldn't repro either.

Reporter, please check bug 1185287 comment 4 or comment 5 and see if your situation falls under that.

Device: Aries 2.5
BuildID: 20150901190712
Gaia: c2582f4be03cd12124b96a263c8d14c774f0ffe4
Gecko: e47423c019643792e6de894cfcee598dead4d3ba
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Device: Flame 2.5
BuildID: 20150901030202
Gaia: c80e8ff25425b007181fd6e3de0500a0358fab37
Gecko: cafb1c90f794a73100a8f0afb9fe3301df0f2bde
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Leaving qawanted tag for others to attempt.
Flags: needinfo?(jmercado)
Flags: needinfo?(jmercado)
(Reporter)

Comment 4

2 years ago
(In reply to Mahendra Potharaju [:mahe] from comment #1)
> Please add screenshot and logs. 
> 
> Thanks

Hi, 

Yes it seems to have only have the issue if you have 1 at the start of the number. When I imported my contacts from my google address book all my contact numbers have a 1 before the contact's phone number. It seems to be a hassle if you have to manually remove the 1 in all contacts in order for their name to show up.
Flags: needinfo?(amlee)
(Reporter)

Comment 5

2 years ago
Created attachment 8657216 [details]
2015-09-04-13-13-54.png

Screenshots for reference. Phone number blocked out for privacy.
(Reporter)

Comment 6

2 years ago
Created attachment 8657217 [details]
2015-09-04-13-14-07.png

Screenshots for reference. Phone number blocked out for privacy.
Thank you Amy. 

Setting a P2 priority and blocking for B2G.
blocking-b2g: --- → 2.5+
Priority: -- → P2
Per comment 4 this issue is actually a dupe of bug 1114525 which has had work done on it.  I will nominate that bug as a blocker.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1114525
Sorry, I don't see how this is a dupe from bug 1114525.
Bug 1114525 is happening when the user imported/added some contacts without international prefix while being in roaming condition. I don't see this information here. Unduping for now.

Amy, it's important to know if you have the same issue in Dialer and in SMS. (I mainly know about the behavior in the SMS app of course).

Also, Amy, I'd like to know if you imported your contacts while in a roaming condition (for example, while in Whistler). If yes, can you try to "just" edit one of those contacts, and save it with no change, and see if the issue still happens ? If yes, it's definitely bug 1114525.

Also, I don't understand what this means:
> Yes it seems to have only have the issue if you have 1 at the start of the number.
Status: RESOLVED → REOPENED
Flags: needinfo?(amlee)
Resolution: DUPLICATE → ---
(Reporter)

Comment 10

2 years ago
(In reply to Julien Wajsberg [:julienw] (PTO Sept 2nd -> Sept 10th) from comment #9)
> Sorry, I don't see how this is a dupe from bug 1114525.
> Bug 1114525 is happening when the user imported/added some contacts without
> international prefix while being in roaming condition. I don't see this
> information here. Unduping for now.
> 
> Amy, it's important to know if you have the same issue in Dialer and in SMS.
> (I mainly know about the behavior in the SMS app of course).
> 
> Also, Amy, I'd like to know if you imported your contacts while in a roaming
> condition (for example, while in Whistler). If yes, can you try to "just"
> edit one of those contacts, and save it with no change, and see if the issue
> still happens ? If yes, it's definitely bug 1114525.
> 
> Also, I don't understand what this means:
> > Yes it seems to have only have the issue if you have 1 at the start of the number.

Hi, 

Just tried SMS/Dialer. Tested it by adding a "1" before the contact number and then removing it and sending incoming calls/sms from that number. I seem to only have issues with certain numbers but I'm not sure why. The area code is the same when I tested it with a few numbers. I was not roaming when I imported my contacts.

Sometimes when you import contacts it adds a "1" at the start of the number. 

When I said adding a 1
Flags: needinfo?(amlee)
Amy, it would help if you can share privately your contact DB by mail (julien AT mozilla.com) for further analysis, and indicate me which phone numbers have an issue.
To fetch your DB, you can try this command from an empty folder:

  abb pull /data/local/storage/permanent/chrome/idb/*csot*

THen you can zip this folder and send me the zip file.

Thanks !
Flags: needinfo?(amlee)
(Reporter)

Comment 12

2 years ago
(In reply to Julien Wajsberg [:julienw] (PTO Sept 2nd -> Sept 10th) from comment #11)
> Amy, it would help if you can share privately your contact DB by mail
> (julien AT mozilla.com) for further analysis, and indicate me which phone
> numbers have an issue.
> To fetch your DB, you can try this command from an empty folder:
> 
>   abb pull /data/local/storage/permanent/chrome/idb/*csot*
> 
> THen you can zip this folder and send me the zip file.
> 
> Thanks !

Hi Julien, 

I seem to have found the issue. When I went into the contact's name and selected "Find duplicate contacts" it had found a duplicate number. I deleted the duplicate and the person's name now shows up normally when I receive incoming calls/sms.
Flags: needinfo?(amlee)
Hum, this is still weird. I think that because you modified the contact, he got reindexed and so it shows up correctly now.

We still don't know why it was badly indexed in the first place though :/

If you still have some contacts that behave strangely, I'd still like to have a peek at your DB, if this is not an issue for you.

Otherwise I think we can close this bug.
(Reporter)

Comment 14

2 years ago
(In reply to Julien Wajsberg [:julienw] (PTO Sept 2nd -> Sept 10th) from comment #13)
> Hum, this is still weird. I think that because you modified the contact, he
> got reindexed and so it shows up correctly now.
> 
> We still don't know why it was badly indexed in the first place though :/
> 
> If you still have some contacts that behave strangely, I'd still like to
> have a peek at your DB, if this is not an issue for you.
> 
> Otherwise I think we can close this bug.

Hi Julien, 

This was the only contact I had an issue with when I imported my contacts. I had manually added the contact to my phone and then I imported my contacts through my sim which resulted in a duplicate. I'm not entirely comfortable sending out my DB since it's other people's information I am handling.
I understand, no problem. I'm glad you got it working now :)

Let's close this bug then.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → INVALID
Flags: needinfo?(jmercado)
Keywords: qawanted
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.