Closed Bug 1199032 Opened 6 years ago Closed 6 years ago

Intermittent test_seek-2.html,test_seek-5.html | application crashed [@ vp8_loop_filter_partial_frame] with WebMDemuxer on the stack

Categories

(Core :: Audio/Video: Playback, defect, P2)

Unspecified
Windows
defect

Tracking

()

RESOLVED FIXED
mozilla43
Tracking Status
firefox41 --- unaffected
firefox42 --- fixed
firefox43 --- fixed
firefox-esr38 --- unaffected

People

(Reporter: RyanVM, Assigned: jya)

References

Details

(Keywords: crash, intermittent-failure)

Attachments

(2 files)

No description provided.
Flags: needinfo?(jyavenard)
It could be the same than bug 1197977. Let see how that pans out.
Flags: needinfo?(jyavenard)
Depends on: 1197977
Priority: -- → P2
Relying on the data being fully buffered or not turned out to not be such a great idea.

Carrying r+ from bug 1197977
Attachment #8653861 - Flags: review+
Assignee: nobody → jyavenard
Blocks: 1197083
https://hg.mozilla.org/mozilla-central/rev/dc5303bf455e
https://hg.mozilla.org/mozilla-central/rev/e721a91c36c0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Backed out for a youtube playback regression. See Bug 1199573.
https://hg.mozilla.org/releases/mozilla-aurora/rev/5bb661db5c6c
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1199776
Isn't it great to know a fix for an intermittent test failure actually fixed a real world test case!
hey jya: can you request approval for aurora etc here since this touch more than just the test, thanks!
Flags: needinfo?(jyavenard)
This one has blanket approval by way of bug 1197083. Rillian is managing those uplifts.
Flags: needinfo?(jyavenard)
You need to log in before you can comment on or make changes to this bug.