Rename dom.ipc.plugins.asyncInit

VERIFIED FIXED in Firefox 41

Status

()

Core
Plug-ins
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: aklotz, Assigned: aklotz)

Tracking

unspecified
mozilla43
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox41+ verified, firefox42 verified, firefox43 verified)

Details

Attachments

(2 attachments)

The deployment of the asyncInit hotfix from bug 1196000 means that we need to rename the asyncInit pref in order to re-enable the feature.
We should make sure to get this checked in and uplifted to  beta before we build the RC for 41.
status-firefox41: --- → affected
tracking-firefox41: --- → +
Duplicate of this bug: 1202420

Comment 3

2 years ago
Aaron, do we have a patch ready for uplift to Beta on this one? We gtb Beta9 on Thursday.
Flags: needinfo?(aklotz)
Created attachment 8658565 [details] [diff] [review]
Patch
Flags: needinfo?(aklotz)
Attachment #8658565 - Flags: review?(gfritzsche)
Comment on attachment 8658565 [details] [diff] [review]
Patch

Georg is on PTO, stealing
Attachment #8658565 - Flags: review?(gfritzsche) → review+

Comment 6

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/10ff4337ccec
Comment on attachment 8658565 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: async plugin init
[User impact if declined]: Feature will be disabled on 41 release for most users
[Describe test coverage new/current, TreeHerder]: Plugin test suite
[Risks and why]: None, pref rename, trivial patch
[String/UUID change made/needed]: None
Attachment #8658565 - Flags: approval-mozilla-beta?
Attachment #8658565 - Flags: approval-mozilla-aurora?

Comment 8

2 years ago
Comment on attachment 8658565 [details] [diff] [review]
Patch

Looks good, let's uplift to Beta41 and Aurora42.
Attachment #8658565 - Flags: approval-mozilla-beta?
Attachment #8658565 - Flags: approval-mozilla-beta+
Attachment #8658565 - Flags: approval-mozilla-aurora?
Attachment #8658565 - Flags: approval-mozilla-aurora+

Updated

2 years ago
status-firefox42: --- → affected
https://hg.mozilla.org/releases/mozilla-beta/rev/f793392aa520
status-firefox41: affected → fixed
https://hg.mozilla.org/mozilla-central/rev/10ff4337ccec
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox43: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Assigning to Petruta for a quick check on Beta 41, since this impacts the Async Plugin Init feature.
Flags: qe-verify+
QA Contact: petruta.rasa
Him this cause conflicts when uplifting:

3 files to edit
merging toolkit/components/telemetry/TelemetryEnvironment.jsm failed!
merging toolkit/components/telemetry/TelemetrySession.jsm  

could you take a look, thanks!
Flags: needinfo?(aklotz)
Verified that the pref dom.ipc.plugins.asyncInit.enabled is true on Firefox 41 beta 9 under Win 7 64-bit and Mac OS X 10.9.5 when using new profiles.

I've opened Firefox 41 beta 8 and set the old pref dom.ipc.plugins.asyncInit to false, then I've updated to Firefox 41 beta 9 (beta-localtest channel). After restart, both prefs were present. 
Is this expected? Will the old pref no longer be taken into consideration?
status-firefox41: fixed → verified
status-firefox41: verified → fixed
Added this to the site compat doc: https://www.fxsitecompat.com/en-US/docs/2015/some-plug-in-content-may-not-be-loaded-due-to-async-initialization/
(In reply to Petruta Rasa [QA] [:petruta] from comment #13)
> I've opened Firefox 41 beta 8 and set the old pref dom.ipc.plugins.asyncInit
> to false, then I've updated to Firefox 41 beta 9 (beta-localtest channel).
> After restart, both prefs were present. 
> Is this expected? Will the old pref no longer be taken into consideration?

Seen with Aaron, this is expected. Marking as verified and removing the flag.
status-firefox41: fixed → verified
Flags: qe-verify+
Flags: needinfo?(aklotz)
(In reply to Carsten Book [:Tomcat] from comment #12)
> Him this cause conflicts when uplifting:
> 
> 3 files to edit
> merging toolkit/components/telemetry/TelemetryEnvironment.jsm failed!
> merging toolkit/components/telemetry/TelemetrySession.jsm  
> 
> could you take a look, thanks!

arron: the need-info was for this conflict, was this solved ?
Flags: needinfo?(aklotz)
Created attachment 8665495 [details] [diff] [review]
Patch for 42

Sorry about that. This one is rebased to 42.
Flags: needinfo?(aklotz)
Attachment #8665495 - Flags: review+
https://hg.mozilla.org/releases/mozilla-beta/rev/2cf009c8bde3
status-firefox42: affected → fixed
Flags: qe-verify+
Verified as fixed using Firefox 42 beta 2 under Win 7 64-bit and Mac OS X 10.9.5.
status-firefox42: fixed → verified

Comment 20

2 years ago
Sorry for my ignorance, why we didn't set this to "false" for beta as well? It constantly hangs for me.
(In reply to Benjamin Peng from comment #20)
> Sorry for my ignorance, why we didn't set this to "false" for beta as well?
> It constantly hangs for me.

The short answer is that it is being shut off on 42 beta in bug 1216665 so that some other changes that I've made to IPC can be phased into release separately from this feature.
Verified that pref dom.ipc.plugins.asyncInit.enabled replaced the old pref in Firefox 43 beta 1. Currently it is set to false.
Status: RESOLVED → VERIFIED
status-firefox43: fixed → verified
You need to log in before you can comment on or make changes to this bug.