system-cairo causes firefox-40 to crash

UNCONFIRMED
Unassigned

Status

()

Core
Graphics
P3
normal
UNCONFIRMED
3 years ago
7 months ago

People

(Reporter: Matthew Thode, Unassigned, NeedInfo)

Tracking

40 Branch
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: gfx-noted, URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150822000330

Steps to reproduce:

compile firefox with --enable-system-cairo
go to youtube and watch some videos or generally browse around for an hour or so
crash


Actual results:

no debug symbols...


(gdb) bt
#0  0x00007fed5f32d009 in raise () from /lib64/libpthread.so.0
#1  0x00007fed5bfcd31f in ?? () from /usr/lib64/firefox/libxul.so
#2  0x00007fed5c38b6c1 in ?? () from /usr/lib64/firefox/libxul.so
#3  <signal handler called>
#4  0x00007fed5c607594 in ?? () from /usr/lib64/firefox/libxul.so
#5  0x00007fed5c607914 in ?? () from /usr/lib64/firefox/libxul.so
#6  0x00007fed5c630ee2 in ?? () from /usr/lib64/firefox/libxul.so
#7  0x00007fed5c63143a in ?? () from /usr/lib64/firefox/libxul.so
#8  0x00007fed5c476663 in ?? () from /usr/lib64/firefox/libxul.so
#9  0x00007fed5c476912 in ?? () from /usr/lib64/firefox/libxul.so
#10 0x00007fed5c8043a0 in ?? () from /usr/lib64/firefox/libxul.so
#11 0x00007fed5c4769ed in ?? () from /usr/lib64/firefox/libxul.so
#12 0x00007fed5c4781f8 in ?? () from /usr/lib64/firefox/libxul.so
#13 0x00007fed5c62a8d9 in ?? () from /usr/lib64/firefox/libxul.so
#14 0x00007fed5f739630 in ?? ()
#15 0x0000000000000000 in ?? ()

and another core dump:
Core was generated by `/usr/lib64/firefox/plugin-container /opt/google/talkplugin/libnpgoogletalk.so -'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00000000004082bc in WebCore::Decimal::operator/(WebCore::Decimal const&) const ()
(gdb) bt
#0  0x00000000004082bc in WebCore::Decimal::operator/(WebCore::Decimal const&) const ()
#1  0x6f727265206c656e in ?? ()
#2  0x656c6966203a2e72 in ?? ()
#3  0x6f702f706d742f20 in ?? ()
#4  0x77772f6567617472 in ?? ()
#5  0x746e65696c632d77 in ?? ()
#6  0x786f66657269662f in ?? ()
#7  0x2f322e302e30342d in ?? ()
#8  0x7a6f6d2f6b726f77 in ?? ()
#9  0x6c65722d616c6c69 in ?? ()
#10 0x6370692f65736165 in ?? ()
#11 0x654d2f65756c672f in ?? ()
#12 0x6168436567617373 in ?? ()
#13 0x7070632e6c656e6e in ?? ()
#14 0x3120656e696c202c in ?? ()
#15 0x0000000000393536 in ?? ()
#16 0x0000000000000005 in ?? ()
#17 0x0000000000000000 in ?? ()
(Reporter)

Comment 1

3 years ago
With system cairo we can disable omtc and be fine as well. Could this be an issue with the version of cairo we compile against.  We are using 1.14.2.
OS: Unspecified → Linux
(Reporter)

Comment 2

3 years ago
If you let me know what specifically I can to to get better test data I'm willing to work, recompile, etc.

Comment 3

3 years ago
Could you remove the google talk plugin and retest? 
Without any firefox plugins, I can only get it to freeze my videos(see: https://bugzilla.mozilla.org/show_bug.cgi?id=1193520 ) but not crash firefox.

But, I can get it to crash very rarely(could take days)(with 40.0.2) but that's another issue (in gst-plugins-libav(1.4.5-r1) not doing the right padding for ffmpeg, see https://bugs.gentoo.org/show_bug.cgi?id=555738#c2  for this one, but again, this is a different unrelated issue)
Flags: needinfo?(mthode)

Comment 4

3 years ago
If you want to recompile with the purpose of getting a (better) stacktrace (in gentoo that is), my emerge --info might help(FEATURES,CFLAGS,...):

# emerge --info firefox
Portage 2.2.20.1 (python 2.7.10-final-0, default/linux/amd64/13.0/no-multilib, gcc-5.1.0, glibc-2.21-r1, 4.2.0-rc6-g45b4b78 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-4.2.0-rc6-g45b4b78-x86_64-AMD_A6-3400M_APU_with_Radeon-tm-_HD_Graphics-with-gentoo-2.2
KiB Mem:     2033200 total,    217488 free
KiB Swap:          0 total,         0 free
Timestamp of repository gentoo: Sat, 29 Aug 2015 00:45:01 +0000
sh bash 4.3_p42
ld GNU ld (Gentoo 2.25.1 p1.0) 2.25.1
ccache version 3.2.3 [enabled]
app-shells/bash:          4.3_p42::gentoo
dev-lang/perl:            5.22.0::gentoo
dev-lang/python:          2.7.10::gentoo, 3.4.3::gentoo
dev-util/ccache:          3.2.3::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r3::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.17::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69-r1::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.13.4::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1::gentoo
sys-devel/gcc:            4.8.5::gentoo, 4.9.3::gentoo, 5.1.0::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.1::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r1::gentoo
Repositories:

gentoo
    location: /usr/portage
    priority: -1000

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -ggdb -fvar-tracking-assignments -fno-omit-frame-pointer -ftrack-macro-expansion=2"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native -ggdb -fvar-tracking-assignments -fno-omit-frame-pointer -ftrack-macro-expansion=2"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache cgroup collision-protect config-protect-if-modified distlocks downgrade-backup ebuild-locks fakeroot fixlafiles force-mirror installsources ipc-sandbox merge-sync multilib-strict network-sandbox news nostrip parallel-fetch parallel-install prelink-checksums preserve-libs sandbox sfperms split-elog split-log strict unknown-features-warn unmerge-backup unmerge-logs userfetch userpriv usersandbox webrsync-gpg"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://ftp.romnet.org/gentoo/ http://tux.rainside.sk/gentoo/ http://de-mirror.org/gentoo/ http://gd.tuwien.ac.at/opsys/linux/gentoo/ http://www.las.ic.unicamp.br/pub/gentoo/"
INSTALL_MASK="/lib/systemd /lib32/systemd /lib64/systemd /usr/lib/systemd /usr/lib32/systemd /usr/lib64/systemd /etc/systemd"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="3dnow 3dnowext X acl amd64 berkdb bindist btrfs bzip2 cli consolekit cracklib cscope cxx dbus dri egl extensions gdbm git gpg gpm gtk3 iconv jpeg lock mmx mmxext modules ncurses nptl openmp pam pcre policykit pulseaudio qt4 readline seccomp session sse sse2 sse3 ssl startup-notification system-icu system-jpeg system-libvpx system-sqlite xcomposite zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="3dnow 3dnowext mmx mmxext sse sse2 sse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="keyboard virtualbox evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="virtualbox" XFCE_PLUGINS="brightness clock trash battery power" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

=================================================================
                        Package Settings
=================================================================

www-client/firefox-40.0.2::gentoo was built with the following:
USE="bindist dbus egl gstreamer jemalloc3 pulseaudio startup-notification system-icu system-jpeg system-libvpx system-sqlite -custom-cflags -custom-optimization -debug -gmp-autoupdate -gstreamer-0 -hardened -jit -minimal (-neon) (-pgo) (-selinux) -system-cairo -test -wifi" LINGUAS="-af -ar -as -ast -be -bg -bn_BD -bn_IN -br -bs -ca -cs -cy -da -de -el -en_GB -en_ZA -eo -es_AR -es_CL -es_ES -es_MX -et -eu -fa -fi -fr -fy_NL -ga_IE -gd -gl -gu_IN -he -hi_IN -hr -hu -hy_AM -id -is -it -ja -kk -km -kn -ko -lt -lv -mai -mk -ml -mr -nb_NO -nl -nn_NO -or -pa_IN -pl -pt_BR -pt_PT -rm -ro -ru -si -sk -sl -son -sq -sr -sv_SE -ta -te -th -tr -uk -vi -xh -zh_CN -zh_TW"
CFLAGS="-pipe -march=native -ggdb -fno-omit-frame-pointer"
CXXFLAGS="-pipe -march=native -ggdb -fno-omit-frame-pointer"

(Ignore the fact that I didn't use system-cairo here(so: -system-cairo), this is my current emerge --info, not the one I tested before  when it used to just freeze the videos all the time(but still not crash))

This needs dev-util/debugedit installed(before you re-emerge firefox) so that it installs the firefox source code(which would need to be available later for gdb when it dumps the stacktrace so you can see variable names and line numbers; or is it only the line numbers in the source code?) (other things may need to be re-emerged like x11-libs/cairo to get their source installed as well) - Note: I'm not too sure what the effect is if you don't have the source code installed as well as having debug info enabled(-ggdb and no strip) (do you still get line numbers inside the source code? probably not; or you just get the symbols and variable names due to debugging info only? probably yes). But I still had to look up in the source code manually and paste it  when I reported the ffmpeg issue I mentioned above( https://trac.ffmpeg.org/ticket/4749#comment:6 )

And I've set the following line inside /etc/config-archive/etc/security/limits.conf

*             soft      core       unlimited

so that a file named 'core' gets written on disk when segmentation fault happens.

When the coredump happens, there's a file named 'core' in the dir where firefox was started from (I usually cd /tmp; firefox   because tmp is in tmpfs with 8G free), then I just run:

$ coredump_to_backtrace `which firefox` core >~/backtrace_simple14.log
(wait about 2 mins to finish)

where coredump_to_backtrace is this script:

-------

#!/bin/bash

gdb_get_backtrace() {
#src: https://wiki.gentoo.org/wiki/Project:Quality_Assurance/Backtraces
    local exe=$1
    local core=$2

    gdb ${exe} \
        --core ${core} \
        --batch \
        --quiet \
        -ex "thread apply all bt full" \
        -ex "quit"
}

gdb_get_backtrace "$@"

-------

Except that this line
-ex "thread apply all bt full" \
is:
-ex "bt full" \


The stacktrace would look like this: 
"
...
Core was generated by `firefox'.
Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007fedc59de8cd in raise (sig=11) at ../sysdeps/unix/sysv/linux/pt-raise.c:36
36	  return INLINE_SYSCALL (tgkill, 3, pid, THREAD_GETMEM (THREAD_SELF, tid),
#0  0x00007fedc59de8cd in raise (sig=11) at ../sysdeps/unix/sysv/linux/pt-raise.c:36
        resultvar = 0
        pid = <optimized out>
#1  0x00007fedc2a2d4d3 in nsProfileLock::FatalSignalHandler (signo=11, info=0x7fed67df4ab0, context=0x7fed67df4980) at /usr/src/debug/www-client/firefox-40.0.2/mozilla-release/profile/dirserviceprovider/nsProfileLock.cpp:181
        unblock_sigs = {__val = {1024, 0 <repeats 15 times>}}
        oldact = <optimized out>
#2  <signal handler called>
No locals.
#3  0x00007fed80158fce in NEG_USR32 (s=<optimized out>, a=<optimized out>) at /usr/src/debug/media-video/ffmpeg-9999/ffmpeg-9999/libavcodec/x86/mathops.h:125
No locals.
#4  decode_spectrum_and_dequant (band_type=0x7fed47415d7c, ics=0x7fed47415100, pulse=0x7fed67df4ea0, pulse_present=0, sf=0x7fed4741615c, gb=0x7fed67df52a0, coef=0x7fed474179c0, ac=0x7fed88a0f000) at /usr/src/debug/media-video/ffmpeg-9999/ffmpeg-9999/libavcodec/aacdec_template.c:1639
        n = <optimized out>
        nb_bits = <optimized out>
        index = <optimized out>
        code = <optimized out>
        cb_idx = <optimized out>
        cf = 0x7fed474184b0
        cb_vector_idx = 0x7fed806fc320 <codebook_vector02_idx>
        vlc_tab = 0x7fed80d628a0 <table>
        re_index = 2024
        re_cache = <optimized out>
        vq = 0x7fed806fc3c8 <codebook_vector0_vals>
        re_size_plus8 = 2040
        cbt_m1 = 0
        cfo = 0x7fed47418440
        off_len = 32
        group = <optimized out>
        g_len = 1
        i = 40
        k = <optimized out>
        g = 0
        idx = 40
        c = <optimized out>
        coef_base = 0x7fed474179c0
        offsets = 0x7fed806fbc40 <swb_offset_1024_48>
#5  decode_ics (ac=ac@entry=0x7fed88a0f000, sce=sce@entry=0x7fed47415100, gb=gb@entry=0x7fed67df52a0, common_window=common_window@entry=1, scale_flag=0) at /usr/src/debug/media-video/ffmpeg-9999/ffmpeg-9999/libavcodec/aacdec_template.c:1963
        pulse = {num_pulse = 0, start = <optimized out>, pos = {<optimized out>, <optimized out>, <optimized out>, <optimized out>}, amp = {<optimized out>, <optimized out>, <optimized out>, <optimized out>}}
        tns = 0x7fed474151b0
        ics = 0x7fed47415100
        out = 0x7fed474179c0
        eld_syntax = <optimized out>
        er_syntax = <optimized out>
        pulse_present = 0
#6  0x00007fed8015987c in decode_cpe (ac=ac@entry=0x7fed88a0f000, gb=gb@entry=0x7fed67df52a0, cpe=cpe@entry=0x7fed47407000) at /usr/src/debug/media-video/ffmpeg-9999/ffmpeg-9999/libavcodec/aacdec_template.c:2089
        i = <optimized out>
        ret = <optimized out>
        common_window = <optimized out>
        ms_present = 2
        eld_syntax = <optimized out>
#7  0x00007fed8015a738 in aac_decode_frame_int (avctx=avctx@entry=0x7fed83897a00, data=data@entry=0x7fed67df54f0, got_frame_ptr=got_frame_ptr@entry=0x7fed67df5868, gb=gb@entry=0x7fed67df52a0, avpkt=avpkt@entry=0x7fed67df5350) at /usr/src/debug/media-video/ffmpeg-9999/ffmpeg-9999/libavcodec/aacdec_template.c:2964
        ac = 0x7fed88a0f000
        che = 0x7fed47407000
        che_prev = <optimized out>
        elem_type_prev = TYPE_END
        err = 0
        elem_id = 0
        samples = 1024
        multiplier = <optimized out>
        audio_found = <optimized out>
        pce_found = <optimized out>
        is_dmono = <optimized out>
        sce_count = <optimized out>
#8  0x00007fed8015b75a in aac_decode_frame (avctx=0x7fed83897a00, data=0x7fed67df54f0, got_frame_ptr=0x7fed67df5868, avpkt=0x7fed67df5350) at /usr/src/debug/media-video/ffmpeg-9999/ffmpeg-9999/libavcodec/aacdec_template.c:3141
        ac = 0x7fed88a0f000
        buf = 0x7fed593fff00 "!\032T\265\235\222F4\242\200J]\240\002\324\r0"
        buf_size = 254
        gb = {buffer = 0x7fed593fff00 "!\032T\265\235\222F4\242\200J]\240\002\324\r0", buffer_end = 0x7fed593ffffe "ZZ"<error: Cannot access memory at address 0x7fed59400000>, index = 1985, size_in_bits = 2032, size_in_bits_plus8 = 2040}
        buf_consumed = <optimized out>
        buf_offset = <optimized out>
        err = <optimized out>
        new_extradata_size = -1758345403
        jp_dualmono_size = 32749
        jp_dualmono = <optimized out>
#9  0x00007fed804eb961 in avcodec_decode_audio4 (avctx=0x7fed83897a00, frame=frame@entry=0x7fed67df54f0, got_frame_ptr=got_frame_ptr@entry=0x7fed67df5868, avpkt=avpkt@entry=0x7fed67df5420) at /usr/src/debug/media-video/ffmpeg-9999/ffmpeg-9999/libavcodec/utils.c:2599
        side_size = 32749
        tmp = {buf = 0x0, pts = 0, dts = 0, data = 0x7fed593fff00 "!\032T\265\235\222F4\242\200J]\240\002\324\r0", size = 254, stream_index = 0, flags = 0, side_data = 0x0, side_data_elems = 0, duration = 0, destruct = 0x0, priv = 0x0, pos = 0, convergence_duration = 0}
        side = <optimized out>
        discard_padding = 0
        skip_reason = 0 '\000'
        discard_reason = 0 '\000'
        did_split = 0
        avci = 0x7fed8629d080
        ret = 0
#10 0x00007fed8160d06d in gst_ffmpegauddec_audio_frame (ffmpegdec=ffmpegdec@entry=0x7fed7b2812a0, data=data@entry=0x7fed593fff00 "!\032T\265\235\222F4\242\200J]\240\002\324\r0", size=<optimized out>, have_data=have_data@entry=0x7fed67df5868, outbuf=outbuf@entry=0x7fed67df57d0, ret=ret@entry=0x7fed67df586c, in_plugin=<optimized out>) at /usr/src/debug/media-plugins/gst-plugins-libav-1.4.5-r1/gst-libav-1.4.5/ext/libav/gstavauddec.c:475
        len = -1
        packet = {buf = 0x0, pts = 0, dts = 0, data = 0x7fed593fff00 "!\032T\265\235\222F4\242\200J]\240\002\324\r0", size = 254, stream_index = 0, flags = 0, side_data = 0x0, side_data_elems = 0, duration = 0, destruct = 0x0, priv = 0x0, pos = 0, convergence_duration = 0}
        frame = {data = {0x7fed894fd000 "\213@R9k\252 *blabla* \324˛8.", <incomplete sequence \354\267>..., 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, linesize = {8192, 0, 0, 0, 0, 0, 0, 0}, extended_data = 0x7fed67df54f0, width = 0, height = 0, nb_samples = 2048, format = 8, key_frame = 1, pict_type = AV_PICTURE_TYPE_NONE, base = {0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, sample_aspect_ratio = {num = 0, den = 1}, pts = -9223372036854775808, pkt_pts = 0, pkt_dts = -9223372036854775808, coded_picture_number = 0, display_picture_number = 0, quality = 0, reference = 0, qscale_table = 0x0, qstride = 0, qscale_type = 0, mbskip_table = 0x0, motion_val = {0x0, 0x0}, mb_type = 0x0, dct_coeff = 0x0, ref_index = {0x0, 0x0}, opaque = 0x0, error = {0, 0, 0, 0, 0, 0, 0, 0}, type = 1, repeat_pict = 0, interlaced_frame = 0, top_field_first = 0, palette_has_changed = 0, buffer_hints = 0, pan_scan = 0x0, reordered_opaque = -9223372036854775808, hwaccel_picture_private = 0x0, owner = 0x0, thread_opaque = 0x0, motion_subsample_log2 = 0 '\000', sample_rate = 44100, channel_layout = 3, buf = {0x7fed64fed300, 0x7fed64fed3a0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, extended_buf = 0x0, nb_extended_buf = 0, side_data = 0x0, nb_side_data = 0, flags = 0, color_range = AVCOL_RANGE_UNSPECIFIED, color_primaries = AVCOL_PRI_RESERVED0, color_trc = AVCOL_TRC_RESERVED0, colorspace = AVCOL_SPC_RGB, chroma_location = AVCHROMA_LOC_UNSPECIFIED, best_effort_timestamp = -9223372036854775808, pkt_pos = 0, pkt_duration = 0, metadata = 0x0, decode_error_flags = 0, channels = 2, pkt_size = 254, qp_table_buf = 0x0}
#11 0x00007fed8160d622 in gst_ffmpegauddec_frame (ffmpegdec=ffmpegdec@entry=0x7fed7b2812a0, data=data@entry=0x7fed593fff00 "!\032T\265\235\222F4\242\200J]\240\002\324\r0", size=size@entry=254, have_data=have_data@entry=0x7fed67df5868, ret=ret@entry=0x7fed67df586c) at /usr/src/debug/media-plugins/gst-plugins-libav-1.4.5-r1/gst-libav-1.4.5/ext/libav/gstavauddec.c:632
        oclass = 0x7fed854e9680
        outbuf = 0x0
        len = 0
        __FUNCTION__ = "gst_ffmpegauddec_frame"
#12 0x00007fed8160ded6 in gst_ffmpegauddec_handle_frame (decoder=0x7fed7b2812a0, inbuf=0x7fed853add20) at /usr/src/debug/media-plugins/gst-plugins-libav-1.4.5-r1/gst-libav-1.4.5/ext/libav/gstavauddec.c:753
        ffmpegdec = 0x7fed7b2812a0
        oclass = <optimized out>
        data = 0x7fed593fff00 "!\032T\265\235\222F4\242\200J]\240\002\324\r0"
        bdata = 0x7fed593fff00 "!\032T\265\235\222F4\242\200J]\240\002\324\r0"
        map = {memory = 0x7fed7dd79490, flags = GST_MAP_READ, data = 0x7fed593fff00 "!\032T\265\235\222F4\242\200J]\240\002\324\r0", size = 254, maxsize = 254, user_data = {0x7fedbc051a7d <g_list_append+29>, 0x7fed67df5960, 0x7fed7b281030, 0x7fed7b2812a0}, _gst_reserved = {0x7fed854e9888, 0x7fed67df58e0, 0x7fedbc06751a <g_queue_push_tail+26>, 0x6c0e59ca98}}
        size = 254
        bsize = 254
        len = <optimized out>
        have_data = 0
        ret = GST_FLOW_OK
        __FUNCTION__ = "gst_ffmpegauddec_handle_frame"
...
"

Note the folder that keeps all installed source code is(courtesy of debugedit): /usr/src/debug/

PS: I'm sure you already know all this(and more!) but maybe this is useful for someone stumbling upon this(maybe even future me rereading this). (in other words, didn't mean to be patronizing or anything)

Updated

3 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
Using system cairo is at your own risk. We'll take fixes but are not likely to spend anytime investigating.

Updated

3 years ago
Whiteboard: gfx-noted
Our current version of Cairo is both old and heavily modified, so I would expect bad things.  I also don't see things getting better, but will take patches as Jeff mentioned.

Comment 7

3 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #5)
> Using system cairo is at your own risk. We'll take fixes but are not likely
> to spend anytime investigating.

doesn't --enable-default-toolkit=cairo-gtk3 on linux require the use of system cairo?  At least on gentoo, setting that causes the build to fail without --enable-system-cairo accompanying it...
It would be helpful to know why it's failing then and why that can't be fixed.
(In reply to Ian Stakenvicius from comment #7)
> (In reply to Jeff Muizelaar [:jrmuizel] from comment #5)
> > Using system cairo is at your own risk. We'll take fixes but are not likely
> > to spend anytime investigating.
> 
> doesn't --enable-default-toolkit=cairo-gtk3 on linux require the use of
> system cairo?  At least on gentoo, setting that causes the build to fail
> without --enable-system-cairo accompanying it...

Newer versions of Firefox no longer have this limitation.

Comment 10

3 years ago
(In reply to Jeff Muizelaar [:jrmuizel] from comment #9)
> (In reply to Ian Stakenvicius from comment #7)
> > (In reply to Jeff Muizelaar [:jrmuizel] from comment #5)
> > > Using system cairo is at your own risk. We'll take fixes but are not likely
> > > to spend anytime investigating.
> > 
> > doesn't --enable-default-toolkit=cairo-gtk3 on linux require the use of
> > system cairo?  At least on gentoo, setting that causes the build to fail
> > without --enable-system-cairo accompanying it...
> 
> Newer versions of Firefox no longer have this limitation.

Ah, good to know; ok sorry for the spam, back to your regularly scheduled system-cairo bug.

Updated

3 years ago
Duplicate of this bug: 1202472

Comment 12

2 years ago
Bug 1259466 removed OMTC pref which means --enable-system-cairo is no longer usable without getting frequent crashes. In FreeBSD Ports we've switched to bundled cairo by default as OMTC will be required once e10s hits release channels. PkgSrc may need to do the same.

https://svnweb.freebsd.org/ports/head/www/firefox/files/patch-modules-libpref-init-all.js?revision=393805&view=markup
http://cvsweb.netbsd.org/bsdweb.cgi/pkgsrc/www/firefox/patches/patch-modules_libpref_init_all.js?rev=1.1&content-type=text/x-cvsweb-markup

Comment 13

2 years ago
Nevermind, I've relied on my memory but actually cannot reproduce anymore. Also, GStreamer was removed in bug 1234092 which may have fixed comment 4.
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.