Last Comment Bug 120198 - [trk] Rendering errors on MathML demos
: [trk] Rendering errors on MathML demos
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: MathML (show other bugs)
: Trunk
: All All
: -- normal with 7 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 161155
Blocks:
  Show dependency treegraph
 
Reported: 2002-01-15 17:29 PST by rbs
Modified: 2011-07-11 15:24 PDT (History)
25 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
A cropped screenshot of the mozilla window showing exmaple #13 on the mathml torture page (3.21 KB, image/png)
2002-03-20 11:18 PST, Jason Edgecombe
no flags Details
half integral (5.63 KB, image/jpeg)
2002-03-26 10:44 PST, mental
no flags Details
less than symbol doesn't render correctly, example #11 on the mathml torture page (12.78 KB, image/png)
2002-04-19 17:53 PDT, jmmrb
no flags Details
Screenshot of example 28 of MathML Torture Test on setup described above (968 bytes, image/gif)
2002-05-27 19:24 PDT, Mårten Svantesson
no flags Details
#13: Numbers and operators fall out of root sign (2.27 KB, image/png)
2002-06-20 20:14 PDT, Leung Wing Chung
no flags Details
Screenshot showing black boxes instead of "/" symbols (33.07 KB, image/png)
2002-07-24 03:04 PDT, Jeremy Sanders
no flags Details
right part of the underbrace doesn't render correctly, mathml torture page #22 (1.66 KB, image/gif)
2002-09-16 11:42 PDT, peter kootstra
no flags Details
Square Root line appears as Box. (19.28 KB, image/jpeg)
2002-12-11 10:27 PST, Shanmuhanathan T
no flags Details
#10 on MathML Torture Test: less-than-or-equal not rendered (22.20 KB, text/xml)
2003-03-20 06:16 PST, Murray Eisenberg
no flags Details
Rendering errors under MacOSX10.2.4 with Math1,Math2,Math4 fonts (20.33 KB, image/png)
2003-03-29 12:35 PST, distler
no flags Details
Same thing, but with Math1,Math3, Math5 (20.30 KB, image/png)
2003-03-29 12:36 PST, distler
no flags Details
Screen capture of MathML torture test #13 (3.08 KB, image/png)
2003-04-20 18:01 PDT, Tom Burkholder
no flags Details
plus, minus, equal, square root signs are allways upperscripted, braces do not scale (49.50 KB, image/png)
2003-06-17 17:12 PDT, Frédéric Sarron
no flags Details
Screenshot for the comment above (16.41 KB, image/jpeg)
2003-11-09 06:53 PST, Alexey
no flags Details
latin & numbers show as symbols & greek (18.03 KB, image/png)
2004-01-26 14:08 PST, Amit Aronovitch
no flags Details
screenshot of mozilla 1.6 using symbol fonts for roman chars (105.19 KB, image/png)
2004-02-03 21:42 PST, Bob McElrath
no flags Details
broken strechy brackets, missing thinspace glyph (64.14 KB, image/png)
2004-02-04 16:45 PST, Amit Aronovitch
no flags Details
Verbar should render as DoubleVerticalBar (6.21 KB, text/xml)
2004-08-04 15:42 PDT, steve.swanson
no flags Details
Screenshot showing problems with #17,21,22 on torture test. (71.87 KB, image/png)
2004-12-09 14:28 PST, Keith Frost
no flags Details
greek letters display as cyryllic (7.74 KB, image/jpeg)
2005-01-19 06:38 PST, tim
no flags Details
Roman alphabets are rendered as symbols (103.92 KB, image/png)
2005-03-12 19:05 PST, mathfield
no flags Details
overline mo accent macr too short (6.31 KB, image/png)
2005-04-09 11:47 PDT, Alex Madon
no flags Details
non breaking space entity   without effect at the end of a mtext (7.09 KB, image/png)
2005-04-09 12:34 PDT, Alex Madon
no flags Details
Upright fonts used for integrands in mathml renderings (3.13 KB, image/png)
2006-01-04 03:50 PST, George N. White III
no flags Details
Severely broken text height calculations (54.54 KB, image/png)
2006-03-03 10:24 PST, Matt Whitlock
no flags Details
The absolute value signs do not render properly. (10.17 KB, image/png)
2006-09-17 05:11 PDT, Dennis
no flags Details
roots rendered as black boxes in #13 of the mathml trouble demos (1.22 KB, image/png)
2006-11-20 08:56 PST, hikuiishi
no flags Details
Fixes some errors (843 bytes, patch)
2011-01-02 07:27 PST, Frédéric Wang (:fredw)
karlt: review+
karlt: checkin+
Details | Diff | Review

Description rbs 2002-01-15 17:29:26 PST
Opening this bug to collect glitches that may be seeing on MathML demos, so that 
fixing these would allow to polish the MathML engine even more.
Comment 1 rbs 2002-01-28 12:07:04 PST
Noted in the demo of mfrac that the thick line (linethickness="1pt") seems to
show up only in those cases where the fraction is in display mode
http://www.mozilla.org/projects/mathml/demo/mfrac.xhtml
Comment 2 Ian Webb 2002-03-14 22:48:15 PST
In the MathML Torture Test, #15 appears as 2^2^28 in the TeX column and 2^2^2^x
in the MathML column. I'm running the latest nightly Win32 build, 2002031403.
However, his would appear to be a bug in the demo -- I'm reportingit here as it
seems the most appropriate place to do so. 
Comment 3 Ben Liblit 2002-03-16 01:55:51 PST
Math operator page <http://www.mozilla.org/projects/mathml/demo/mo.xhtml>,
stretchy fences demo: forward slash (/) stretches just fine, but backslash (\)
doesn't stretch at all.  It just remains at normal display size.
Comment 4 iraqispy 2002-03-17 17:05:10 PST
Lowercase letters inside math tags are rendered in Greek on all of the demo
pages.  For example, a (not &alpha;) becomes alpha, z becomes zeta.  I guess
it's poor font choice.  I'm running Solaris 2.6 build 2002031500.
Comment 5 Hixie (not reading bugmail) 2002-03-17 18:35:00 PST
iraqispy: You probably have a buggy "Symbol" font.
Comment 6 Jason Edgecombe 2002-03-20 11:18:05 PST
Created attachment 75210 [details]
A cropped screenshot of the mozilla window showing exmaple #13 on the mathml torture page
Comment 7 rbs 2002-03-20 15:46:06 PST
Comment on attachment 75210 [details]
A cropped screenshot of the mozilla window showing exmaple #13 on the mathml torture page

which platform/OS?
Comment 8 mental 2002-03-26 10:41:59 PST
I had a problem resembling Jason's (comment #6) that disappeared after
re-installing fonts.

Noticed the integral sign is rendering incorrectly with build 2002032503 on
Windows 98 on the page http://www.mozilla.org/projects/mathml/demo/basics.xhtml

Screenshot will follow.
Comment 9 mental 2002-03-26 10:44:28 PST
Created attachment 76228 [details]
half integral
Comment 10 jmmrb 2002-04-19 17:53:19 PDT
Created attachment 80132 [details]
less than symbol doesn't render correctly,  example #11 on the mathml torture page

It's probably a font error.
OS: WXP
Moz: Mozilla RPC 1
Comment 11 Mårten Svantesson 2002-05-27 19:20:50 PDT
I'm running Mozilla 1.0RC3 on Solaris 8 and have the fonts 
Math1-4, cmex10 and cmsy10 installed.

Example 14 and 23 have the same error: The first parenthesis in example 14 is
missing and so are the smaller left parenthesis in example 23.

Example 28 looks a bit strange, I'll supply a screenshot.
Comment 12 Mårten Svantesson 2002-05-27 19:24:20 PDT
Created attachment 85211 [details]
Screenshot of example 28 of MathML Torture Test on setup described above
Comment 13 rbs 2002-05-27 19:46:19 PDT
Example 28b is intentional (although the rendering should perhaps be improved).
Its purpose is to warn authors not to use that markup if what they want is
really 28a (click on them to see the different markups in 28a vs. 28b).

Got a screenshot for Example 14 and 23?
Comment 14 Leung Wing Chung 2002-06-20 20:14:17 PDT
Created attachment 88586 [details]
#13: Numbers and operators fall out of root sign

Numbers and operators fall out of root signs
Comment 15 Jeremy Sanders 2002-07-23 04:10:50 PDT
For me on http://www.mozilla.org/projects/mathml/demo/texvsmml.xml tests 5, 8
and 18 show the slash symbol as a solid block (this is with linux on i686 using
mathematica and tex fonts).
Comment 16 rbs 2002-07-23 11:15:14 PDT
>this is with linux
which distro?
Comment 17 Jeremy Sanders 2002-07-23 11:18:48 PDT
RedHat 7.3, Mozilla 1.1b
Comment 18 rbs 2002-07-23 14:09:50 PDT
Your problem looks like bug 149566. I suggest you try experimenting what I said
in bug 149566 comment 4 with the Symbol font in general, and filing a bug
against GFX Compositor.
Comment 19 Jeremy Sanders 2002-07-24 03:03:24 PDT
This looks rather different - I'm not getting greek characters everywhere -
everything else looks fine. I'll include a screenshot to demonstrate.
Comment 20 Jeremy Sanders 2002-07-24 03:04:17 PDT
Created attachment 92558 [details]
Screenshot showing black boxes instead of "/" symbols
Comment 21 Dan Wallach 2002-08-27 09:27:46 PDT
On Mozilla 1.1, Windows XP, with TeX and Mathematica fonts installed, everything
rendered correctly except for the <= (less than or equal) signs, which came out
as square boxes.
Comment 22 Jeremy Sanders 2002-08-27 09:31:45 PDT
Still broken on Mozilla 1.1 on Linux with Mathematica and Tex fonts for me.
Comment 23 peter kootstra 2002-09-16 11:42:24 PDT
Created attachment 99389 [details]
right part of the underbrace doesn't render correctly, mathml torture page #22
Comment 24 Mikko Rantalainen 2002-12-11 03:17:39 PST
I'm confirming the problem mentioned in comment 23 on both Windows 2000 (GDI+,
SVG and MathML build from yesterday) and Linux (ID:2002121021) builds. All the
other tests look OK (minus a few missing glyphs on my system).
Comment 25 Shanmuhanathan T 2002-12-11 10:27:31 PST
Created attachment 109035 [details]
Square Root  line appears as Box.
Comment 26 rbs 2003-02-05 20:13:17 PST
re: comment 23
should be fixed now, it was a regression - see bug 191529.
Comment 27 Murray Eisenberg 2003-03-20 06:16:14 PST
Created attachment 117840 [details]
#10 on MathML Torture Test: less-than-or-equal not rendered

The less-than-or-equal symbols in the subscript location under the large
summation sign in item #10 on the MathML Torture Test
(http://www.mozilla.org/projects/mathml/demo/texvsmml) are not rendered --
appear as missing-symbol boxes.  This is in Mozilla 1.3 (under Windows XP Pro
SP-1) with the stated fonts installed:	the 4 BakoMa cm fonts; the various
Wolfram "Math" (and even the newer "Mathematica") fonts; and MTSymbol and
MTExtra.
Comment 28 rbs 2003-03-20 15:01:06 PST
Was also reported in comment 21. I see no problem on Win2K. I think something
fishy is happening on WinXP with the CMSY10 font in particular. Try using the
Character Map (from Start Menu -> Programs -> Accessories -> System Tools ->
Character Map) to see the glyphs that are in the fonts. If everything is alright
you should get this:
http://www.mozilla.org/projects/mathml/fonts/encoding/cmsy-ttf.gif
(note that '<=' can be seen at position B7).
Comment 29 distler 2003-03-29 12:35:47 PST
Created attachment 118866 [details]
Rendering errors under MacOSX10.2.4 with Math1,Math2,Math4 fonts
Comment 30 distler 2003-03-29 12:36:51 PST
Created attachment 118867 [details]
Same thing, but with Math1,Math3, Math5
Comment 31 distler 2003-03-29 12:40:14 PST
MacOSX 10.2.4 with the Mathematica Fonts installed.

Using:
   user_pref("font.mathfont-family", "Math1, Math2, Math4");

Tests 5,8,13,16,18,19,21,22 are broken: "/", stretchy integral sign, square-root
and over- and under-braces not rendering correctly. See <a
href="http://bugzilla.mozilla.org/attachment.cgi?id=118866&action=view">attachement
118866</a>.

Using:
   user_pref("font.mathfont-family", "Math1, Math3, Math5");

Things are a little better: square-root does not render correctly, and over- and
under-braces are not stretchy. See <a
href="http://bugzilla.mozilla.org/attachment.cgi?id=118867&action=view">attachement
118867</a>.
Comment 32 Tom Burkholder 2003-04-20 18:01:15 PDT
Created attachment 121146 [details]
Screen capture of MathML torture test #13

This is the rendering with 
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.4a) Gecko/20030401
Comment 33 rbs 2003-04-20 18:18:50 PDT
Re: Comment #32. Same as Comment #25: 

Square Root line appears as Box:
http://bugzilla.mozilla.org/attachment.cgi?id=109035&action=view

Since you are on Windows, just install the TeX fonts and the problem will go away.
http://www.mozilla.org/projects/mathml/fonts/
Comment 34 Robert Basch 2003-05-20 15:37:12 PDT
Environment: Mozilla 1.2.1 on Solaris 9, with the TeX CM and Mathematica fonts
added to the font path.

In Test 9, none of the minus signs appear after adding the fonts (they do
appear if the fonts are not added).

We also see the problem with missing left parentheses in 14 and 23, reported
in comment #11.  We have found that this problem goes away when you tell
Mozilla to use the Mathematica fonts when stretching, by adding the following
to prefs.js:

	user_pref("font.mathfont-family", "Math1, Math2, Math4");
Comment 35 rbs 2003-05-20 19:13:11 PDT
old problems:
slash screenshot: http://bugzilla.mozilla.org/attachment.cgi?id=92558
less-or-equal screenshot: http://bugzilla.mozilla.org/attachment.cgi?id=80132

these have been fixed in more recent builds (expected milestone release: m1.4final)
Comment 36 Frédéric Sarron 2003-06-17 17:12:50 PDT
Created attachment 125867 [details]
plus, minus, equal, square root signs are allways upperscripted, braces do not scale

Mozilla 1.3.1, Debian Sid

I installed all fonts needed, as told in
http://www.mozilla.org/projects/mathml/fonts/. The font are served by xfs, seen
by X font managers.
Comment 37 rbs 2003-06-17 17:21:53 PDT
> Mozilla 1.3.1, Debian Sid

That build is too old... and seems to be Xft-enabled. See the troubleshooting
link on the math font page.
Comment 38 Frédéric Sarron 2003-06-17 18:40:12 PDT
unfortunately http://bugzilla.mozilla.org/show_bug.cgi?id=35236#c4 did not help.
Shall I manage to disable xft to render MathML properly ?
Comment 39 rbs 2003-06-17 19:02:51 PDT
I was meaning the thread, no just that single comment. Yes, you have to turn off
Xft for the time being: bug 35236 comment 38.  C.f. also this thread in the
n.p.m.mathml news group: http://groups.google.com/groups?th=cfb805db450d7d65
Comment 40 Daniel Jamous 2003-09-11 14:24:41 PDT
Environment: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4)
Gecko/20030624 with the Mathematica fonts installed.

I'm seeing some of the problems mentioned in comments #29, #30, and #31 although
not as many probably because my Mozilla build is more recent:

test 13 -- the square root is not rendered correctly (appears as in the
attachment provided in comment #29)
tests 16 and 21 -- the integral is not rendered correctly (appear as in
attachment comment #29)
tests 19 and 22 -- the under and over-braces are not rendered correctly (same as
comment #29)

In addition: test 14 displays an "upper-case phi" instead of a lower-case one.

Also, the Mozilla pop-up window lists the "Symbol" fonts are missing even though
they are installed on my computer.
Comment 41 Paul Vojta 2003-09-15 11:25:55 PDT
In mathML torture test #9, minus signs are missing.

I am using Mozilla-1.5b under Solaris 9 for the sparc.

Everything else on that page looks great (except for bugs in the page itself,
as noted for example in Comment #2).
Comment 42 Daniel Jamous 2003-09-15 12:02:39 PDT
Hi Paul,

We also observed the same problem -- see comment #34 -- and found out that it
comes from the TeX fonts. We haven't found a way to fix it but decided NOT to
install the TeX fonts on Solaris 9. Just having the Mathematica fonts is fine
for most purposes (if you can live with the Mozilla "missing fonts" pop-up window).

Daniel Jamous
Comment 43 rbs 2003-09-15 15:58:23 PDT
re: comment 39 
Xft builds now have MathML. No need to turn it off. Apparently, people who try
it vow not to come back to a build without Xft again. However the intl support
is still not in parity with the default trunk build.


re: Daniel & Paul (comment 41, comment 42)
Set the following pref (e.g., in your prefs.js or simply using the handy
about:config, and righ-click from there to define a new string pref)

pref("font.mathfont-family.\u2212.base", "Symbol")

This pref will instruct the MathML engine to use the Symbol font for the minus
sign. U+2212 is the official Unicode minus sign. It looks much better for math
than the text hyphen-minus (-, U+002D). It is what the MathML engine uses
internally for the minus sign. Let me know how it goes, and I might make the
Symbol font the default provider of that glyph. See also mathfont.properties in
your <moz-bin>/fonts/ installation.
Comment 44 Paul Vojta 2003-09-15 16:30:01 PDT
Re: comment #43

I tried adding

pref("font.mathfont-family.\u2212.base", "Symbol")

to my prefs.js file, but it just disappeared from the file after running mozilla.
When I changed pref to user_pref, it appeared in the file with \u2212 changed
to Control-R for some reason.  But it still had no effect.

I investigated the bug a little further, and it seems to be the Solaris version
of xfs.  (The X server that ships with Solaris doesn't grok .pf[ab] fonts
itself, so you have to use xfs.  That's what you're doing, isn't it, Daniel?)
Anyway, the Solaris xfs doesn't show the first 32 characters of cmsy10
(and probably also cmex10, but I didn't check).  If I run xfs under Linux,
then I do get those 32 characters.
Comment 45 rbs 2003-09-15 16:57:03 PDT
oops, double the slash... (exit Mozilla before editing prefs, or just enter
about:config in the URL bar to use the built-in GUI to edit prefs)

user_pref("font.mathfont-family.\\u2212.base", "Symbol");
Comment 46 Paul Vojta 2003-09-15 17:05:30 PDT
That works ... looks great.  Thanks!
Comment 47 rbs 2003-09-15 18:22:09 PDT
Symbol is now the default for minus (fix in mathfont.properties on 1.6 trunk).
Comment 48 Daniel Jamous 2003-09-16 07:20:54 PDT
Question for Paul on the minus sign problem on Solaris 9: did you also see a
left parenthesis missing on test 14? Again, this does not appear with the
Mathematica fonts only or by selecting View-->Use Style-->Mathematica

Is there a way to fix this as well? 
Comment 49 rbs 2003-09-16 17:35:11 PDT
> Is there a way to fix this as well? 

yes, with a similar pref. But I am getting worried of this. If your TeX fonts
are that bad, you might try the newer versions that are supposedly better. 
http://www.ctan.org/tex-archive/fonts/ps-type1/cm-super/
Comment 50 Paul Vojta 2003-09-16 18:23:28 PDT
> Question for Paul on the minus sign problem on Solaris 9: did you also see a
> left parenthesis missing on test 14? Again, this does not appear with the
> Mathematica fonts only or by selecting View-->Use Style-->Mathematica

No, test 14 looks OK, except that the right parenthesis looks a little
crooked (the upper part is misaligned).

Strangely, selecting View-->Use Style doesn't affect the appearance in
any noticeable way.

Re: Comment #49

>> Is there a way to fix this as well? 

>yes, with a similar pref. But I am getting worried of this. If your TeX fonts
>are that bad, you might try the newer versions that are supposedly better. 
>http://www.ctan.org/tex-archive/fonts/ps-type1/cm-super/

It's not the fonts, it's the font server.  It doesn't serve characters
below 0x20.  If I use a font server running on a Linux machine, everything
looks OK.
Comment 51 rbs 2003-09-17 14:53:28 PDT
> No, test 14 looks OK, except that the right parenthesis looks a little
> crooked (the upper part is misaligned).

I think this problem comes from the Symbol _bitmap_ font. Some of its glyphs
have incorrect metrics. Are you not using a type1 version (the one that comes
with Acrobat Reader), as per your comment in bug 128153 comment 83.

Comment 52 Paul Vojta 2003-09-17 18:35:56 PDT
> I think this problem comes from the Symbol _bitmap_ font. Some of its glyphs
> have incorrect metrics. Are you not using a type1 version (the one that comes
> with Acrobat Reader), as per your comment in bug 128153 comment 83.

Indeed, ls -lu indicates that I'm using the bitmap font.  The X server seems to
insist on using that font, instead of the Type 1 font which is ahead of it on
the list.
Comment 53 Paul Vojta 2003-09-20 16:40:51 PDT
Addendum to comment 50:

If I use the Solaris xfs, then the TeX fonts are missing the bottom 32 characters.
If I have the X server access the font directory itself, then only character 0
is missing.
If I use a Linux xfs, then all characters are present.
Comment 54 Daniel Jamous 2003-09-25 13:43:13 PDT
Re comment 49
yes, with a similar pref. But I am getting worried of this. If your TeX fonts
are that bad, you might try the newer versions that are supposedly better. 
http://www.ctan.org/tex-archive/fonts/ps-type1/cm-super/

Thanks for the suggestion. I downloaded the fonts and tried to add them to the
font path using:

xset fp+ ...../cm-super/pfb 

but there are no fonts.dir and fonts.scale in the directory so the command
fails. I tried creating these files using the script "type1inst" as described at:

http://bugzilla.mozilla.org/show_bug.cgi?id=35236#c4

but that also failed. Not sure what to do next. Any idea?
Comment 55 Paul Vojta 2003-09-25 13:53:59 PDT
I don't think you need a fonts.scale.

Here's my fonts.dir:

2
cmsy10.pfb -ams-cmsy10-medium-r-normal--0-0-0-0-p-0-adobe-fontspecific
cmex10.pfb -ams-cmex10-medium-r-normal--0-0-0-0-p-0-adobe-fontspecific

If you're running Solaris, don't forget to run makepsres.

Next time you write please say what version of mozilla you're using.
Comment 56 Daniel Jamous 2003-09-25 14:15:14 PDT
Paul,

Thanks for the answer. Here's my environment:
Mozilla 1.4 on Solaris 9.

Just to clarify: are you using the cm-super type 1 TeX fonts? These are the ones
I'm currently testing (I already installed the TeX fonts obtained from the
Mozilla fonts page). 
Comment 57 Paul Vojta 2003-09-25 16:20:11 PDT
No, just the standard TeX fonts from teTeX 2.0.2 (which are probably identical
to those supplied by mozilla).

But I don't see this as a fonts issue; it's an issue with the Solaris X server
(and also a worse issue with xfs, all Solaris versions so far, plus versions
compiled from older versions of the X Consortium sources).
Comment 58 Alexey 2003-11-09 06:49:47 PST
An error rendering sum using content markup.

Tried in:
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6b) Gecko/20031108 Firebird/0.7+
and (not so new Mozilla)
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4) Gecko/20030624

Look here:
http://www.w3.org/Math/testsuite/testsuite/Content/SequencesAndSeries/sum/rec-sum1.xml

Error:
Mozilla shows 'a' instead of 'x=a'.
Comment 59 Alexey 2003-11-09 06:53:49 PST
Created attachment 135122 [details]
Screenshot for the comment above

Screenshot of invalid rendering of sum
Comment 60 rbs 2003-11-09 16:41:11 PST
Re: Comment #58 & Comment #59
It is bug in the Universal MathML XSLT Sheet (UMSS) that does the conversion
from content markup to the presentation markup that is passed onto Mozilla. You
can see it by placing the mouse over the 'x' under consideration, then right
click and pick 'View MathML Source' in the context menu. There is no 'x=a' in
the DOM. Please refer the bug to the W3C Math WG who maintains the UMSS and the
testsuite.
Comment 61 Amit Aronovitch 2004-01-26 14:08:55 PST
Created attachment 139927 [details]
latin & numbers show as symbols & greek

On mozilla 1.5 (mozilla 1.5-3 from Debian testing + mozilla-xft 2:1.5-3).
(I also observed the same problem on Mandrake 9.1 running mozilla 1.4)

I installed the fonts recommended in
http://www.mozilla.org/projects/mathml/fonts/ (in Xft-enabled linux section),
by copying the .ttf's to my ~/.fonts/.

 Now I don't have the "missing fonts" messages, but get mangled rendering
(adding the cm fonts cause the attached display. Adding mathematica fonts only
cause greek letters only).

  Seems like I have the wrong encoding, but I have no idea how to get encoding
info for xft-tt fonts (fc-list just shows name and style), nor how to force
mozilla to use another encoding.
Comment 62 Bob McElrath 2004-02-03 21:06:36 PST
Amit: confirm that I see the same thing.  I can be worked around by unchecking
"Allow documents to use other fonts".

Is there a separate bug for this?  Is this linux-specific?
Comment 63 rbs 2004-02-03 21:24:04 PST
jshin, any regression in mozilla+xft? see comment 61 & comment 62.
Comment 64 Bob McElrath 2004-02-03 21:40:48 PST
It is definitely xft (if I set GDK_USE_XFT=0 on Mozilla 1.5 the problem goes
away but fonts are not anti-aliased, the same trick does not work with mozilla 1.6).

Also user_pref("font.mathfont-family", "Math1, Math2, Math4, Symbol"); to use
Mathematica fonts does not fix the problem.

Also note about the "Allow documents to use other fonts" trick -- this behavior
occurs on ALL MathML pages (and the trick works on ALL MathML pages), even if
the page didn't specify a font.

The roman symbol 'x' is coming from the font cmsy (the ttf one on the moz mathml
page)...some other glyphs are coming from some decorative ttf fonts I have
installed.

Screenshot to follow.
Comment 65 Bob McElrath 2004-02-03 21:42:26 PST
Created attachment 140577 [details]
screenshot of mozilla 1.6 using symbol fonts for roman chars

there are other font problems in this shot.  I have all fonts installed,
Mozilla does not give the dialog box complaining about fonts.
Comment 66 Jungshik Shin 2004-02-04 00:18:27 PST
By default, an Xft build uses Adobe type 1/PS Symbol font that comes with Adobe
Acroread. Did you install it (add a symbolic link to it to ~/.fonts)? 

If you have a truetype Symbol font (that comes with Windows.[1]), instead, you
have to edit fontEncoding.properties file (that is in res/fonts directory : use
'locate fontEncoding.properties' to locate it) manually.  

Anyway, make sure that you have only one of two available to fontconfig. 


[1] I wasn't usre whether it's allowed to use it on non-Windows platforms so
that I made Xft builds use type1/PS Symbol fonts by default.
Comment 67 Bob McElrath 2004-02-04 00:28:53 PST
I have installed the symbol font.  As I mentioned, Mozilla does not complain
about missing fonts any longer.

(0)<mcelrath@draal:/usr/share/fonts> xlsfonts | grep -i symbol
-adobe-symbol-medium-r-normal--0-0-0-0-p-0-adobe-fontspecific
-adobe-symbol-medium-r-normal--10-100-75-75-p-61-adobe-fontspecific
-adobe-symbol-medium-r-normal--11-80-100-100-p-61-adobe-fontspecific
-adobe-symbol-medium-r-normal--12-120-75-75-p-74-adobe-fontspecific
-adobe-symbol-medium-r-normal--14-100-100-100-p-85-adobe-fontspecific
-adobe-symbol-medium-r-normal--14-140-75-75-p-85-adobe-fontspecific
-adobe-symbol-medium-r-normal--17-120-100-100-p-95-adobe-fontspecific
-adobe-symbol-medium-r-normal--18-180-75-75-p-107-adobe-fontspecific
-adobe-symbol-medium-r-normal--20-140-100-100-p-107-adobe-fontspecific
-adobe-symbol-medium-r-normal--24-240-75-75-p-142-adobe-fontspecific
-adobe-symbol-medium-r-normal--25-180-100-100-p-142-adobe-fontspecific
-adobe-symbol-medium-r-normal--34-240-100-100-p-191-adobe-fontspecific
-adobe-symbol-medium-r-normal--8-80-75-75-p-51-adobe-fontspecific
-microsoft-webdings-medium-r-normal--0-0-0-0-p-0-microsoft-symbol
-urw-standard symbols l-medium-r-normal--0-0-0-0-p-0-adobe-fontspecific
-urw-standard symbols l-medium-r-normal--0-0-0-0-p-0-urw-fontspecific
-urw-standard symbols l-regular-r-normal--0-0-0-0-p-0-adobe-fontspecific
-urw-symbol-medium-r-normal--0-0-0-0-p-0-urw-fontspecific
Comment 68 Jungshik Shin 2004-02-04 06:57:06 PST
Do you have fontEncoding.properties file? Try 'locate fontEncoding.properties'.
What do you get? If it's not installed in $MOZILLA_INSTALL_DIRECTORY/res/fonts
(e.g. /usr/lib/mozilla/res/fonts). You have to get it at
http://lxr.mozilla.org/seamonkey/source/gfx/src/gtk/fontEncoding.properties
and put it res/fonts directory.

BTW, xlsfonts doesn't tell you anything (we're not dealing with X11 core fonts
but the client-side fonts).  You have to use 'fc-list' and 'fc-match'. Try
'fc-match --verbose Symbol' and the font file listed is indeed Adobe Postscript
symbol. 

I've found that on Fedora Core 1 (1.4.2 rpm) has fontEncoding.properties file,
but it's a broken symbolic link to an unexisting file. A similar thing may have
happened to Debian builds. You have to report that to Debian developers. I'm
gonna report it to Fedora developers.

mozilla.org build doesn't have such a problem as far as I know. You may want to
install 

ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.6/contrib/mozilla-i686-pc-linux-gnu-gtk2-pango.tar.gz

Comment 69 Jungshik Shin 2004-02-04 07:11:34 PST
FYI, I've just filed a bug report for Fedora Core1 at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=114917
You may file a similar bug report to Debian.
Comment 70 Jungshik Shin 2004-02-04 07:20:20 PST
(In reply to comment #68)
> You have to use 'fc-list' and 'fc-match'. Try
> 'fc-match --verbose Symbol' and the font file listed is indeed Adobe Postscript
> symbol. 

   ==> .... and make sure that the font file listed is .......
Comment 71 Bob McElrath 2004-02-04 10:20:39 PST
Missing fontEncoding.properties on debian *and* a M$ symbol.ttf are the problem.
  Now when I do fc-match Symbol I get:
  Bitstream-Vera-Sans.ttf: "Bitstream Vera Sans" "Roman"
but the math renders fine in both serif and sans-serif.

Can something be done about the M$ Symbol font problem?  Can mozilla do
something in code to select the proper font?  Can distributions modify their
fontEncoding.properties (or something) so select fonts properly?  Making the
user deal with this is not an acceptable solution.

Also with the Computer Modern fonts there are some spacing problems with large
parenthesis and the like (but I think this is known).  I've added: 
  user_pref("font.mathfont-family", "Math1, Math2, Math4");
and this improves the look.

BTW don't tell people to get files out of lxr, unless they enjoy hand-editing
the HTML out.  ;)

I will file a bug against Debian.

Thanks for your help.
Comment 72 Bob McElrath 2004-02-04 11:41:44 PST
Netscape 7.1 is also missing the fontEncoding.properties file.

...so then no distributed moz except for the mozilla.org builds can render
MathML...sad...
Comment 73 Amit Aronovitch 2004-02-04 16:18:51 PST
Re: comments 61,66,68,71 (fontEncoding.properties etc.)

1) Installing fontEncoding.properties solved the main problem - thanks, jshin.
 Before I saw comment #68, I copyed the file from Netscape7.0/mswin installation
- but it did not work well (prbly older version. p.s. I'm surprised to hear that
in 7.1 it's missing altogether...). The version from lxr does work.

2) About the symbol.ttf from Windows - it does work fine for me (result looks
much like what you get with the adobe ps Symbol) - provided that I edit
fontEncoding.properties, and uncomment the #encoding.symbol lines, as explained
in the file itself. Anyway - the mathml-torture-page seems to load fine now even
*without any* Symbol font (you get the missing font warning, but the page is
rendered almost the same).
 bob, if your'e going to file a bug with debian - maybe they can put a debconf
question to determine if you want to use adobe or ms encoding for symbol (maybe
the script can fill this automaticly if only one of the two is installed).

3) Now I can see math - so I turn my attention to smaller details - I'm
attaching a screenshot...
Comment 74 Bob McElrath 2004-02-04 16:35:47 PST
Re: debconf

Both the Adobe symbol and the windows symbol font are copyrighted and
non-redistributable, so neither is an option for debian.  There is an acroread
in non-free with the font, but the font directory contains a LICFONT.TXT that
explicitly says the fonts are not to be used by any application but acroread. 
Suck me, Adobe.

Where can a free Symbol font be found?

On a related note, the set of instructions so far collected (see
http://mcelrath.org/Notes/MathML) is not sufficent.  It works on Fedora but on
Debian, mozilla is grabbing a non-antialiased font for roman characters.  On
Redhat there are also characters still coming from a non-antialiased font (but
romans are fine).

Can anyone suggest how to figure out which font is giving a given glyph on a page?
Comment 75 Amit Aronovitch 2004-02-04 16:45:38 PST
Created attachment 140630 [details]
broken strechy brackets, missing thinspace glyph

 Several issues here:

1) The stretchy brackets and det-signs come out as broken lines.

2) <mo></mo> causes "thinspace" (U2009), which is missing, and is rendered as a
box with unicode value inside. Also - I noticed in other places ocurrences of
2061 (ApplyFunction) and 2062 (Invisible Times). Is there some "font" that
provides all these spaces? Maybe you can add some "View" or "Style" option that
would allow ignoring all these missing spaces instead of putting in their
unicode boxes.

3) I noticed that <mi>dx</mi> comes out as roman (not italic) - personally I
like it better this way when representing differentials - but it is different
than the tex rendering shown there - was that intentional?
Comment 76 Jungshik Shin 2004-02-04 18:51:18 PST
It'd have better if this discussion had been moved to bug 128153.

> I copyed the file from Netscape7.0/mswin installation
> - but it did not work well 

fontEncoding.properties file for Windows is different from
fontEncoding.properties file for Unix, which is why it didn't work. 

> Where can a free Symbol font be found?

You can use 'Standard Symbols L' (it's made by URW and GPL'd). In that case, you
have to edit the font file yourself and  change the name to 'Symbol' (not the
name of the font file but 'FamilyName' insdie the file). On Fedora, it's  in
/usr/share/fonts/default/Type1 (the name of the file is s050000l.pfb). 

I wish fontconfig aliasing worked for this case, but it didn't when I tried that
in 2002/2003. If it worked, there'd be no need for editing the URW font file. 
See also http://bugzilla.mozilla.org/show_bug.cgi?id=128153#c81

A moment ago, I  found that URW 'Standard Symbols L' is also included in CUPS as
well. On Fedora, it's in /usr/share/cups/fonts. The name of the file is Symbol
and the family name is 'Symbol' although it's URW's 'clone' of Adobe's Symbol.
With this, you don't have to edit the font file. Just add the path
(/usr/share/cups/fonts) to /etc/fonts/local.conf or ~/.fonts.conf  and you're
all set. (alternatively, copy it to or make a symbolic link to it in ~/.fonts).
 Debian can certainly include this font (with the changed name) unless Adobe has
the exclusive right to the name 'Symbol', which is not likely. 

re: comment #43
>  However the intl support is still not in parity with the default trunk build.

  I wonder where  you got this 'impression'. Then as well as now, the intl
support in Xft build is better than that in the default build in many aspects.
 
> Netscape 7.1 is also missing the fontEncoding.properties file.

 AFAIK, Netscape 7.1 is not an Xft build so that it doesn't need it, which is
why it's not included. 

> BTW don't tell people to get files out of lxr, unless they enjoy 
> hand-editing the HTML out.

  You could have used 'File | Save As' (text file) and the amount of manual
editing would have been a lot less. You could also have just copy'n'pasted from
the screen ;-)

re: http://mcelrath.org/Notes/MathML
> missing from most RedHat/Fedora, and Debian installations

  I guess it's the case of 1.4 rpm/deb. I wonder SuSE/Mandrake rpms have the
same problem. Anyway, 1.6 rpm (Xft build) without this issue is available at

  ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/yum/
Comment 77 Jungshik Shin 2004-02-05 01:30:18 PST
> I guess it's the case of 1.4 rpm/deb. I wonder SuSE/Mandrake rpms have the
> same problem.

  It must be the case of any 1.4branch rpm/deb. (tar.gz doesn't have the
problem). The patch to apply is attachment 126983 [details] [diff] [review] (to bug 176290). I forgot to
ask for approval for 1.4branch landing last July. I've just done it (bug 176290
comment #140) so that 1.4.2 release should be all right when released. In the
meantime, distribution builders can apply the patch to their 1.4 builds. 
Comment 78 Bob McElrath 2004-06-04 15:15:33 PDT
Mozilla inserts too much space between <mi> tags.

  http://mcelrath.org/Notes/ITeXLaTeXDifferences

I've beat myself up trying to solve this with CSS, but I don't think it's possible.

Is this the correct place to report this?
Comment 79 Bob McElrath 2004-06-04 15:34:17 PDT
Mozilla does not implement lspace and rspace for the <mo> tag?

http://www.dessci.com/en/reference/MathMLTestSuite/testsuite/Presentation/TokenElements/mo/moAlrspace13.html
Comment 80 steve.swanson 2004-08-04 15:42:14 PDT
Created attachment 155213 [details]
Verbar should render as DoubleVerticalBar

Verbar (\u2016) doesn't stretch.  However, if you read the Unicode spec. "used
in pairs to indicate norm of a matrix" it seems it should.

Now, DoubleVerticalBar (\u2225) does stretch (and looks like Verbar should). 
The Unicode description says "parallel to".  Maybe that shouldn't stretch.
Comment 81 Keith Frost 2004-12-09 14:28:45 PST
Created attachment 168350 [details]
Screenshot showing problems with #17,21,22 on torture test.

This is debian sarge, Mozilla 1.7.3, using the texcm ttf fonts, Mathematica 4.1

ttf fonts, and the Symbol font which came with the Adobe Acrobat Reader 5.09. 
I
had to comment out the lines referring to the symbol font in the
fontsEncoding.properties file to get this to work, but there is a missing
symbol 
for empty space (2009 in #17, 21) and a lowered apostrophe appearing in #22.
Comment 82 brahim marzouk 2005-01-14 11:21:09 PST
Hi.
Just to say that Radicals of formula #13 of the torture test don't appear
correctly : they are filled with black rectangles.
Good luck.
Comment 83 tim 2005-01-19 06:38:54 PST
Created attachment 171754 [details]
greek letters display as cyryllic

the greek alphabet displays as these slanty cryllic characyers
Comment 84 mathfield 2005-03-12 19:05:31 PST
Created attachment 177261 [details]
Roman alphabets are rendered as symbols

Only a problem in my linux machine. The same page loads fine in Windows!
Comment 85 Alex Madon 2005-04-09 11:47:17 PDT
Created attachment 180196 [details]
overline mo accent macr too short

A <mo accent="true">&macr;</mo> placed over more than one character keeps a one
character length. Correct behaviour : the line should be over all the
characters.
In attachement a PNG image showing the Mozilla output and the LaTeX output
(obtained with the \overline command).

Note that Amaya renders well this accent.

Here is the MATHML code used to generate the PNG image:


<math xmlns="http://www.w3.org/1998/Math/MathML" display="block">
  <mstyle id="x7-7004r22" class="label"/>
  <msub>
    <mrow>
      <mover accent="false" class="mml-overline">
	<mrow>
	  <msup>
	    <mrow>
	      <mi>L</mi>
	    </mrow>
	    <mrow>
	      <mo class="MathClass-bin">&lowast;</mo>
	    </mrow>
	  </msup>
	  <msup>
	    <mrow>
	      <mi mathvariant="script">G</mi>
	    </mrow>
	    <mrow>
	      <mo class="MathClass-bin">&lowast;</mo>
	    </mrow>
	  </msup>
	</mrow>
	<mo accent="true">&macr;</mo>
      </mover>
    </mrow>
    <mrow>
      <mi>y</mi>
    </mrow>
  </msub>

  <mo class="MathClass-rel">=</mo>

  <msub>
    <mrow>
      <mi>&delta;</mi>
    </mrow>
    <mrow>
      <mi>y</mi>
    </mrow>
  </msub>
</math>
Comment 86 Alex Madon 2005-04-09 12:34:15 PDT
Created attachment 180204 [details]
non breaking space entity &nbsp;  without effect at the end of a mtext

The non breaking space nbsp is without effect in the following MathML code
(before a </mtext>).
The PNG attachment shows that the space is missing in the output generated by
Mozilla. 

<math xmlns="http://www.w3.org/1998/Math/MathML" display="block">
  <mstyle id="x7-6003r18" class="label"/>
  <mi>L</mi>
  <mi>u</mi>
  <mo class="MathClass-rel">=</mo>
  <mi>f</mi>
  <mtext>&nbsp;in&nbsp;</mtext>
  <mi>&Omega;</mi>
</math>
Comment 87 Hugh Coomes 2005-06-07 08:19:08 PDT
On Solaris 10, with either the Sun supplied Mozilla 1.7 or contributied 
Firefox 1.04 with xft, in the MathML torture test, each Roman character is 
replaces with a corresponding Greek character, e.g., a, b, d, become the
alpha,beta, delta characters. This is similar, but not the same as comment 84. 
 
Mathematical symbols, e.g. <, >, brackets, etc are displayed correctly (expect
for test 28). If the MathML fonts are not configured, the same behavior occurs
(but of course the rendering has many more defects.
Comment 88 rbs 2005-10-26 19:09:06 PDT
Re: Comment #86
&nbsp; has been fixed in bug 297464.
Comment 89 rbs 2005-10-26 19:12:34 PDT
Re: Comment #78
Gecko 1.8-based browsers have significant inter-space improvements via bug 306543.
Comment 90 rbs 2005-10-26 19:21:09 PDT
Re: Comment #88
I meant bug 247151.

Re: Comment #75
Gaps in stretchy characters have been fixed in bug 307157 and bug 311046.
The problems with 2061 (ApplyFunction) and 2062 (Invisible Times) were also fixed in bug 306543.

All these fixes will be in Gecko 1.8-based browsers such as Firefox 1.5.
Comment 91 rbs 2005-10-31 19:37:04 PST
Re: Comment #80
Both &Vert; and &DoubleVerticalBar; now stretch - fixed in bug 314459
Comment 92 steve.swanson 2005-10-31 19:47:36 PST
Thanks.  The fix the bug 314459 improves the appearance of a number of my documents.
Comment 93 Lesley 2005-12-28 03:15:08 PST
As per comment 75 on this list I get THSP for &thinspace; at the moment in items 17 and 22 of http://www.mozilla.org/projects/mathml/demo/texvsmml.xhtml, but I am using a standard 1.5 build on SuSE 9.2 Linux.  I have followed the font installs as directed on http://www.mozilla.org/projects/mathml/fonts/

Also is there a bug in the TeX item 22 of http://www.mozilla.org/projects/mathml/demo/texvsmml.xhtml 
(http://www.mozilla.org/projects/mathml/screenshots/ex52.gif) ?

The MathML renders it well with a nice script 'l' but the TeX looks like it's using a '1' whereas the 'l' makes much more sense.
Comment 94 George N. White III 2006-01-04 03:50:30 PST
Created attachment 207483 [details]
Upright fonts used for integrands in mathml renderings

Mozilla 1.5 on Win32 and debian

In the integrands, the <mi>xx</mi> terms are rendered using an upright font.  Replacing, e.g., <mi>dt</mi> with <mrow><mi>d</mi><mi>t</mi></mrow> better matches the TeX display.
Comment 95 rbs 2006-01-04 04:12:16 PST
re: Comment #93 and Comment #94

As you guessed, these are poor markups (discrepancies in the authoring side), as opposed to being bugs in the MathML renderer itself. Per the spec, <mi> is rendered in italics if its textual content consists of a _single_ character, otherwise it is rendered upright, unless overriden by a style instruction.
Comment 96 Matt Whitlock 2006-03-03 10:24:06 PST
Created attachment 213905 [details]
Severely broken text height calculations

Firefox 1.5.0.1 on Gentoo Linux; X.org X11 6.8.2; KDE 3.5.1

font.mathfont-family = CMSY10, CMEX10, Mathematica1, Mathematica2, Mathematica4

Output from fc-list includes but is not limited to:
cmsy10:style=Regular
cmex10:style=Regular
Mathematica1:style=Regular
Mathematica2:style=Regular
Mathematica4:style=Regular

These files do exist:
/usr/share/fonts/texcm-ttf/cmsy10.ttf
/usr/share/fonts/texcm-ttf/cmex10.ttf
/usr/share/fonts/mathematica-fonts/Mathematica1.ttf
/usr/share/fonts/mathematica-fonts/Mathematica2.ttf
/usr/share/fonts/mathematica-fonts/Mathematica4.ttf
Comment 97 George N. White III 2006-03-03 11:26:47 PST
(In reply to comment #96)
> Created an attachment (id=213905) [edit]
> Severely broken text height calculations
> 
> Firefox 1.5.0.1 on Gentoo Linux; X.org X11 6.8.2; KDE 3.5.1

Similar problems on Debian Linux:
Firefox:  Debian/1.5.dfsg+1.5.0.1-3,
X.org X11: 6.9.0dfsg.1-4
KDE 3.5.1

but looks OK on Windows XP (Firefox 1.5.0.1)
Comment 98 Dennis 2006-09-17 05:11:02 PDT
Created attachment 238882 [details]
The absolute value signs do not render properly.

The attached picture shows absolute value and determinant (from the MathML Torture Test) rendering incorrectly when I install cmex10.ttf, cmmi10.ttf, cmr10.ttf, and cmsy10.ttf

Alternatively, I can NOT install these four fonts, in which case the absolute value renders well, but the minus sign does not appear.

Changing user.js does not seem to matter.

I am running Camino and Firefox (both had the same results) in OSX.4.7
Comment 99 rbs 2006-09-17 07:46:00 PDT
re:  Comment #98

This pref should resolve the problem:
user_pref("font.mathfont-family", "Math1, Math2, Math4");

You can set the pref with about:config. Once there, just popup the contextmenu and create a new pref entry with name: font.mathfont-family (no quotes) and value:
Math1, Math2, Math4
Comment 100 Dennis 2006-09-20 22:03:15 PDT
Unfortunately, I had already added
        user_pref("font.mathfont-family", "Math1, Math2, Math4"); 
And, like I said, turning off the computer-modern fonts solves the absolute value problem, but creates the famous no minus sign problem.

Of course, I did the following (which may be wrong):
        user_pref("font.mathfont-family.\u2212.base", "Times");

Both Camino and Firefox change \u2212 to some garble when I check the pref file again (or look it up in about:config). They persist in not rendering the - sign

I also tried:
        user_pref("font.mathfont-family.\u02212.base", "Times");
and I also tried changing "Times" to several other options.
Comment 101 rbs 2006-09-21 00:15:06 PDT
> Of course, I did the following (which may be wrong):
>        user_pref("font.mathfont-family.\u2212.base", "Times");

Try instead:
         user_pref("font.mathfont-family.\\u2212.base", "Times");
Comment 102 Dennis 2006-09-28 12:11:35 PDT
Adding the extra slash in the user pref DID solve the problem. However, the following may be a more robust multi-purpose solution for all users, best I can tell:
            user_pref("font.mathfont-family.\\u2212.base",
                   "Symbol, Courier New, Courier, Times");

Can this line be made a standard preference in all installs/updates until
the Stix fonts render all of this bogus anyway?

I chose the order above due to wanting a solution that prioritizes:
1. a WIDE minus sign. (Times makes a yucky one)
2. Symbol font (apparently Mozilla doesn't believe that the
   Symbol font DOES HAVE the minus sign. BIZARRE!)

What do you think?

Thanks for your help so far, by the way. You are very dedicated to making
MathML work for the average user. I am not a programmer, but I am an above average user, and I think average users would find these little things mind-boggline and have no recourse.
Comment 103 rbs 2006-09-28 15:00:31 PDT
Re: Comment #90

> Gaps in stretchy characters have been fixed in bug 307157 and bug 311046.
> The problems with 2061 (ApplyFunction) and 2062 (Invisible Times) were also
> fixed in bug 306543.
>
> All these fixes will be in Gecko 1.8-based browsers such as Firefox 1.5.

I had to temporarily undo this on the 1.8 branch because it caused an obscure, yet serious bug on Linux, bug 321994 - "Firefox doesn't display pages containing MathML", which is still under investigation.
Comment 104 rbs 2006-09-28 22:17:43 PDT
Re: Comment #102

Filed bug 354785 to consider it.
Comment 105 hikuiishi 2006-11-20 08:56:25 PST
Created attachment 246031 [details]
roots rendered as black boxes in #13 of the mathml trouble demos

this is a screen shot of the roots being rendered incorrectly on firefox 2.0 running winxp sp2.  the text of the roots drop to the below the roots and the horizontal lines are replaced by black boxes.
Comment 106 Julian Gilbey 2007-02-14 01:43:52 PST
I'm stumped.  I cannot find any way to get Firefox to load the Symbol font, despite having tried the advice in #90 of bug 128153 (adding aliasing to .fonts.conf).  fc-match --verbose Symbol finds the URW Symbol font, and it is accessed by Mozilla (ls -lu), but I still get the MathML error message (Symbol font not found), and my square roots are not rendered, summation signs and overbraces etc are rendered incorrectly too.

Any suggestions what I could try next?  Using version 2.0.0.1 on Debian....

Thanks!
Comment 107 Bill Gianopoulos [:WG9s] 2008-01-05 16:49:26 PST
Have you tried putting the files in ~/.fonts?
Comment 108 David Goldsmith 2008-02-27 11:31:17 PST
Experiencing same version of problem as Attachment 246031 [details].  I see that it appears to be a very recalcitrant bug.
Comment 109 Julian D. A. Wiseman 2008-04-05 13:02:01 PDT
Firefox 2.0.0.13, Macintosh, similar problem to #105 above. 

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13
Comment 110 cloos 2008-05-06 13:13:03 PDT
I just gave http://www.mozilla.org/projects/mathml/demo/texvsmml.xhtml a test in my usual (seamonkey) profile and a couple of different ff profiles.  All on 32-bit Linux.

My seamonkey profile uses just my fonts; everything was OK there.

But all of the ff profiles — including a new one I created just for a test, which had everything left at default — all of the letters were rendered as Greek rather than Latin.  Otherwise they were OK.

I have all of the mathml fonts installed; both the old dist and the Styx fonts.
Comment 111 Joe Java 2008-05-14 09:11:51 PDT
looking at http://www.mozilla.org/projects/mathml/demo/texvsmml.xhtml 
with both 20080504 builds for windows and OS X, the sigma and integral signs are too small in tests 10, 12, 16, and 17.  On test 23 the right hand bracket is too close (see the j in the lower right hand side).  
Comment 112 Joe Java 2008-12-19 13:37:49 PST
The MathML torture page at:
http://www.mozilla.org/projects/mathml/demo/texvsmml.xhtml

Needs to update the DTD.

The DTD it is using now:

<!DOCTYPE html
    PUBLIC "-//W3C//DTD XHTML 1.1 plus MathML 2.0//EN"
           "http://www.w3.org/TR/MathML2/dtd/xhtml-math11-f.dtd"

was recommended in the old:

Mathematical Markup Language (MathML) Version 2.0
W3C Recommendation 21 February 2001
Section: A.2 MathML as a DTD Module

instead of using the latest: 

Mathematical Markup Language (MathML) Version 2.0 (Second Edition)
W3C Recommendation 21 October 2003
Section: A.2.3 MathML as a DTD Module 

which recommends:

<!DOCTYPE html
    PUBLIC "-//W3C//DTD XHTML 1.1 plus MathML 2.0//EN"
           "http://www.w3.org/Math/DTD/mathml2/xhtml-math11-f.dtd"

Note that the location of the file xhtml-math11-f.dtd is in a new location.

This is: 
Bug 448509 -  Make http://www.mozilla.org/projects/mathml/demo/texvsmml.xhtml CSS validate
Comment 113 石庭豐 (Seak, Teng-Fong) 2010-12-30 08:02:23 PST
For test #10, those two lines under the summation symbol are achieved using a fraction.  But IMO, a natural (or even a correct) way is to use a matrix (table).  The "torture" isn't severe enough :)

Really, to be honest to Mozilla itself, a matrix should be used.
Comment 114 Frédéric Wang (:fredw) 2011-01-02 07:26:52 PST
(In reply to comment #111)
(In reply to comment #112)
The bugs about the size of sums/integrals as well as the DTD are now fixed. I suppose the bug with the "j" in mtable is the same as bug 415413 (attachment 306114 [details]).

(In reply to comment #113)
I agree that a mtable should be used. The spec says "The mfrac element is used for fractions. It can also be used to mark up fraction-like objects such as binomial coefficients and Legendre symbols."

---

I attach a patch fixing some errors in the MathML markup:
- Test 14: use &#x3C6; instead of &phiv; (which is really supposed to map to &#x3D5;)
- Test 17: the D in subscript ("domain" of integration) should correspond to the set of the two integrals, not only a single one. I've also replaced these integrals by a "double" integral.
- Test 16, 17: I've splitted the "dx", "dy", "dt" into two <mi/>'s (differential and variable). However, I've keeped the "d" instead of a "double-struck d" as it has been discussed elsewhere.
Comment 115 Frédéric Wang (:fredw) 2011-01-02 07:27:26 PST
Created attachment 500672 [details] [diff] [review]
Fixes some errors
Comment 116 Gary 2011-01-29 08:53:53 PST
Firefox 4 in 2011 MathML issues.

Tests 19 through 22 do not render the MathML properly in firefox4b11pre (2011-01-29 build)

https://picasaweb.google.com/lh/photo/i6iTsRqd1rRnT-fow6dm7Q?feat=directlink
http://is.gd/8KKDeL

Debian GNU/Linux 6.0 64 bit
Comment 117 Bill Gianopoulos [:WG9s] 2011-01-29 09:12:12 PST
(In reply to comment #116)
> Firefox 4 in 2011 MathML issues.
> 
> Tests 19 through 22 do not render the MathML properly in firefox4b11pre
> (2011-01-29 build)
> 
> https://picasaweb.google.com/lh/photo/i6iTsRqd1rRnT-fow6dm7Q?feat=directlink
> http://is.gd/8KKDeL
> 
> Debian GNU/Linux 6.0 64 bit

Please refer to this webpage for instructions on what fonts need to be installed for MathML to work properly with Firefox 4 beta releases.

https://developer.mozilla.org/en/Mozilla_MathML_Project/Fonts
Comment 118 Gary 2011-01-29 14:41:07 PST
(In reply to comment #117)
> (In reply to comment #116)
> > Firefox 4 in 2011 MathML issues - Debian GNU/Linux 6.0 64 bit

Thanks Bill, fixed my problem and inspired a post:

http://gnubyexample.blogspot.com/2011/01/firefox4-and-mathml-firefox-needs-font.html
Shortened: http://goo.gl/VtUi4

For Debian based distributions everything should already be prepackaged and ready to go, as shown in my article.
Comment 119 Karl Tomlinson (ni?:karlt) 2011-06-26 16:20:48 PDT
Comment on attachment 500672 [details] [diff] [review]
Fixes some errors

I tend to think of the differential d as an operator rather than an identifier.

There is some support for that 
http://opus4.kobv.de/opus4-zib/files/797/ZR-04-22.pdf
http://www-sop.inria.fr/apics/tralics/doc-d.html#cmd-DifferentialD
http://markmail.org/message/glymqm7rjb5gyk5p#query:+page:1+mid:esv6srqrq5dyq74x+state:results

But David Carlisle uses the identifier:
http://markmail.org/message/glymqm7rjb5gyk5p#query:+page:1+mid:wtqiggvnsybiphkp+state:results

so I don't mind.
Comment 120 Joe Java 2011-06-27 13:05:27 PDT
In reference to comment #119

differentiable d is short for differentiable operator.
See 
http://en.wikipedia.org/wiki/Differential_operator

it is most definitely an operator.
Comment 121 Karl Tomlinson (ni?:karlt) 2011-07-10 18:55:48 PDT
Comment on attachment 500672 [details] [diff] [review]
Fixes some errors

http://viewvc.svn.mozilla.org/vc?view=revision&revision=92374
Comment 122 Karl Tomlinson (ni?:karlt) 2011-07-10 18:59:38 PDT
I switched the differential d to operator mo instead of identifier mi.

http://viewvc.svn.mozilla.org/vc?view=revision&revision=92375

I choose mathvariant="italic" to match the LaTeX it is compared with even though some authors use an upright d.
http://en.wikipedia.org/wiki/Integral#Terminology_and_notation
http://en.wikipedia.org/wiki/Variable_of_integration

I'll close this bug as there is too much here to work out what has been fixed and what hasn't.  New bugs can be opened for remaining issues.
Comment 123 Frédéric Wang (:fredw) 2011-07-11 09:58:07 PDT
(In reply to comment #122)
> I switched the differential d to operator mo instead of identifier mi.
> 
> http://viewvc.svn.mozilla.org/vc?view=revision&revision=92375
> 
> I choose mathvariant="italic" to match the LaTeX it is compared with even
> though some authors use an upright d.

In that case, I think we should also set the space around the operator, otherwise it will be thickmathspace when bug 662756 is fixed.

> 
> I'll close this bug as there is too much here to work out what has been
> fixed and what hasn't.  New bugs can be opened for remaining issues.

This bug is still referred on the MathML Torture page. We should update the link "report rendering errors on the demos.", for example to allow users to open a new bug in the MathML component.
Comment 124 Karl Tomlinson (ni?:karlt) 2011-07-11 15:24:46 PDT
(In reply to comment #123)
> In that case, I think we should also set the space around the operator,
> otherwise it will be thickmathspace when bug 662756 is fixed.

I think it's worth setting the default spacing for operator "d" (and its variant characters, I guess) in the operator dictionary.

> This bug is still referred on the MathML Torture page. We should update the
> link "report rendering errors on the demos.", for example to allow users to
> open a new bug in the MathML component.

Oh.  Yes, sounds good.

Note You need to log in before you can comment on or make changes to this bug.