Closed Bug 1202553 Opened 4 years ago Closed 4 years ago

Drag and drop addresses between different address books and Mailing lists fails

Categories

(SeaMonkey :: MailNews: Address Book & Contacts, defect)

SeaMonkey 2.35 Branch
defect
Not set

Tracking

(seamonkey2.38 affected, seamonkey2.39 fixed, seamonkey2.40 fixed)

RESOLVED FIXED
seamonkey2.39
Tracking Status
seamonkey2.38 --- affected
seamonkey2.39 --- fixed
seamonkey2.40 --- fixed

People

(Reporter: TestObb-SW15, Unassigned)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 SeaMonkey/2.35
Build ID: 20150827182544

Steps to reproduce:

I wanted to move adresses from one to another adressbook


Actual results:

not allowed sign, when moving single adress to another adressbook by copy and paste


Expected results:

normal function as in Version 2.33
Severity: normal → enhancement
Component: General → MailNews: Address Book & Contacts
Same problem with SM 2.38B1, tested in safe mode.

Errors at the Error Console:

- when select a contact in a address book

Error: ReferenceError: kAllDirectoryRoot is not defined
Source File: chrome://messenger/content/addressbook/abResultsPane.js
Line: 423
Error: An error occurred updating the cmd_newlist command: [Exception... "[JavaScript Error: "kAllDirectoryRoot is not defined" {file: "chrome://messenger/content/addressbook/abResultsPane.js" line: 423}]'[JavaScript Error: "kAllDirectoryRoot is not defined" {file: "chrome://messenger/content/addressbook/abResultsPane.js" line: 423}]' when calling method: [nsIController::isCommandEnabled]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://global/content/globalOverlay.js :: goUpdateCommand :: line 80"  data: yes]
Source File: chrome://global/content/globalOverlay.js
Line: 85

- when drag and drop this contact to another address book or mailing list:
Error: ReferenceError: kAllDirectoryRoot is not defined
Source File: chrome://messenger/content/addressbook/abDragDrop.js
Line: 103
Tested with SM 2.39a1 (Xubuntu 14.04), it works. No problem drag-n-drop a contact to another address book or mailing list.
as you could see the failure is in 2.35, 2.39 is an Alpha version!
OS: Unspecified → Windows 7
Hardware: Unspecified → All
Correct spelling really eases finding DUPs ;-)
Summary: Moving adresses between different adressbooks → drag and drop addresses between different address books fails
Yes, I see the failure in 2.35, same behavior and errors obtained with 2.38b1.
The failure has been tested in 2.35 and 2.38b1 (xubuntu 14.04) with User agent: Mozilla/5.0 (X11; Linux i686; rv:41.0) Gecko/20100101 Firefox/41.0 SeaMonkey/2.38.
REPRODUCIBLE with  German SeaMonkey 2.38b1  (Windows NT 6.1; WOW64; rv:41.0)  Gecko/20100101 Firefox/41.0 Build 20150904215228  (Classic Theme) on German WIN7 64bit
"Bug 1203854 - drag and drop of address to other address book fails" contains some additional information concerning affected Versions
Duplicate of this bug: 1203854
Hm, I think "enhancement" was accidentally - this one is a regression, and adding collected addresses to address books is not an unimportant function
Severity: enhancement → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
I am not sure what to make of any of these comments.  As I said, I researched this matter and there were several people who came up with this CTL solution over the years.  I tried it and it would not work at all....I got the prohibited indicator all the time....If I used a version prior to 2.35, then it worked again normally.   In my mail area I am able to drag and drop emails into categories I have created under the IN BOX ..so drag and drop does still function moving mail from the in box to sub categories I have created ...  It is the address book that no longer allows drag and drop.  Something is very wrong in that it is not my some quirk in my computer but a repeatable error and repeatable success in SeaMonkey by changing versions.  

So this is NOT resolved by any stretch of the imagination though it might be OK in your German version to use the CTL function meaning something IS wrong anyway even if your German version if you are now forced to use the CTL key to drag and drop.  That should not be necessary.
@anthony1947@sbcglobal.net
Please stop commenting, everything is clear.
Duplicate of this bug: 1204219
The term kAllDirectoryRoot came in with http://hg.mozilla.org/comm-central/rev/66e1d27612ea on 2015-08-05 as solution for bug 1143812. Therefore CC-ing :aceman

(In reply to Pololo from comment #2)
> Tested with SM 2.39a1 (Xubuntu 14.04), it works. 
Are you sure? I'm wondering which code change made this possible. Also: Where can I download Window versions now?

(In reply to Rainer Bielefeld from comment #4)
Contacts can't be dragged within one Address Book too.
OS: Windows 7 → All
Summary: drag and drop addresses between different address books fails → Can't drag and drop Contacts in Address Book any more
(In reply to :Hb from comment #12)
> Are you sure? 
Absolutely (for 2.40)

> Where can I download Window versions now?
What version do you want to test - 2.40 yo can find at <http://www.seamonkey-project.org/dev/nightly>
doesn't work in 2.38b1 beta and somebody needs to fix that before it goes as an official update....this is a very bad problem since it NEVER existed before 2.35.
Ian, I thought this was already noticed and fixed in Seamonkey. Is this a dupe or is this a new place that needs fixing?

The constant is defined in abCommon.js both in TB and SM, and also in /mailnews.  I can't reproduce the bug in TB trunk.
Flags: needinfo?(iann_bugzilla)
not fixed despite relying on the CTL function to drag and drop meaning you should not even have to do that to drag and drop... THIS IS NOT FIXED DESPITE easy to find solutions all over the place re this problem...it is NOT resolved and NOT fixed for Win 7  64 bit Home edition...
Also works fine with  en-US SeaMonkey 2.40a1 Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0 from official download area)  Gecko/20150813070342  Firefox/ 43.0  Build 20150908212008  (Classic Theme) on German WIN7 64bit, so problem seems to have been fixed or has vanished. So WFM, TM 2.39 due to Comment 2

@all: Please feel free to reopen this Bug if it reappears for you with a Version later than the one mentioned above in this comment. 

(In reply to :Hb from comment #12)
> Contacts can't be dragged within one Address Book too.

I think that's by design, addresses are sorted, I doubt that there is a way to drag and drop in an unsorted address-book - and for what should that be good?
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Summary: Can't drag and drop Contacts in Address Book any more → Drag and drop addresses between different address books and Mailing lists fails
Target Milestone: --- → seamonkey2.39
> so problem seems to have been fixed or has vanished. 

Please take only official releases into account for this conclusion.  The bug was filed and confirmed against the current version 2.35.  So a WFM for a possible future release can't be the correct solution now.  Perhaps Ian is going to push a patch for the upcoming 2.38 release.  He can only do this when this bug is open.

> I think that's by design, addresses are sorted, I doubt that there is a way to drag and drop in an unsorted address-book ...

You should be able to drag contacts from an address book into mailing lists within the same address book.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Just to confirm, I just noticed the inability to move contacts from one address book to another in SM 2.35 (Win7). Drag and drop no longer works. Dropping a contact results in the "Not Available" symbol showing when the contact is moved to another address book.
Just updated to SeaMonkey 2.38 - this highly annoying bug is still present...
status-seamonkey2.38:affected
status-seamonkey2.39:unaffected
status-seamonkey2.40:unaffected

You´ll have to wait till 2.39 has been released!
Seamonkey 2.38 french : affected

seamonkey 2.41a1 (english :-/ )
Yes, the fix which is in bug 1143812 only landed on 2.39 and above.
Flags: needinfo?(iann_bugzilla)
Version 2.39 (german) o.k.
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → INVALID
This was a valid bug report, so WFM more appropriate
<https://developer.mozilla.org/en-US/docs/What_to_do_and_what_not_to_do_in_Bugzilla#Resolving_bugs_as_WORKSFORME>
Resolution: INVALID → WORKSFORME
Fixed with http://hg.mozilla.org/comm-central/rev/66e1d27612ea (original for bug 1143812).
Resolution: WORKSFORME → FIXED
Great to know the fix.
You need to log in before you can comment on or make changes to this bug.