Startup warning: While creating services from category 'profile-after-change', service for entry 'Sapi Speech Synth', contract ID '@mozilla.org/synthsapi;1' does not implement nsIObserver

RESOLVED FIXED in Firefox 45

Status

()

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Gijs, Assigned: m_kato)

Tracking

Trunk
mozilla45
Points:
---

Firefox Tracking Flags

(firefox43 affected, firefox45 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

3 years ago
I see this on my Windows 8.1 machine every day, and I'm wondering what's breaking. Maybe related to / dupe of bug 1080863 ?
Flags: needinfo?(m_kato)
(Reporter)

Comment 1

3 years ago
Err, meant bug 922841.
(Assignee)

Comment 2

3 years ago
take this.
Assignee: nobody → m_kato
Flags: needinfo?(m_kato)
(Assignee)

Comment 3

3 years ago
Created attachment 8666579 [details] [diff] [review]
Add nsIObserver
(Assignee)

Comment 4

3 years ago
Created attachment 8683064 [details] [diff] [review]
Add nsIObserver
Attachment #8666579 - Attachment is obsolete: true
(Assignee)

Comment 5

3 years ago
Comment on attachment 8683064 [details] [diff] [review]
Add nsIObserver

add nsIObserver and initalize by profile-after-change
Attachment #8683064 - Flags: review?(eitan)
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1205876
Comment on attachment 8683064 [details] [diff] [review]
Add nsIObserver

Review of attachment 8683064 [details] [diff] [review]:
-----------------------------------------------------------------

One question below.

::: dom/media/webspeech/synth/windows/SapiService.cpp
@@ +369,5 @@
> +SapiService::Observe(nsISupports* aObject, const char* aTopic,
> +                     const char16_t* aMessage)
> +{
> +  if (!strcmp(aTopic, "profile-after-change")) {
> +    Init();

Is it necessary to call init here? Isn't that the job of SapiModule?
Attachment #8683064 - Flags: review?(eitan)
(Assignee)

Comment 8

3 years ago
(In reply to Eitan Isaacson [:eeejay] from comment #7)
> Comment on attachment 8683064 [details] [diff] [review]
> Add nsIObserver
> 
> Review of attachment 8683064 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> One question below.
> 
> ::: dom/media/webspeech/synth/windows/SapiService.cpp
> @@ +369,5 @@
> > +SapiService::Observe(nsISupports* aObject, const char* aTopic,
> > +                     const char16_t* aMessage)
> > +{
> > +  if (!strcmp(aTopic, "profile-after-change")) {
> > +    Init();
> 
> Is it necessary to call init here? Isn't that the job of SapiModule?

I change init to profile-after-change.  But I think that this fix cannot check Init is failed.  So I will update this.
(Assignee)

Comment 9

3 years ago
Created attachment 8687816 [details] [diff] [review]
Add nsIObserver v2
Attachment #8683064 - Attachment is obsolete: true
(Assignee)

Comment 10

3 years ago
Comment on attachment 8687816 [details] [diff] [review]
Add nsIObserver v2

Add nsIObserver simply.
Attachment #8687816 - Flags: review?(eitan)
Attachment #8687816 - Flags: review?(eitan) → review+

Comment 12

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c6cd7a6e5e09
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox45: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla45
You need to log in before you can comment on or make changes to this bug.