[New Homescreen] Can't access last page of apps

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: twen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe])

(Reporter)

Description

3 years ago
Users can't reach bottom row of apps, because when they scroll down to the bottom, scroll bar auto scroll back to the top.

note: search bar also changes size as user scrolls up and down.

[Repro Steps]:
Prereq: apply the new home screen
1. Install youtube from marketplace
2. Tap to open the game, SWOOP and wait until it finishes loading
3. Tap homescreen button
4. Scroll to the top and scroll to the bottom

[Actual Result]: 
Screen bounce back to the top as the scroll bar move to the bottom

[Expected Result]:
Scroll bar stays on bottom and screen do not scroll to the top
(Reporter)

Comment 1

3 years ago
See video 
https://youtu.be/b4kGDVVK_BY
(Reporter)

Updated

3 years ago
Blocks: 1191745
QA Whiteboard: [COM=New Homescreen]
Whiteboard: [systemsfe]
(Reporter)

Comment 2

3 years ago
Build info:

Build ID               20150909010445
Gaia Revision          e69f2c86b931b723dd405115e33a1d02e6c5f5e6
Gaia Date              2015-09-08 20:39:40
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/01ae99b53561a2c3b40533d8c1c92bd3efc42d00
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150909.002556
Firmware Date          Wed Sep  9 00:26:04 UTC 2015
Bootloader             s1

Comment 3

3 years ago
This should have been fixed with bug 1199182, I'll take a look at this after I've fixed some other blockers (if someone gets to this before me, feel free).
Summary: [New Homescreen] Auto-scroll to the top after user scroll to the bottom → [New Homescreen] Can't access last page of apps

Comment 4

3 years ago
I can't reproduce this, and a few bugs have touched this code that may fix this issue (namely bug 1199182 and bug 1207616).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.