Closed Bug 1203460 Opened 6 years ago Closed 6 years ago

Specify gtk3 library path for emulator build

Categories

(Taskcluster :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1203513

People

(Reporter: jdai, Assigned: jdai)

References

Details

Attachments

(1 file)

According to bug 1146713 comment 87, after TC install gtk3 library,  emulator/gecko build still show error. libgtk-3.so.0: cannot open shared object file: No such file or directory.
I applied Bug 1203144 and Bug 1146713 patches to verify TC emulator build is work.

Try result:
https://treeherder.allizom.org/#/jobs?repo=try&revision=2e07c1a90b7f
Attachment #8659169 - Flags: feedback?(dustin)
Summary: [TestCluster] Specify gtk3 library path for emulator build → Specify gtk3 library path for emulator build
Haha, good fix greg -- let's please don't create a Mozilla project called "TestCluster"!

To be clear, John, TaskCluster (TC) doesn't install Gtk3.  In fact, it's not "installed" at all.  Instead, the gecko build process downloads a tarball containing Gtk3 from tooltool, then unpacks that in the root of the gecko source directory.  The mozconfigs have some additional configuration to help autoconf find the library under this directory.
Comment on attachment 8659169 [details] [diff] [review]
Add gtk3 library path to TC build.

Review of attachment 8659169 [details] [diff] [review]:
-----------------------------------------------------------------

::: testing/docker/b2g-build/Dockerfile
@@ +100,5 @@
>  ENV PATH /tools/tools/buildfarm/utils:$PATH:/home/worker/bin/
>  ENV PATH /tools/gcc-4.7.3-0moz1/bin:$PATH
>  
>  # Use the libstd++ we installed over all others...
> +ENV LD_LIBRARY_PATH /tools/gcc-4.7.3-0moz1/lib64:/tools/gcc-4.7.3-0moz1/lib:/home/worker/workspace/gecko/gtk3/usr/local/lib

It feels very odd to me to be configuring build parameters in the Dockerfile, but it seems this is already occurring for two versions of gcc, so adding another path can't hurt.
Attachment #8659169 - Flags: feedback?(dustin) → feedback+
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1203513
You need to log in before you can comment on or make changes to this bug.