No such file libgtk-3.so.0 in Emulator build

RESOLVED FIXED in Firefox 43

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jdai, Assigned: jdai)

Tracking

unspecified
mozilla43
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 fixed)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Assignee

Description

4 years ago
According to bug 1146713 comment 118, we got an error show /builds/slave/b2g_try_emu_dep-00000000000000/build/gaia/b2g_sdk/43.0a1-2015-08-17-15-02-06/b2g/xpcshell: error while loading shared libraries: libgtk-3.so.0: cannot open shared object file: No such file or directory in buildbot Emulator ICS build.
Assignee

Comment 1

4 years ago
I applied Bug 1203144 and Bug 1146713 patches to verify ICS emulator build is work.
Try link:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=a03487a48b35
Attachment #8659240 - Flags: feedback?(garndt)
Comment on attachment 8659240 [details] [diff] [review]
Add LD_LIBRARY_PATH in ICS Emulator build script.

Review of attachment 8659240 [details] [diff] [review]:
-----------------------------------------------------------------

I like this patch a lot better than the one in bug 1203460 :)  Do they accomplish the same thing?
Attachment #8659240 - Flags: feedback+
Comment hidden (obsolete)
Comment on attachment 8659240 [details] [diff] [review]
Add LD_LIBRARY_PATH in ICS Emulator build script.

I'm not as familiar with mozharness, but this seems to accomplish what you're looking for.
Attachment #8659240 - Flags: feedback?(garndt) → feedback+
Please ignore comment 3
Status: NEW → ASSIGNED
Flags: needinfo?(jdai)
Assignee

Comment 6

4 years ago
(In reply to Dustin J. Mitchell [:dustin] from comment #2)
> Comment on attachment 8659240 [details] [diff] [review]
> Add LD_LIBRARY_PATH in ICS Emulator build script.
> 
> Review of attachment 8659240 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I like this patch a lot better than the one in bug 1203460 :)  Do they
> accomplish the same thing?

Yes, they are trying to accomplish the same thing. I will merge them into one patch. Thanks for your suggestion.
Summary: No such file libgtk-3.so.0 in Emulator ICS build → No such file libgtk-3.so.0 in Emulator build
Assignee

Updated

4 years ago
Duplicate of this bug: 1203460
Assignee

Updated

4 years ago
Attachment #8659788 - Attachment description: Add LD_LIBRARY_PATH in Emulator build script. → Add LD_LIBRARY_PATH in Emulator build script. v2
Comment on attachment 8659788 [details] [diff] [review]
Add LD_LIBRARY_PATH in Emulator build script. v2

Review of attachment 8659788 [details] [diff] [review]:
-----------------------------------------------------------------

::: testing/mozharness/scripts/b2g_build.py
@@ +539,5 @@
>                  cmd.append('-j{0}'.format(multiprocessing.cpu_count()))
>              cmd.append(target)
>          return cmd
>  
> +    def link_gtk3(self):

It might be worth calling this "symlink_gtk3" -- we're talking about linker configuration, so "link" is ambiguous.
Attachment #8659788 - Flags: review?(dustin) → review+
Assignee

Comment 10

4 years ago
Address comment 9.
Attachment #8659788 - Attachment is obsolete: true
Attachment #8660530 - Flags: review+
Assignee

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d60ded826635
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla43
Assignee

Updated

4 years ago
See Also: → 1204822
Hey,

I don't follow why we're not simply forwarding LD_LIBRARY_PATH ? I see the patch also tries to find another path for gtk3, but indeed it should already be in LD_LIBRARY_PATH set by the tooltool tool, right ?
Flags: needinfo?(jdai)
tooltool doesn't set LD_LIBRARY_PATH.  Tooltool is a tool for downloading (and unpacking) tarballs.
That case is a little bit different since we found that there are three kinds of machine envs.

env LD_LIBRARY_PATH=/tools/gcc-4.7.3-0moz1/lib64:/tools/gcc-4.7.3-0moz1/lib

it's hardcoded inside dockerfile for taskcluster machine (b2g-desktop, emulator-kk, emulator-jb and emaulator-l...etc. However, we're still use old machine for emulator-ics.

So instead of hardcode it in dockerfile, the final solution was that set LD_LIBRARY_PATH in testing/mozharness/scripts/b2g_build.py
Flags: needinfo?(jdai)
You need to log in before you can comment on or make changes to this bug.