Last Comment Bug 1203697 - Panning right with a braille display should eventually navigate to the next item
: Panning right with a braille display should eventually navigate to the next item
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: Unspecified Unspecified
-- normal (vote)
: Firefox 43
Assigned To: Eitan Isaacson [:eeejay]
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on: 1182222
Blocks: AndroidA11yUpdates
  Show dependency treegraph
 
Reported: 2015-09-10 13:27 PDT by Eitan Isaacson [:eeejay]
Modified: 2015-09-15 06:08 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Add braille navigation. (7.44 KB, patch)
2015-09-10 13:51 PDT, Eitan Isaacson [:eeejay]
no flags Details | Diff | Splinter Review
Add braille navigation. (7.57 KB, patch)
2015-09-14 10:51 PDT, Eitan Isaacson [:eeejay]
yzenevich: review+
mark.finkle: review+
Details | Diff | Splinter Review

Description User image Eitan Isaacson [:eeejay] 2015-09-10 13:27:00 PDT

    
Comment 1 User image Eitan Isaacson [:eeejay] 2015-09-10 13:30:13 PDT
STR:

1. Enable Talkback and Brailleback (I use the debug on-screen braille display option).
2. Go to a web page, navigate with Talkback to a heading, either with swipe or explore by touch.
3. In the braille display, press the right button to scroll through the full text of the heading.
4. After reaching the end of the text, another press of the button does nothing.

Expected:

Pressing the button again should bring you to the next item.
Comment 2 User image Eitan Isaacson [:eeejay] 2015-09-10 13:51:31 PDT
Created attachment 8659479 [details] [diff] [review]
Add braille navigation.
Comment 3 User image Eitan Isaacson [:eeejay] 2015-09-10 13:52:33 PDT
This patch depends on the patch in bug 1182222, that makes our web view an official android a11y web view.
Comment 4 User image Marco Zehe (:MarcoZ) 2015-09-11 05:01:06 PDT
Comment on attachment 8659479 [details] [diff] [review]
Add braille navigation.

OK, something weird is going on here. it pans to a next and previous item, but it's not the next or previous item one would swipe to. Instead, the Android Section rule or something similar seems to be applied. I tried this page:

https://support.mozilla.org/en-US/kb/how-use-talkback-support-firefox

1. I then start from somewhere at the top, for example by touching the heading in the main section "How to use TalkBack support in Firefox for Android for accessibility".

2. I pan through this heading without problems.
3. Next pan brings me to the next element, but TalkBack reads the whole huge bunch, as if it was all just one big thing lumped together, including the table of contents and other items. So it doesn't move to the paragraph that follows the heading, but to the container that encompasses it.
4. When I get to the end of the paragraph, and pan right, I land on the "Share this page" heading way down at the bottom.
5. If I pan left, I land back on the start of step 3, not the just previous section or item.
6. Similarly, if I touch somewhere within the main article, for example on some link in the Table Of Contents, and then pan right, I land on "Share this page", as in step 4. If I pan left, I land at the beginning of the main content, below the heading, as in step 3.

It would appear that panning, when it should traverse to the next or previous element, uses the wrong granularity somehow. Normal swiping on the touch screen works as expected.

This is all with the test build you sent me, Eitan.
Comment 5 User image Yura Zenevich [:yzen] 2015-09-11 11:20:47 PDT
Comment on attachment 8659479 [details] [diff] [review]
Add braille navigation.

Review of attachment 8659479 [details] [diff] [review]:
-----------------------------------------------------------------

removing the flag since Marco's noticing some weirdness, question inline.

::: accessible/jsat/AccessFu.jsm
@@ +866,1 @@
>          this.moveCursor('move' + aDetails.direction, 'Paragraph', 'gesture');

Just based on Marco's feedback do we need a Line traversal rule by any chance?
Comment 6 User image Eitan Isaacson [:eeejay] 2015-09-14 09:38:15 PDT
I am going to use the Simple traversal rule in the next patch. I think that is what Marco was expecting anyway.
Comment 7 User image Eitan Isaacson [:eeejay] 2015-09-14 10:51:09 PDT
Created attachment 8660844 [details] [diff] [review]
Add braille navigation.

Changed rule to Simple, it should be a lot simpler now :)
Comment 8 User image Mark Finkle (:mfinkle) (use needinfo?) 2015-09-14 11:01:06 PDT
Comment on attachment 8660844 [details] [diff] [review]
Add braille navigation.

Code looks fine to me
Comment 9 User image Yura Zenevich [:yzen] 2015-09-14 11:47:33 PDT
Comment on attachment 8660844 [details] [diff] [review]
Add braille navigation.

Review of attachment 8660844 [details] [diff] [review]:
-----------------------------------------------------------------

looks good
Comment 11 User image Carsten Book [:Tomcat] 2015-09-15 06:08:59 PDT
https://hg.mozilla.org/mozilla-central/rev/b10bb607c2f0

Note You need to log in before you can comment on or make changes to this bug.