Statistics stopped for all my products as of 7th September

RESOLVED FIXED

Status

defect
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: davewhiting, Assigned: jason)

Tracking

Details

Reporter

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150826023504

Steps to reproduce:

Statistics on all my addons have stopped since the 7th of September
https://addons.mozilla.org/en-US/firefox/addon/googleuk/statistics/?last=7

The same for all my other addons.
Yeah, looks like all add-ons are affected:
https://addons.mozilla.org/addon/adblock-plus/statistics/?last=30
Status: UNCONFIRMED → NEW
Ever confirmed: true
:jason, do you see anything strange regarding the stats? Maybe the scripts not running, or the queries not completing on hive?
Flags: needinfo?(jthomas)
Duplicate of this bug: 1204315
Assignee

Updated

4 years ago
Depends on: 1203293
Flags: needinfo?(jthomas)
Assignee

Comment 5

4 years ago
(In reply to Mathieu Agopian [:magopian] from comment #3)
> :jason, do you see anything strange regarding the stats? Maybe the scripts
> not running, or the queries not completing on hive?

Yes, the script is failing to run on hive. Bug 1203293 filed requesting assistance from the Metrics team.

Comment 6

4 years ago
Are any news about fixing this bug? 
Is it really soooooo hard and complicated?
Duplicate of this bug: 1206408
Assignee

Comment 8

4 years ago
I've started the stats backfill process. It will take a while to complete but we should start seeing updates on the stats pages within the next few hours. I will update the bug once the backfill process is completed. Thanks for the patience.
Reporter

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 9

4 years ago
there are still plenty of missing stats...
Assignee

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Assignee

Updated

4 years ago
Assignee: nobody → jthomas
Status: REOPENED → ASSIGNED
Assignee

Comment 10

4 years ago
The backfill process has not completed yet. Let's keep this bug open until it is completed.
Assignee

Comment 11

4 years ago
Backfill process is done.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED

Comment 12

4 years ago
> Resolution: --- → FIXED
Backfill really fixed. But what about live data? 
Statistic on my page https://addons.mozilla.org/en-US/firefox/addon/restyler/statistics/?last=30
stopped on 21.05.2015 - seems it's the last backfilled date. But after it no more fresh data (
Assignee

Updated

4 years ago
Depends on: 1207800
Assignee

Comment 13

4 years ago
The daily updates to stats was failing and fixed in bug 1207800. I've backfilled 2015.09.22 and 2015.09.23 is being processed now. Tomorrow's stats processing jobs should work as expected.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.