[Contacts]It always prompts "Imported X contacts. contactsMerged" from a vcard so user don't know how many contacts are merged after importing.

VERIFIED FIXED in Firefox OS master

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Shally Li(leave from Mozilla), Assigned: fcampo)

Tracking

({regression})

unspecified
FxOS-S8 (02Oct)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 disabled, b2g-master verified)

Details

(Whiteboard: [NG Gaia Contacts][2.5-aries-test-run-2][patch])

Attachments

(5 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
[Aries KK v2.5][Flame KK v2.5][Email] When importing contacts from email or importing them again, it always prompts "Imported 12 contacts. contactsMerged". From the prompt words "contactsMerged", so user doesn't know how many contacts were merged.

Found time: 01:45
Attachments: logcat_0145.txt and Aries_v2.5.3gp.
Test file: 2015_9_9_12.vcf or 2015_9_9_10.vcf

[2.Testing Steps]: 
1. Receive a email with a vcard with 12 contacts.
2. Download and open the vcard file.
3. Tap "Import all" icon.
4. Open the .vcf file and tap "Import all" again.

[3.Expected Result]: 
Step 3. It should prompt "Imported 12 contacts." or "Imported 12 contacts. No duplicated contacts merged".
Step 4. It should prompt "Imported 12 contacts. 12 contacts merged".

[4.Actual Result]: 
Step 3 & step 4. Contacts are imported successfully, but it always prompts "Imported 12 contacts. contactsMerged". From the prompt message "contactsMerged", user don't know how many contacts are merged while importing.  And there is no space between the prompt words "contactsMerged".

[5.Reproduction build]: 
Device: Flame KK 2.2 (Disabled) 
Build ID               20150910032509
Gaia Revision          7a427e0f8aa6c185a9e22358006b97c19435ca4a
Gaia Date              2015-09-09 13:06:12
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/0d9c46d01861
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150910.070213
Firmware Date          Thu Sep 10 07:02:24 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK 2.5 (Affected)
Build ID               20150910150202
Gaia Revision          6280500a6cb8d1b178cdd163450e36d22846fbed
Gaia Date              2015-09-10 11:38:24
Gecko Revision         https://hg.mozilla.org/mozilla-

central/rev/7671701d15cadd2b343fc27685231e0689bb71df
Gecko Version          43.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150910.182915
Firmware Date          Thu Sep 10 18:29:25 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Affected)
Build ID               20150911000328
Gaia Revision          6280500a6cb8d1b178cdd163450e36d22846fbed
Gaia Date              2015-09-10 11:38:24
Gecko Revision         https://hg.mozilla.org/integration/mozilla-

inbound/rev/c0abc2a6e11f52761366e029eb1bae4c9864a8a3
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150910.232411
Firmware Date          Thu Sep 10 23:24:19 UTC 2015
Bootloader             s1


[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test

[8.Note]:
It prompts "Not enabled yet" on Flame KK v2.2.
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → disabled
status-b2g-master: --- → affected
(Reporter)

Comment 1

3 years ago
Created attachment 8659810 [details]
Aries_v2.5.3gp
(Reporter)

Comment 2

3 years ago
Created attachment 8659816 [details]
logcat_0145.txt
Looking at the video, and searching for contactsMerged in the code, this seems to be controlled by the Contacts app so switching the component to that.
Component: Gaia::E-Mail → Gaia::Contacts

Updated

3 years ago
Summary: [Email]It always prompts "Imported 12 contacts. contactsMerged", so user don't know how many contacts are merged after importing. → [Contacts]It always prompts "Imported 12 contacts. contactsMerged", so user don't know how many contacts are merged after importing.
(Assignee)

Updated

3 years ago
Assignee: nobody → fernando.campo
[Blocking Requested - why for this release]:

I think this is a regression introduced when landing the merging of #open and #import activities (bug 1184075 and bug 1184077) as part of the NGA work, as I remember seeing it working fine in master before this work.
Status: NEW → ASSIGNED
blocking-b2g: --- → 2.5?
Keywords: regression
Whiteboard: [2.5-aries-test-run-2] → [NG Gaia Contacts][2.5-aries-test-run-2]
Target Milestone: --- → FxOS-S7 (18Sep)
Summary: [Contacts]It always prompts "Imported 12 contacts. contactsMerged", so user don't know how many contacts are merged after importing. → [Contacts]It always prompts "Imported X contacts. contactsMerged" from a vcard so user don't know how many contacts are merged after importing.
Regression from 2.2, blocking.
blocking-b2g: 2.5? → 2.5+
Created attachment 8661814 [details] [review]
[gaia] fcampo:vcard-import-merged-error-1203885 > mozilla-b2g:master
(Assignee)

Comment 7

3 years ago
Created attachment 8661821 [details] [review]
Link to PR - https://github.com/mozilla-b2g/gaia/pull/31868

property name change
Attachment #8661821 - Flags: review?(francisco)
Whiteboard: [NG Gaia Contacts][2.5-aries-test-run-2] → [NG Gaia Contacts][2.5-aries-test-run-2][patch]
This issue happens in both branches, master and NGA, so leaving 2.5+ blocking flag.
Target Milestone: FxOS-S7 (18Sep) → FxOS-S8 (02Oct)
status-b2g-master: affected → fixed
Tested in latest master build (9/24) and working fine. Thanks Fernando!

Environmental Variables (9/24):
flame master (2.5 version)
Build ID: 20150924072151
Gecko: 65a0dd9
Gaia: 7e72976
Platform version: 44.0a1
(Reporter)

Comment 12

2 years ago
This bug has been verified as "pass" on the latest build of Flame KK 2.5 and Aires KK 2.5 by the STR in comment 0.

Actual results: 
Step 3. It prompts correct message "Imported 12 contacts. No duplicated contacts merged".
Step 4. It prompts correct message "Imported 12 contacts. 12 contacts merged" and the contacts are merged normally.

See attachment: verified_Aries_v2.5.3gp
Reproduce rate: 0/10


Device: Flame KK 2.5 (Pass)
Build ID               20150923150203
Gaia Revision          8472f0c736660072799aaae60e4b6001a6aaceb4
Gaia Date              2015-09-23 10:29:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/4a46de29431baa621d98d8f1168e43297ce1a916
Gecko Version          44.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150923.184655
Firmware Date          Wed Sep 23 18:47:17 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK 2.5 (Pass)
Build ID               20150923233246
Gaia Revision          8472f0c736660072799aaae60e4b6001a6aaceb4
Gaia Date              2015-09-23 10:29:02
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/f1dffc8682fbba463cb4bb305f293ddcccbc20b4
Gecko Version          44.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150923.225204
Firmware Date          Wed Sep 23 22:52:12 UTC 2015
Bootloader             s1
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-master: fixed → verified
(Reporter)

Comment 13

2 years ago
Created attachment 8665334 [details]
verified_Aries_v2.5.3gp
You need to log in before you can comment on or make changes to this bug.