Closed Bug 1205043 Opened 6 years ago Closed 6 years ago

[Browser] Control Center - Track Protection

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(feature-b2g:2.5+)

RESOLVED WONTFIX
feature-b2g 2.5+

People

(Reporter: tif, Assigned: mikehenrty)

References

Details

(Whiteboard: [systemsfe])

Within the Control Center doorhanger (also contains pin the web functionality), information about Tracking Protection is shown with a control to disable the feature.

Please see Tracking Protection meta bug for specs.
Depends on: 1207710
No longer blocks: 1180674
Blocks: 1207710
No longer depends on: 1207710
blocking-b2g: --- → 2.5+
Note there are two parts to this bug:

1.) Displaying whether Tracking Protection is on or off
2.) "Manage Setting" link that opens and activity to the "Browser Privacy" settings panel.

I was going to open up a bug for each, but I think they both can be done here.
Whiteboard: [systemsfe]
We will need bug 1205040 so that we actually have the Tracking Protection toggle in Settings to link to.
Depends on: 1205040
blocking-b2g: 2.5+ → ---
feature-b2g: --- → 2.5+
Assignee: nobody → gmarty
Duplicate of this bug: 1202591
Duplicate of this bug: 1207054
Gotta steal this one from you gmarty. I've been coordinating with Tif, epang, and kCaldwell, and we need to change the design here a little due to the pin-the-web changes. I'm going to work with Eric to come up with something tomorrow. I apologize if you've already started something :/
Assignee: gmarty → mhenretty
In the latest reduced spec, we have decided to remove the control panel drop down for 2.5.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.