Note: There are a few cases of duplicates in user autocompletion which are being worked on.

browserAction icon should match appearance of native Firefox toolbar buttons

RESOLVED DUPLICATE of bug 1329242

Status

()

Toolkit
WebExtensions: Frontend
P5
normal
RESOLVED DUPLICATE of bug 1329242
2 years ago
3 months ago

People

(Reporter: designakt, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [webextension-polish][browserAction]triaged)

(Reporter)

Description

2 years ago
To achieve that we would like devs to provide an .svg outline of their icon instead of a full color icon. This .svg will be colored by us matching the OS (currently a lighter gray on windows).

This can also be used to implement the icon highlight state (blue) we currently use in our toolbar-icons. (like bookmarks, download)

Using such an icon should be preferred by developers to best integrate their add-ons in Firefox.

Updated

2 years ago
Whiteboard: [webextension-polish] → [webextension-polish][browserAction]

Updated

2 years ago
Blocks: 1214433
Priority: -- → P4

Updated

2 years ago
Flags: blocking-webextensions+

Updated

2 years ago
Whiteboard: [webextension-polish][browserAction] → [webextension-polish][browserAction]triaged

Updated

2 years ago
Flags: blocking-webextensions+ → blocking-webextensions-

Comment 1

a year ago
A related question...
http://stackoverflow.com/questions/37366781/how-to-detect-firefox-theme

Updated

10 months ago
Component: WebExtensions: Untriaged → WebExtensions: Frontend
Flags: blocking-webextensions-
Priority: P4 → P5
Blocks: 1311472

Comment 2

3 months ago
Calling out that Screenshots will ship in 54 as a WebExtension. Currently, we our browserAction icon looks janky on dark themes.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1329242
You need to log in before you can comment on or make changes to this bug.